aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose G. Juanino <jjuanino@gmail.com>2021-11-26 13:33:26 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-11-28 17:19:09 +0000
commit01e29cd1030a7067a9908c654913f32f3cb5dcc0 (patch)
tree28f53c7c75d06d3fd6e8635b9b813294e10c4cc0
parentf5051ff5940b1fb6fd49bd5f1f63f3bdc0176d27 (diff)
downloadports-01e29cd1030a7067a9908c654913f32f3cb5dcc0.tar.gz
ports-01e29cd1030a7067a9908c654913f32f3cb5dcc0.zip
databases/powerarchitect: update to 1.0.9
ChangeLog: http://www.bestofbi.com/downloads/architect/1.0.9/ReleaseNotes.txt PR: 259684 Reported by: jjuanino@gmail.com (maintainer)
-rw-r--r--databases/powerarchitect/Makefile26
-rw-r--r--databases/powerarchitect/distinfo6
-rw-r--r--databases/powerarchitect/pkg-descr2
-rw-r--r--databases/powerarchitect/pkg-plist6
4 files changed, 21 insertions, 19 deletions
diff --git a/databases/powerarchitect/Makefile b/databases/powerarchitect/Makefile
index 2308e98bbb90..ed6177d1e3a4 100644
--- a/databases/powerarchitect/Makefile
+++ b/databases/powerarchitect/Makefile
@@ -1,11 +1,8 @@
-# Created by: Jose Garcia Juanino <jjuanino@gmail.com>
-
PORTNAME= powerarchitect
-PORTVERSION= 1.0.8
-PORTREVISION= 1
+PORTVERSION= 1.0.9
CATEGORIES= databases java
-MASTER_SITES= http://download.sqlpower.ca/architect/1.0.8/community/
-DISTNAME= SQL-Power-Architect-generic-jdbc-${PORTVERSION}
+MASTER_SITES= http://www.bestofbi.com/downloads/architect/${PORTVERSION}/
+DISTNAME= SQL-Power-Architect-generic-${PORTVERSION}
MAINTAINER= jjuanino@gmail.com
COMMENT= Data modeling and profiling tool
@@ -13,12 +10,13 @@ COMMENT= Data modeling and profiling tool
LICENSE= GPLv3
USE_JAVA= yes
+NO_ARCH= yes
NO_BUILD= yes
+SUB_FILES= ${PORTNAME}
PORTDOCS= *
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
WRKSRC= ${WRKDIR}/architect-${PORTVERSION}
-SUB_FILES= ${PORTNAME}
OPTIONS_DEFINE= DOCS MYSQL_JDBC PGSQL_JDBC
@@ -26,15 +24,17 @@ MYSQL_JDBC_RUN_DEPENDS= ${JAVALIBDIR}/mysql-connector-java.jar:databases/mysql-c
PGSQL_JDBC_RUN_DEPENDS= ${JAVALIBDIR}/postgresql.jar:databases/postgresql-jdbc
do-install:
- @${MKDIR} ${STAGEDIR}/${DATADIR}/jdbc
+ @${MKDIR} ${STAGEDIR}/${DATADIR}
(cd ${WRKSRC}/ && \
- ${INSTALL_DATA} architect.jar ${STAGEDIR}/${DATADIR}/ && \
- ${INSTALL_DATA} jdbc/sqlserver_2005.jar ${STAGEDIR}/${DATADIR}/jdbc/ && \
- ${COPYTREE_SHARE} lib ${STAGEDIR}/${DATADIR})
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}/${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} architect.jar \
+ ${STAGEDIR}/${DATADIR}/ && \
+ ${COPYTREE_SHARE} lib ${STAGEDIR}/${DATADIR})
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} \
+ ${STAGEDIR}/${PREFIX}/bin/${PORTNAME}
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}/${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.generic ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.generic \
+ ${STAGEDIR}/${DOCSDIR}
.include <bsd.port.mk>
diff --git a/databases/powerarchitect/distinfo b/databases/powerarchitect/distinfo
index d02603234702..8140c419cb90 100644
--- a/databases/powerarchitect/distinfo
+++ b/databases/powerarchitect/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1490528072
-SHA256 (SQL-Power-Architect-generic-jdbc-1.0.8.tar.gz) = 1e17e1f8b3277509d5e4e6dbc524831c7591c43b64c7f6c3b53044ebe741886b
-SIZE (SQL-Power-Architect-generic-jdbc-1.0.8.tar.gz) = 25106766
+TIMESTAMP = 1636225865
+SHA256 (SQL-Power-Architect-generic-1.0.9.tar.gz) = 2817d634965530792bf51a1d8b5d308b665915b94fa7a560612d4fbd21a6ef6f
+SIZE (SQL-Power-Architect-generic-1.0.9.tar.gz) = 27822585
diff --git a/databases/powerarchitect/pkg-descr b/databases/powerarchitect/pkg-descr
index 0bf0820ca8bb..580fb9e8d20e 100644
--- a/databases/powerarchitect/pkg-descr
+++ b/databases/powerarchitect/pkg-descr
@@ -9,4 +9,4 @@ metadata.
Plus, the Power*Architect has the ability to take snapshots of database
structures, allowing users to design DW data models while working offline.
-WWW: http://software.sqlpower.ca/page/demos
+WWW: http://www.bestofbi.com/page/architect
diff --git a/databases/powerarchitect/pkg-plist b/databases/powerarchitect/pkg-plist
index b8136c283e04..2f46646d7b98 100644
--- a/databases/powerarchitect/pkg-plist
+++ b/databases/powerarchitect/pkg-plist
@@ -1,9 +1,9 @@
bin/powerarchitect
%%DATADIR%%/architect.jar
-%%DATADIR%%/jdbc/sqlserver_2005.jar
%%DATADIR%%/lib/activation.jar
%%DATADIR%%/lib/annotations.jar
%%DATADIR%%/lib/apache-mime4j-0.6.jar
+%%DATADIR%%/lib/architecthelp.jar
%%DATADIR%%/lib/commons-beanutils-bean-collections.jar
%%DATADIR%%/lib/commons-beanutils-core.jar
%%DATADIR%%/lib/commons-beanutils.jar
@@ -21,6 +21,7 @@ bin/powerarchitect
%%DATADIR%%/lib/eigenbase-properties.jar
%%DATADIR%%/lib/forms-1.3.0.jar
%%DATADIR%%/lib/guava-11.0.2.jar
+%%DATADIR%%/lib/hamcrest-core-1.3.jar
%%DATADIR%%/lib/httpclient-4.0.jar
%%DATADIR%%/lib/httpcore-4.0.1.jar
%%DATADIR%%/lib/httpmime-4.0.jar
@@ -30,7 +31,7 @@ bin/powerarchitect
%%DATADIR%%/lib/jfreechart-1.0.1.jar
%%DATADIR%%/lib/jmdns-2.1.jar
%%DATADIR%%/lib/jsr305.jar
-%%DATADIR%%/lib/junit-3.8.2.jar
+%%DATADIR%%/lib/junit-4.12.jar
%%DATADIR%%/lib/kettle-core-3.2.2.jar
%%DATADIR%%/lib/kettle-db-3.2.2.jar
%%DATADIR%%/lib/kettle-engine-3.2.2.jar
@@ -39,6 +40,7 @@ bin/powerarchitect
%%DATADIR%%/lib/miglayout-3.7-swing.jar
%%DATADIR%%/lib/olap4j-0.9.7.302.jar
%%DATADIR%%/lib/opencsv-1.8.jar
+%%DATADIR%%/lib/osx_adapter.jar
%%DATADIR%%/lib/piccolo.jar
%%DATADIR%%/lib/piccolox.jar
%%DATADIR%%/lib/rsyntaxtextarea.jar