aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-01-26 21:45:41 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-02-14 14:27:53 +0000
commit01ef0a96665e6c379aed31910dfbdea184fd1e9b (patch)
tree933876801e7dbc2b6992427afa1422e549fc22ed
parent7b8336a02ad8cf9aae82afc1ce63984b866266ad (diff)
downloadports-01ef0a96665e6c379aed31910dfbdea184fd1e9b.tar.gz
ports-01ef0a96665e6c379aed31910dfbdea184fd1e9b.zip
x11-wm/cagebreak: add new port
This is Cagebreak, a Wayland tiling compositor. The goal of this project is to provide a successor to ratpoison for Wayland users. However, this is no reimplementation of ratpoison. Should you like to know if a feature will be implemented, open an issue or get in touch with the development team. https://github.com/project-repo/cagebreak
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/cagebreak/Makefile47
-rw-r--r--x11-wm/cagebreak/distinfo3
-rw-r--r--x11-wm/cagebreak/pkg-descr7
-rw-r--r--x11-wm/cagebreak/pkg-message9
5 files changed, 67 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 02c0f00363e4..3c2ee70e2451 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -13,6 +13,7 @@
SUBDIR += blackbox
SUBDIR += bspwm
SUBDIR += cage
+ SUBDIR += cagebreak
SUBDIR += chamfer
SUBDIR += compiz
SUBDIR += compiz-plugins-extra
diff --git a/x11-wm/cagebreak/Makefile b/x11-wm/cagebreak/Makefile
new file mode 100644
index 000000000000..8314351c5a8d
--- /dev/null
+++ b/x11-wm/cagebreak/Makefile
@@ -0,0 +1,47 @@
+PORTNAME= cagebreak
+DISTVERSION= 1.8.3
+CATEGORIES= x11-wm
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Wayland tiling compositor inspired by ratpoison
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
+ wayland-protocols>=1.14:graphics/wayland-protocols \
+ wlroots>=0.15.0<0.16.0:x11-toolkits/wlroots
+LIB_DEPENDS= libevdev.so:devel/libevdev \
+ libudev.so:devel/libudev-devd \
+ libwayland-server.so:graphics/wayland \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libwlroots.so:x11-toolkits/wlroots \
+ libinput.so:x11/libinput \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c11 gnome meson pkgconfig xorg
+USE_GITHUB= yes
+USE_GNOME= cairo pango
+USE_XORG= pixman
+GH_ACCOUNT= project-repo
+MESON_ARGS= -Dversion_override="${DISTVERSIONFULL}" # if snapshot
+PLIST_FILES= bin/${PORTNAME} \
+ etc/xdg/${PORTNAME}/config
+
+OPTIONS_DEFINE= MANPAGES X11
+OPTIONS_DEFAULT=MANPAGES X11
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_MESON_TRUE= man-pages
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz \
+ man/man5/${PORTNAME}-config.5.gz
+
+X11_MESON_TRUE= xwayland
+
+post-patch:
+# Respect PREFIX for system-wide config
+ @${REINPLACE_CMD} -e 's,/etc,${PREFIX}&,' \
+ ${WRKSRC}/${PORTNAME}.c \
+ ${WRKSRC}/meson.build
+
+.include <bsd.port.mk>
diff --git a/x11-wm/cagebreak/distinfo b/x11-wm/cagebreak/distinfo
new file mode 100644
index 000000000000..fb6b7e39dcdc
--- /dev/null
+++ b/x11-wm/cagebreak/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1643233541
+SHA256 (project-repo-cagebreak-1.8.3_GH0.tar.gz) = b90ad92927959fd0331f56282bf5839b53d27f136f74a72cbb96b563c88ce4e4
+SIZE (project-repo-cagebreak-1.8.3_GH0.tar.gz) = 135885
diff --git a/x11-wm/cagebreak/pkg-descr b/x11-wm/cagebreak/pkg-descr
new file mode 100644
index 000000000000..11314c7b9693
--- /dev/null
+++ b/x11-wm/cagebreak/pkg-descr
@@ -0,0 +1,7 @@
+This is Cagebreak, a Wayland tiling compositor. The goal of this
+project is to provide a successor to ratpoison for Wayland users.
+However, this is no reimplementation of ratpoison. Should you like to
+know if a feature will be implemented, open an issue or get in touch
+with the development team.
+
+WWW: https://github.com/project-repo/cagebreak
diff --git a/x11-wm/cagebreak/pkg-message b/x11-wm/cagebreak/pkg-message
new file mode 100644
index 000000000000..bee4ead247d9
--- /dev/null
+++ b/x11-wm/cagebreak/pkg-message
@@ -0,0 +1,9 @@
+[
+{ type: install
+ message: <<EOM
+Known issues:
+- Running X11 applications (e.g., xterm) via Xwayland is broken, see
+ https://github.com/project-repo/cagebreak/issues/23
+EOM
+}
+]