aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2022-12-16 16:20:34 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2022-12-16 16:32:16 +0000
commit023d0745ae4ea4adc4f852366af30c286ea8d60d (patch)
tree80a5e4b6aeae73a6a333d48d1c02405dbdbb5eca
parent5765ec9382b822381ab6de329704b94ba31f85fb (diff)
downloadports-023d0745ae4ea4adc4f852366af30c286ea8d60d.tar.gz
ports-023d0745ae4ea4adc4f852366af30c286ea8d60d.zip
sysutils/pot: Update to 0.15.4
Includes adding a new group "pot" which is used to grant unprivileged users access to read-only pot commands. Depend on security/signify for pot image signatures. While there, add a stub man page so users entering `man pot` see something slightly useful, readd pkg-message.in to package. Add a longer pkg-descr to make portlint happy. Approved by: pizzamig (maintainer)
-rw-r--r--GIDs2
-rw-r--r--sysutils/pot/Makefile13
-rw-r--r--sysutils/pot/distinfo6
-rw-r--r--sysutils/pot/files/pkg-message.in16
-rw-r--r--sysutils/pot/files/pot.8.in60
-rw-r--r--sysutils/pot/pkg-descr5
-rw-r--r--sysutils/pot/pkg-plist1
7 files changed, 91 insertions, 12 deletions
diff --git a/GIDs b/GIDs
index b3542b24f17c..4b9e29f03df0 100644
--- a/GIDs
+++ b/GIDs
@@ -929,7 +929,7 @@ tvheadend:*:984:
puppetdb:*:985:
kamailio:*:986:
spark:*:987:
-# free: 988
+pot:*:988:
emby:*:989:
oozie:*:990:
sguil:*:991:
diff --git a/sysutils/pot/Makefile b/sysutils/pot/Makefile
index 146852c6890e..14cf6351d17c 100644
--- a/sysutils/pot/Makefile
+++ b/sysutils/pot/Makefile
@@ -1,6 +1,5 @@
PORTNAME= pot
-DISTVERSION= 0.15.3
-PORTREVISION= 0
+DISTVERSION= 0.15.4
CATEGORIES= sysutils
MAINTAINER= pizzamig@FreeBSD.org
@@ -11,12 +10,17 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= potnet:sysutils/potnet \
- ncat:security/nmap \
- freebsd-release-manifests>0:misc/freebsd-release-manifests
+ ncat:security/nmap \
+ freebsd-release-manifests>0:misc/freebsd-release-manifests \
+ signify:security/signify
TEST_DEPENDS= flock:sysutils/flock
+GROUPS= pot
+
USE_RC_SUBR= pot pot_early
+SUB_FILES= pkg-message pot.8
+
USE_GITHUB= yes
GH_ACCOUNT= pizzamig
NO_ARCH= yes
@@ -52,6 +56,7 @@ do-install:
${STAGEDIR}${ETCDIR}/flavours
${INSTALL_SCRIPT} ${WRKSRC}/etc/pot/flavours/slim.sh \
${STAGEDIR}${ETCDIR}/flavours
+ ${INSTALL_MAN} ${WRKDIR}/pot.8 ${STAGEDIR}${MANPREFIX}/man/man8
do-install-ZSH-on:
( cd ${WRKSRC}/share/zsh && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/zsh)
diff --git a/sysutils/pot/distinfo b/sysutils/pot/distinfo
index 80e8ea688f11..811fd604195e 100644
--- a/sysutils/pot/distinfo
+++ b/sysutils/pot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1663414719
-SHA256 (pizzamig-pot-0.15.3_GH0.tar.gz) = 335572816e86aeba6e5698122339a14d74764983c3197e9899412db12e96f408
-SIZE (pizzamig-pot-0.15.3_GH0.tar.gz) = 173190
+TIMESTAMP = 1671139747
+SHA256 (pizzamig-pot-0.15.4_GH0.tar.gz) = 455dbd7939ba5b757acd0fd0980f9d522440fca5a2a9691e6623d9ec679897f5
+SIZE (pizzamig-pot-0.15.4_GH0.tar.gz) = 175705
diff --git a/sysutils/pot/files/pkg-message.in b/sysutils/pot/files/pkg-message.in
index 953d0a52e494..687b0d72598b 100644
--- a/sysutils/pot/files/pkg-message.in
+++ b/sysutils/pot/files/pkg-message.in
@@ -1,6 +1,6 @@
[
-{ type: install
- message: <<EOM
+ { type: install
+ message: <<EOM
Now, before to run 'pot init', it would be wise to edit the configuration file
Do not edit pot.default.conf, but pot.conf instead.
@@ -14,6 +14,16 @@ To upgrade from prevoius versions of pot (<0.6.0) to 0.6.0+ the following steps
The variable `pot_list` in the rc.conf file is deprecated.
Use `pot set-attr` to enable the attribute start-at-boot to your pot
+
+Non-privileged users need to be invited to group "pot" in order
+to use read-only commands.
+EOM
+ }
+ { type: upgrade
+ maximum_version: "0.15.4"
+ message: <<EOM
+After running pot-init, non-privileged users need to be invited to
+group "pot" in order to use read-only commands.
EOM
-}
+ }
]
diff --git a/sysutils/pot/files/pot.8.in b/sysutils/pot/files/pot.8.in
new file mode 100644
index 000000000000..f455453dcdee
--- /dev/null
+++ b/sysutils/pot/files/pot.8.in
@@ -0,0 +1,60 @@
+.\"
+.\" Copyright (c) 2022 Michael Gmelin
+.\"
+.\" All rights reserved.
+.\"
+.\" Redistribution and use in source and binary forms, with or without
+.\" modification, are permitted provided that the following conditions
+.\" are met:
+.\" 1. Redistributions of source code must retain the above copyright
+.\" notice, this list of conditions and the following disclaimer.
+.\" 2. Redistributions in binary form must reproduce the above copyright
+.\" notice, this list of conditions and the following disclaimer in the
+.\" documentation and/or other materials provided with the distribution.
+.\"
+.\" THIS SOFTWARE IS PROVIDED BY THE DEVELOPERS ``AS IS'' AND ANY EXPRESS OR
+.\" IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+.\" OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+.\" IN NO EVENT SHALL THE DEVELOPERS BE LIABLE FOR ANY DIRECT, INDIRECT,
+.\" INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+.\" NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+.\" DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+.\" THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+.\" (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+.\" THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+.\"
+.Dd December 16, 2022
+.Dt POT 8
+.Os
+.Sh NAME
+.Nm pot
+.Nd another container framework for FreeBSD, based on jails, ZFS and pf
+.Sh SYNOPSIS
+.Nm
+.Ar <command>
+.Ar [<args>]
+.Sh DESCRIPTION
+This man page is a stub.
+.Bl -tag -width "pothelp"
+.It pot help
+Get list of commands
+.It pot help Ar command
+Get help on
+.Ar command .
+.El
+.Pp
+Please see
+.Pa https://github.com/bsdpot/pot
+for more information.
+.Sh FILES
+.Bl -tag -width ".Pa %%PREFIX%%/etc/pot/pot.conf" -compact
+.It Pa %%PREFIX%%/etc/pot/pot.conf
+Global configuration file
+.It Pa %%PREFIX%%/share/doc/pot/
+Basic documentation
+.El
+.Sh SEE ALSO
+.Xr jail 8 ,
+.Xr pfctl 8 ,
+.Xr rctl 8 ,
+.Xr zfs 8
diff --git a/sysutils/pot/pkg-descr b/sysutils/pot/pkg-descr
index 07359539c28b..90f8061a711d 100644
--- a/sysutils/pot/pkg-descr
+++ b/sysutils/pot/pkg-descr
@@ -1 +1,4 @@
-This port contains scripts to manage FreeBSD containers called pot.
+pot is a container framework to run FreeBSD containers on FreeBSD.
+Every running instance is called pot, like the one that the author
+uses to cook all different types of pasta. It is heavily based on
+FreeBSD, in particular on jails, ZFS, pf and rctl.
diff --git a/sysutils/pot/pkg-plist b/sysutils/pot/pkg-plist
index 6334d7f70824..894fde2dacf5 100644
--- a/sysutils/pot/pkg-plist
+++ b/sysutils/pot/pkg-plist
@@ -57,3 +57,4 @@ bin/pot
%%DATADIR%%/version.sh
%%DATADIR%%/vnet-start.sh
%%ZSH%%share/zsh/site-functions/_pot
+man/man8/pot.8.gz