aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2024-05-30 11:14:27 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2024-05-30 11:14:27 +0000
commit02aaa15f269fff7eecbb00fc16986641a9536fd4 (patch)
tree2877638e81c618ad80dc559f19202ce0fe118ccf
parent7b9e3fc821beac9e03d8e641a2281cfeb320c0d5 (diff)
devel/py-sip4: limit to python 3.9 to fix build
sip4 doesn't support py3.11, so lower the required version. Do the same for dependent ports PR: 275494 Approved by: portmgr (blanket approval)
-rw-r--r--devel/libsavitar/Makefile3
-rw-r--r--devel/py-pynest2d/Makefile4
-rw-r--r--devel/py-sip4/Makefile4
3 files changed, 6 insertions, 5 deletions
diff --git a/devel/libsavitar/Makefile b/devel/libsavitar/Makefile
index 4623ee716921..316079904e47 100644
--- a/devel/libsavitar/Makefile
+++ b/devel/libsavitar/Makefile
@@ -1,5 +1,6 @@
PORTNAME= libSavitar
DISTVERSION= 4.13.1
+PORTREVISION= 1
CATEGORIES= devel cad
DIST_SUBDIR= Ultimaker
@@ -13,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= sip:devel/py-sip4
LIB_DEPENDS= libpugixml.so:textproc/pugixml
-USES= cmake compiler:c++11-lang python pyqt:5 gettext-runtime
+USES= cmake compiler:c++11-lang python:3.9 pyqt:5 gettext-runtime
USE_GITHUB= yes
GH_ACCOUNT= Ultimaker
USE_LDCONFIG= yes
diff --git a/devel/py-pynest2d/Makefile b/devel/py-pynest2d/Makefile
index 4c2f540833eb..be0556571f91 100644
--- a/devel/py-pynest2d/Makefile
+++ b/devel/py-pynest2d/Makefile
@@ -1,7 +1,7 @@
PORTNAME= pynest2d
# XXX there is no 4.13.1
DISTVERSION= 4.12.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,7 +19,7 @@ LIB_DEPENDS= libpolyclipping.so:graphics/polyclipping \
libboost_system.so:devel/boost-libs \
libnlopt.so:math/nlopt
-USES= python cmake compiler:c++11-lang pyqt:5 pkgconfig
+USES= python:3.9 cmake compiler:c++11-lang pyqt:5 pkgconfig
USE_PYTHON= flavors
USE_GITHUB= yes
diff --git a/devel/py-sip4/Makefile b/devel/py-sip4/Makefile
index ad15d855c4b1..8d8d06ababbc 100644
--- a/devel/py-sip4/Makefile
+++ b/devel/py-sip4/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sip4
PORTVERSION= ${SIP4_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= https://www.riverbankcomputing.com/static/Downloads/sip/${SIP4_VERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,7 +10,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Python to C and C++ bindings generator
WWW= http://www.riverbankcomputing.co.uk/software/sip/
-USES= python pyqt:sip
+USES= python:3.9 pyqt:sip
USE_PYTHON= concurrent py3kplist flavors
USE_PYQT= #