aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 10:08:12 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 11:53:18 +0000
commit02c61dffcbacd639cec46b55501f7c10ecedc1ec (patch)
tree823faaf78f58b191cab112c6b83b7215e0b55cd6
parent434e2b4fe99643bb159809ac774d4f438fbaf462 (diff)
downloadports-02c61dffcbacd639cec46b55501f7c10ecedc1ec.tar.gz
ports-02c61dffcbacd639cec46b55501f7c10ecedc1ec.zip
security/pecl-crypto: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--security/pecl-crypto/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/security/pecl-crypto/Makefile b/security/pecl-crypto/Makefile
index 48ef0cb0a3c7..b19667bc3d00 100644
--- a/security/pecl-crypto/Makefile
+++ b/security/pecl-crypto/Makefile
@@ -8,9 +8,17 @@ WWW= https://pecl.php.net/package/crypto
LICENSE= PHP301
-USES= compiler:c++11-lang php:pecl
+USES= compiler:c++11-lang php:pecl ssl
+
CONFIGURE_ARGS= --with-crypto
+
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
.include <bsd.port.mk>