aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2023-01-15 13:36:28 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-01-15 13:36:28 +0000
commit02d70c993d78af840b2dc9615ef6512c41db13b2 (patch)
tree2fb0f1c7e91bd252c23753f32bbcb5ca54e0d628
parentb5cd792b477f5a513548d273b3d31ba5c0e64901 (diff)
downloadports-02d70c993d78af840b2dc9615ef6512c41db13b2.tar.gz
ports-02d70c993d78af840b2dc9615ef6512c41db13b2.zip
audio/py-gtts: Adopt/Update to 2.3.0
- Use pep517 build - Renamed PORTNAME gtts -> gTTS to match PYPI package name case - Added issue url on test failures - Updated run dependencies versions ChangeLog: https://github.com/pndurette/gTTS/releases/tag/v2.3.0 PR: 268902
-rw-r--r--audio/py-gtts/Makefile32
-rw-r--r--audio/py-gtts/distinfo6
2 files changed, 16 insertions, 22 deletions
diff --git a/audio/py-gtts/Makefile b/audio/py-gtts/Makefile
index 14119aaf29e7..c654bb26bab6 100644
--- a/audio/py-gtts/Makefile
+++ b/audio/py-gtts/Makefile
@@ -1,35 +1,29 @@
-PORTNAME= gtts
-DISTVERSIONPREFIX= v
-DISTVERSION= 2.2.4
+PORTNAME= gTTS
+DISTVERSION= 2.3.0
CATEGORIES= audio python
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= eduardo@FreeBSD.org
COMMENT= Library/CLI tool to interface with Google Translate text-to-speech API
WWW= https://github.com/pndurette/gTTS
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.9:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=8.1.3:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.28.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.16.0:devel/py-six@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}testfixtures>0:devel/py-testfixtures@${PY_FLAVOR}
-USES= python:3.7+
-USE_GITHUB= yes
-GH_ACCOUNT= pndurette
-GH_PROJECT= gTTS
-USE_PYTHON= distutils concurrent autoplist
+USES= python
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
-do-test:
- # Comment out hardcoded pytest version requirement
- @${REINPLACE_CMD} -Ee 's|(^minversion)|#\1|' ${WRKSRC}/pytest.ini
- @cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -rs -v
+#do-test: test_file_ascii and test_file_utf8: AssertionError, see https://github.com/pndurette/gTTS/issues/393
.include <bsd.port.mk>
diff --git a/audio/py-gtts/distinfo b/audio/py-gtts/distinfo
index a75d8c92b631..21fdd9320c0d 100644
--- a/audio/py-gtts/distinfo
+++ b/audio/py-gtts/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1657006797
-SHA256 (pndurette-gTTS-v2.2.4_GH0.tar.gz) = e0b688ff777928afe280c3cf4d36bc7b794e93e86851b680d54ba2fb68e88456
-SIZE (pndurette-gTTS-v2.2.4_GH0.tar.gz) = 37695
+TIMESTAMP = 1673605832
+SHA256 (gTTS-2.3.0.tar.gz) = bccebcae57e96eb629da1bb6d4c7a870d47af5f083a8faf1827cd3fe735ed620
+SIZE (gTTS-2.3.0.tar.gz) = 22398