aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2025-02-08 19:15:16 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2025-02-08 19:15:16 +0000
commit02fe0e57819d1d81395e1db21c8a06ea226447a1 (patch)
treeb245c58428178390e24776b819b60a6bf7d29627
parentfed41ee59f991b0544b201b3c47c489489f9b307 (diff)
filesystems/mtools: the port had been updated to version 4.0.47
While here, simplify one regular expression in the `post-patch' target recipe, garbage-collect a patch, and sort the pkg-plist.
-rw-r--r--filesystems/mtools/Makefile7
-rw-r--r--filesystems/mtools/distinfo6
-rw-r--r--filesystems/mtools/files/patch-Makefile.in6
-rw-r--r--filesystems/mtools/files/patch-configure63
-rw-r--r--filesystems/mtools/pkg-plist8
5 files changed, 13 insertions, 77 deletions
diff --git a/filesystems/mtools/Makefile b/filesystems/mtools/Makefile
index 33b2c796964c..0acfa890d644 100644
--- a/filesystems/mtools/Makefile
+++ b/filesystems/mtools/Makefile
@@ -1,6 +1,5 @@
PORTNAME= mtools
-PORTVERSION= 4.0.43
-PORTREVISION= 1
+PORTVERSION= 4.0.47
CATEGORIES= filesystems emulators
MASTER_SITES= GNU
@@ -16,7 +15,6 @@ USES= gmake makeinfo tar:lz
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_malloc_h=no
CONFIGURE_ARGS= --enable-xdf
-GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
SUB_FILES= pkg-message
@@ -49,8 +47,7 @@ MAKE_ENV+= WITHOUT_X11=yes
post-patch:
@${REINPLACE_CMD} -e '/LOCAL_CONF_FILE/s,/etc/default,${LOCALBASE}/etc,' \
${WRKSRC}/mtoolsPaths.h
- @${REINPLACE_CMD} -e 's|^\(SAMPLE FILE\)$$|#\1|' \
- ${WRKSRC}/mtools.conf
+ @${REINPLACE_CMD} -e '/^SAMPLE FILE/s,^,#,' ${WRKSRC}/mtools.conf
post-install:
${INSTALL_DATA} ${WRKSRC}/mtools.conf ${STAGEDIR}${PREFIX}/etc/mtools.conf.sample
diff --git a/filesystems/mtools/distinfo b/filesystems/mtools/distinfo
index fdded9f52cc2..f56ccce6871e 100644
--- a/filesystems/mtools/distinfo
+++ b/filesystems/mtools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1679438048
-SHA256 (mtools-4.0.43.tar.lz) = 997ffe4125a19de1fd433ed63f128f7d54bc1a5915f3cdb36da6491ef917f217
-SIZE (mtools-4.0.43.tar.lz) = 383347
+TIMESTAMP = 1737275818
+SHA256 (mtools-4.0.47.tar.lz) = 2709cd2f42d65500829b056cb0630edd515d7060b4865bad31277f0da9f9e9d5
+SIZE (mtools-4.0.47.tar.lz) = 391656
diff --git a/filesystems/mtools/files/patch-Makefile.in b/filesystems/mtools/files/patch-Makefile.in
index 1c9d84b0e764..56b372653f16 100644
--- a/filesystems/mtools/files/patch-Makefile.in
+++ b/filesystems/mtools/files/patch-Makefile.in
@@ -1,4 +1,4 @@
---- Makefile.in.orig 2022-10-09 09:55:19 UTC
+--- Makefile.in.orig 2024-11-30 22:13:06 UTC
+++ Makefile.in
@@ -72,11 +72,14 @@ INSTALL_INFO = @INSTALL_INFO@
.SUFFIXES: .o .c
@@ -6,7 +6,7 @@
-MAN1 = floppyd.1 floppyd_installtest.1 mattrib.1 mbadblocks.1 mcat.1 \
+MAN1 = mattrib.1 mbadblocks.1 mcat.1 \
- mcd.1 mcopy.1 mdel.1 mdeltree.1 mdir.1 mdu.1 mformat.1 \
+ mcd.1 mcopy.1 mdel.1 mdeltree.1 mdir.1 mdoctorfat.1 mdu.1 mformat.1 \
minfo.1 mkmanifest.1 mlabel.1 mmd.1 mmount.1 mmove.1 mpartition.1 \
mrd.1 mren.1 mshortname.1 mshowfat.1 mtoolstest.1 mtools.1 mtype.1 \
mzip.1
@@ -23,7 +23,7 @@
-SCRIPTS = mcheck mxtar uz tgz mcomp amuFormat.sh
+SCRIPTS = mcheck mxtar mcomp amuFormat.sh
- LINKS=mattrib mcat mcd mcopy mdel mdeltree mdir mdu \
+ LINKS=mattrib mcat mcd mcopy mdel mdeltree mdir mdoctorfat mdu \
mformat minfo mlabel mmd mmount mmove mpartition mrd mren mtype \
@@ -264,11 +267,9 @@ install-links: $(DESTDIR)$(bindir)/mtools
install-scripts: $(DESTDIR)$(bindir)/mtools
diff --git a/filesystems/mtools/files/patch-configure b/filesystems/mtools/files/patch-configure
deleted file mode 100644
index f7dc9e442ebd..000000000000
--- a/filesystems/mtools/files/patch-configure
+++ /dev/null
@@ -1,63 +0,0 @@
---- configure.orig 2020-11-28 11:54:35 UTC
-+++ configure
-@@ -5696,10 +5696,10 @@ host_os3=`echo $host_os2 | sed 's/^\([^0-9]*\)[0-9]*$/
- host_cpu1=`echo $host_cpu | sed 's/\./_/g'`
- host_vendor1=`echo $host_vendor | sed 's/\./_/g'`
- HOST_ID="-DCPU_$host_cpu1 -DVENDOR_$host_vendor1 -DOS_$host_os1"
--if [ $host_os1 != $host_os2 ] ; then
-+if [ "$host_os1" != "$host_os2" ] ; then
- HOST_ID="$HOST_ID -DOS_$host_os2"
- fi
--if [ $host_os1 != $host_os3 ] && [ $host_os2 != $host_os3 ] ; then
-+if [ "$host_os1" != "$host_os3" ] && [ "$host_os2" != "$host_os3" ] ; then
- HOST_ID="$HOST_ID -DOS_$host_os3"
- fi
-
-@@ -5725,39 +5725,39 @@ if [ "X$GCC" = "Xyes" ] ; then
- esac
- CFLAGS="$CFLAGS $Wall"
- else
-- if [ $host_os3 = hpux ] ; then
-+ if [ "$host_os3" = hpux ] ; then
- CPPFLAGS="$CPPFLAGS -Ae"
- fi
-
-- if [ $host_os3 = xenix ] ; then
-+ if [ "$host_os3" = xenix ] ; then
- CFLAGS="$CFLAGS -M2e"
- fi
- fi
-
--if [ $host_os3 = hpux ] ; then
-+if [ "$host_os3" = hpux ] ; then
- LDFLAGS="$LDFLAGS -z"
- fi
-
--if [ $host_os3 = xenix ] ; then
-+if [ "$host_os3" = xenix ] ; then
- LDFLAGS="$LDFLAGS -M2e -i -f 5000"
- fi
-
--if [ $host_os2 = sysv4 ] ; then
-+if [ "$host_os2" = sysv4 ] ; then
- SHLIB="-lc -L/usr/ucblib -lucb"
- else
- SHLIB=""
- fi
-
--if [ $host_os3 = isc ] ; then
-+if [ "$host_os3" = isc ] ; then
- CFLAGS="$CFLAGS -D_SYSV3"
- SHLIB="-lc_s"
- fi
-
--if [ $host_os3 = solaris -a x$newVold = xxyes ] ; then
-+if [ "$host_os3" = solaris -a x$newVold = xxyes ] ; then
- SHLIB="$SHLIB -s -lvolmgt"
- fi
-
--if [ $host_os3 = nextstep ] ; then
-+if [ "$host_os3" = nextstep ] ; then
- CFLAGS="$CFLAGS -DBSD"
- SHLIB=""
- fi
diff --git a/filesystems/mtools/pkg-plist b/filesystems/mtools/pkg-plist
index 8fe66ac5cb9c..4fe5245fbb24 100644
--- a/filesystems/mtools/pkg-plist
+++ b/filesystems/mtools/pkg-plist
@@ -11,6 +11,7 @@ bin/mcopy
bin/mdel
bin/mdeltree
bin/mdir
+bin/mdoctorfat
bin/mdu
bin/mformat
bin/minfo
@@ -22,13 +23,14 @@ bin/mmove
bin/mpartition
bin/mrd
bin/mren
+bin/mshortname
bin/mshowfat
bin/mtools
bin/mtoolstest
bin/mtype
bin/mxtar
bin/mzip
-bin/mshortname
+@sample etc/mtools.conf.sample
%%X11%%share/man/man1/floppyd.1.gz
%%X11%%share/man/man1/floppyd_installtest.1.gz
share/man/man1/mattrib.1.gz
@@ -39,6 +41,7 @@ share/man/man1/mcopy.1.gz
share/man/man1/mdel.1.gz
share/man/man1/mdeltree.1.gz
share/man/man1/mdir.1.gz
+share/man/man1/mdoctorfat.1.gz
share/man/man1/mdu.1.gz
share/man/man1/mformat.1.gz
share/man/man1/minfo.1.gz
@@ -50,11 +53,10 @@ share/man/man1/mmove.1.gz
share/man/man1/mpartition.1.gz
share/man/man1/mrd.1.gz
share/man/man1/mren.1.gz
+share/man/man1/mshortname.1.gz
share/man/man1/mshowfat.1.gz
share/man/man1/mtools.1.gz
share/man/man1/mtoolstest.1.gz
share/man/man1/mtype.1.gz
share/man/man1/mzip.1.gz
-share/man/man1/mshortname.1.gz
share/man/man5/mtools.5.gz
-@sample etc/mtools.conf.sample