aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-12-22 21:57:57 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-02-21 16:10:14 +0000
commit04167ca4eaa634d8e741f24fd5d9dff7e4b6ac32 (patch)
tree2eeb8ae5f10c0319a5196cd18bceba0b1c4539a4
parentf3d7b45ee594f0dc110358249c8a2c10018319c0 (diff)
downloadports-04167ca4eaa634d8e741f24fd5d9dff7e4b6ac32.tar.gz
ports-04167ca4eaa634d8e741f24fd5d9dff7e4b6ac32.zip
x11/wayout: add new port
Wayout takes text from standard input and outputs it to a desktop-widget on Wayland desktops. Periodic updates are supported; e.g. newline-separated input or any other delimiter of choice. We call this a feed. The desktop widget can be shown either on top (OSD-like functionality) or below other windows. A Wayland compositor must implement the Layer-Shell and XDG-Output for wayout to work. Features: - Allow updating from standard input at a regular interval; custom delimiters - Configurable colours/border/position/fonts - Supports the pango markup language for text markup/colours. https://git.sr.ht/~proycon/wayout
-rw-r--r--x11/Makefile1
-rw-r--r--x11/wayout/Makefile30
-rw-r--r--x11/wayout/distinfo3
-rw-r--r--x11/wayout/pkg-descr15
4 files changed, 49 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 511f969cca39..d3610ad6f528 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -382,6 +382,7 @@
SUBDIR += wapanel
SUBDIR += waybar
SUBDIR += wayland-logout
+ SUBDIR += wayout
SUBDIR += wbar
SUBDIR += wcm
SUBDIR += wdisplays
diff --git a/x11/wayout/Makefile b/x11/wayout/Makefile
new file mode 100644
index 000000000000..d59e234f9432
--- /dev/null
+++ b/x11/wayout/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= wayout
+DISTVERSION= 0.1.2
+CATEGORIES= x11
+MASTER_SITES= https://git.sr.ht/~proycon/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Output simple text to a Wayland desktop widget
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>0:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
+
+USES= compiler:c11 gnome meson pkgconfig
+USE_GNOME= cairo pango
+PLIST_FILES= bin/${PORTNAME}
+
+OPTIONS_DEFINE= EPOLL MANPAGES
+OPTIONS_DEFAULT=EPOLL MANPAGES
+
+EPOLL_DESC= Handle signals via epoll-shim
+EPOLL_LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim
+EPOLL_MESON_ENABLED= handle-signals
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_MESON_ENABLED= man-pages
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
+
+.include <bsd.port.mk>
diff --git a/x11/wayout/distinfo b/x11/wayout/distinfo
new file mode 100644
index 000000000000..c77c8d2ca286
--- /dev/null
+++ b/x11/wayout/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1640210277
+SHA256 (wayout-0.1.2.tar.gz) = 56342bfb93c645979dfdb0fee867c29eaf80e993f6959318853748302b9a2c90
+SIZE (wayout-0.1.2.tar.gz) = 32609
diff --git a/x11/wayout/pkg-descr b/x11/wayout/pkg-descr
new file mode 100644
index 000000000000..65a65c5889cb
--- /dev/null
+++ b/x11/wayout/pkg-descr
@@ -0,0 +1,15 @@
+Wayout takes text from standard input and outputs it to a desktop-widget
+on Wayland desktops. Periodic updates are supported; e.g. newline-separated
+input or any other delimiter of choice. We call this a feed. The desktop
+widget can be shown either on top (OSD-like functionality) or below other
+windows.
+
+A Wayland compositor must implement the Layer-Shell and XDG-Output for wayout
+to work.
+
+Features:
+- Allow updating from standard input at a regular interval; custom delimiters
+- Configurable colours/border/position/fonts
+- Supports the pango markup language for text markup/colours.
+
+WWW: https://git.sr.ht/~proycon/wayout