aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2025-02-06 08:46:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2025-02-06 15:05:37 +0000
commit041e3a8bc5470fd083f8d20801fe2877e2854cf5 (patch)
tree4668031fd76b2ce42e110fd2769149dbbac95575
parent11db35ac67dfe7252477e465b621d2ee6e7996d9 (diff)
biology/gatk: Fix build breakage after gradle update to 8.12.1
Reported by: fallout
-rw-r--r--biology/gatk/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/biology/gatk/Makefile b/biology/gatk/Makefile
index 2bcf2b0647e3..7a69c6327be0 100644
--- a/biology/gatk/Makefile
+++ b/biology/gatk/Makefile
@@ -11,7 +11,7 @@ WWW= https://gatk.broadinstitute.org/hc/en-us
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
-BUILD_DEPENDS= gradle:devel/gradle
+BUILD_DEPENDS= gradle8:devel/gradle8
RUN_DEPENDS= ${LOCALBASE}/lib/libfml.so:biology/fermi-lite \
gkl>0:biology/gkl \
mummer>0:biology/mummer
@@ -106,7 +106,7 @@ post-extract: # need a separate extract step because the cache is in /tmp, and n
.endif
do-build:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gradle \
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gradle8 \
--gradle-user-home ${DEPS_CACHE_DIR}/gradle-${PORTNAME} --project-cache-dir ${DEPS_CACHE_DIR}/gradle-${PORTNAME} \
${GRADLE_ARGS} --build-cache localJar
@@ -116,7 +116,7 @@ do-install:
do-test: # tests require WITH_LARGE_FILES=ON, and they use a lot of disk space
@cd ${WRKSRC} && \
- ${SETENV} ${TEST_ENV} gradle -DLIBBWA_PATH=${PREFIX}/lib/libfml.so test
+ ${SETENV} ${TEST_ENV} gradle8 -DLIBBWA_PATH=${PREFIX}/lib/libfml.so test
# tests results as of version 4.6.1.0: 288552 tests, 301 failures, 37 ignored, 1h55m5.63s duration, 99% successful, see https://github.com/broadinstitute/gatk/issues/8940
# see https://github.com/broadinstitute/gatk/issues/8939: Tests fail to find libgkl libraries in /usr/local/lib