aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2022-01-12 20:07:32 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2022-01-12 20:07:32 +0000
commit04a6dbb444fb2496f31aa7dd3cda4f6b44a86136 (patch)
tree2f46c686ea38f48c69bd90460737f6b8f605c260
parentb63918758d4547ce590e37677c3df7bdab9ff36e (diff)
downloadports-04a6dbb444fb2496f31aa7dd3cda4f6b44a86136.tar.gz
ports-04a6dbb444fb2496f31aa7dd3cda4f6b44a86136.zip
graphics/qcomicbook: switch from p7zip to 7-zip
PR: 260866
-rw-r--r--graphics/qcomicbook/Makefile2
-rw-r--r--graphics/qcomicbook/files/patch-src_Archivers_P7zipArchiverStrategy.cpp25
2 files changed, 26 insertions, 1 deletions
diff --git a/graphics/qcomicbook/Makefile b/graphics/qcomicbook/Makefile
index 8de015e6617d..357ec204f3e4 100644
--- a/graphics/qcomicbook/Makefile
+++ b/graphics/qcomicbook/Makefile
@@ -21,7 +21,7 @@ USE_QT= core gui printsupport widgets x11extras\
OPTIONS_DEFINE= 7ZIP ACE RAR
7ZIP_DESC= 7-Zip (.cb7) comic book archives support
-7ZIP_RUN_DEPENDS= 7z:archivers/p7zip
+7ZIP_RUN_DEPENDS= 7zz:archivers/7-zip
ACE_DESC= ACE (.cba) comic book archives support
ACE_RUN_DEPENDS= unace:archivers/unace
diff --git a/graphics/qcomicbook/files/patch-src_Archivers_P7zipArchiverStrategy.cpp b/graphics/qcomicbook/files/patch-src_Archivers_P7zipArchiverStrategy.cpp
new file mode 100644
index 000000000000..bfda595cec1b
--- /dev/null
+++ b/graphics/qcomicbook/files/patch-src_Archivers_P7zipArchiverStrategy.cpp
@@ -0,0 +1,25 @@
+--- src/Archivers/P7zipArchiverStrategy.cpp.orig 2016-11-22 17:45:10 UTC
++++ src/Archivers/P7zipArchiverStrategy.cpp
+@@ -30,7 +30,7 @@ void P7zipArchiverStrategy::configure()
+ addExtension(".7z");
+ addExtension(".cb7");
+
+- setExecutables("7z", "7zr");
++ setExecutables("7z", "7zz");
+
+ if (which("7z") != QString::null)
+ {
+@@ -38,10 +38,10 @@ void P7zipArchiverStrategy::configure()
+ setListArguments("7z l @F");
+ setSupported();
+ }
+- else if (which("7zr") != QString::null)
++ else if (which("7zz") != QString::null)
+ {
+- setExtractArguments("7zr x @F");
+- setListArguments("7zr l @F");
++ setExtractArguments("7zz x @F");
++ setListArguments("7zz l @F");
+ setSupported();
+ }
+ }