aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2023-10-25 22:32:40 +0000
committerDiane Bruce <db@FreeBSD.org>2023-10-25 22:32:40 +0000
commit04c9b0ef4f45f8c38eb3b33f199157c7ddc6dba9 (patch)
tree04a53cf7d476d907b84eecf5084200b92f01afca
parent698f6c34b0f718a2c24df62f76feae6a97ac8afb (diff)
downloadports-04c9b0ef4f45f8c38eb3b33f199157c7ddc6dba9.tar.gz
ports-04c9b0ef4f45f8c38eb3b33f199157c7ddc6dba9.zip
comms/flrig: No hid support on FreeBSD 12
Can't build on FreeBSD 12 due to no hid support.
-rw-r--r--comms/flrig/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/comms/flrig/Makefile b/comms/flrig/Makefile
index 86103810d550..a18daee579f5 100644
--- a/comms/flrig/Makefile
+++ b/comms/flrig/Makefile
@@ -1,5 +1,6 @@
PORTNAME= flrig
PORTVERSION= 2.0.04
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= SF/fldigi/${PORTNAME} \
http://www.w1hkj.com/files/fldigi/
@@ -8,20 +9,23 @@ MAINTAINER= hamradio@FreeBSD.org
COMMENT= Ham Radio rig control program, cooperates with fldigi
WWW= http://www.w1hkj.com/flrig-help/index.html
+IGNORE_FreeBSD_12= no hid support
+
LICENSE= GPLv2
-LIB_DEPENDS= libpng.so:graphics/png \
+LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
libfontconfig.so:x11-fonts/fontconfig \
- libfltk.so:x11-toolkits/fltk \
+ libpng.so:graphics/png \
libudev.so:devel/libudev-devd
-USES= gmake jpeg xorg desktop-file-utils
-USE_XORG= x11 xrender xcursor xfixes xext xft xinerama
+USES= desktop-file-utils gmake jpeg xorg
+USE_XORG= x11 xcursor xext xfixes xft xinerama xrender
GNU_CONFIGURE= yes
CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config"
-PLIST_FILES= bin/flrig share/applications/flrig.desktop \
- share/pixmaps/flrig.xpm
+PLIST_FILES= bin/flrig \
+ share/applications/flrig.desktop \
+ share/pixmaps/flrig.xpm
OPTIONS_DEFINE= NATIVE
NATIVE_CONFIGURE_ON+= --enable-optimizations=native