aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-06-05 19:33:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-06-05 20:01:38 +0000
commit05a1e2cb1bbf02a3d25e465f53a6b27794e70630 (patch)
tree399bea9c814c0f0605c2232464985ac0bc9c87d6
parentcc40f06db666f0fef3139a10d237c69e626c776e (diff)
downloadports-05a1e2cb1bbf02a3d25e465f53a6b27794e70630.tar.gz
ports-05a1e2cb1bbf02a3d25e465f53a6b27794e70630.zip
science/xcfun: New port: Exchange-correlation functionals with arbitrary-order derivatives
-rw-r--r--science/Makefile1
-rw-r--r--science/xcfun/Makefile19
-rw-r--r--science/xcfun/distinfo3
-rw-r--r--science/xcfun/pkg-descr7
-rw-r--r--science/xcfun/pkg-plist33
5 files changed, 63 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index e0c5545b0e69..66209aa09188 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -352,6 +352,7 @@
SUBDIR += wannier90
SUBDIR += wwplot
SUBDIR += wxmacmolplt
+ SUBDIR += xcfun
SUBDIR += xcrysden
SUBDIR += xdrawchem
SUBDIR += xtb
diff --git a/science/xcfun/Makefile b/science/xcfun/Makefile
new file mode 100644
index 000000000000..dc426993fba2
--- /dev/null
+++ b/science/xcfun/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= xcfun
+DISTVERSIONPREFIX= v
+DISTVERSION= v2.1.1-1
+DISTVERSIONSUFFIX= -gf87ca0e
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Exchange-correlation functionals with arbitrary-order derivatives
+
+LICENSE= MPL20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USES= cmake
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= dftlibs
+
+.include <bsd.port.mk>
diff --git a/science/xcfun/distinfo b/science/xcfun/distinfo
new file mode 100644
index 000000000000..0ac12da7bc9c
--- /dev/null
+++ b/science/xcfun/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1622919937
+SHA256 (dftlibs-xcfun-vv2.1.1-1-gf87ca0e_GH0.tar.gz) = a2fd406cd2e49b0a1e16539262c9c6aebeacbc120d1fa24b61bb4db8bfa19cd7
+SIZE (dftlibs-xcfun-vv2.1.1-1-gf87ca0e_GH0.tar.gz) = 175579
diff --git a/science/xcfun/pkg-descr b/science/xcfun/pkg-descr
new file mode 100644
index 000000000000..7463ff10b434
--- /dev/null
+++ b/science/xcfun/pkg-descr
@@ -0,0 +1,7 @@
+XCFun is a library of exchange-correlation (XC) functionals to be used in
+density-functional theory (DFT) codes. XCFun follows a unique implementation
+strategy which enables the computation of derivatives of the XC functional
+kernel up to arbitrary order. It does so by relying on forward-mode automatic
+differentiation.
+
+WWW: https://xcfun.readthedocs.io/en/latest/
diff --git a/science/xcfun/pkg-plist b/science/xcfun/pkg-plist
new file mode 100644
index 000000000000..26c8d9527622
--- /dev/null
+++ b/science/xcfun/pkg-plist
@@ -0,0 +1,33 @@
+include/XCFun/XCFunExport.h
+include/XCFun/XCFunctional.hpp
+include/XCFun/config.hpp
+include/XCFun/densvars.hpp
+include/XCFun/functional.hpp
+include/XCFun/functionals/SCAN_like_eps.hpp
+include/XCFun/functionals/b97c.hpp
+include/XCFun/functionals/b97x.hpp
+include/XCFun/functionals/b97xc.hpp
+include/XCFun/functionals/constants.hpp
+include/XCFun/functionals/list_of_functionals.hpp
+include/XCFun/functionals/m0xy_fun.hpp
+include/XCFun/functionals/pbec_eps.hpp
+include/XCFun/functionals/pbex.hpp
+include/XCFun/functionals/pw92eps.hpp
+include/XCFun/functionals/pw9xx.hpp
+include/XCFun/functionals/pz81c.hpp
+include/XCFun/functionals/revtpssc_eps.hpp
+include/XCFun/functionals/revtpssx_eps.hpp
+include/XCFun/functionals/slater.hpp
+include/XCFun/functionals/tpssc_eps.hpp
+include/XCFun/functionals/tpssx_eps.hpp
+include/XCFun/functionals/vwn.hpp
+include/XCFun/specmath.hpp
+include/XCFun/xcfun.f90
+include/XCFun/xcfun.h
+include/XCFun/xcint.hpp
+lib/libxcfun.so
+lib/libxcfun.so.2
+share/cmake/XCFun/XCFunConfig.cmake
+share/cmake/XCFun/XCFunConfigVersion.cmake
+share/cmake/XCFun/XCFunTargets-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/XCFun/XCFunTargets.cmake