aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2022-02-21 15:00:54 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2022-02-21 15:04:35 +0000
commit05ab0b7b59aad904120f6a07d31a359a50b91b2b (patch)
treee9a8f9445d0509a3fdc87fd9fccd7eac36d2b339
parent1fc7952c1b362285de712ce75f91e638d6684ca4 (diff)
downloadports-05ab0b7b59aad904120f6a07d31a359a50b91b2b.tar.gz
ports-05ab0b7b59aad904120f6a07d31a359a50b91b2b.zip
net/bird2: Update to 2.0.9
Sponsored by: Netflix
-rw-r--r--net/bird2/Makefile7
-rw-r--r--net/bird2/distinfo6
-rw-r--r--net/bird2/files/patch-Makefile.in18
-rw-r--r--net/bird2/files/patch-proto_babel_babel.c24
4 files changed, 11 insertions, 44 deletions
diff --git a/net/bird2/Makefile b/net/bird2/Makefile
index 0ba12f96d705..db523094a910 100644
--- a/net/bird2/Makefile
+++ b/net/bird2/Makefile
@@ -1,8 +1,7 @@
# Created by: Alexander V. Chernikov <melifaro@FreeBSD.org>
PORTNAME= bird
-DISTVERSION= 2.0.8
-PORTREVISION= 1
+DISTVERSION= 2.0.9
CATEGORIES= net
MASTER_SITES= https://bird.network.cz/download/
PKGNAMESUFFIX= 2
@@ -59,8 +58,4 @@ STATIC_VARS= rt_prot+=static
CONFIGURE_ARGS+=--with-protocols="${RT_PROT}"
RPKI_LIB_DEPENDS= libssh.so:security/libssh
-post-patch:
- #${REINPLACE_CMD} -e 's|\.example|\.sample|g' ${WRKSRC}/Makefile.in
- #${MV} ${WRKSRC}/doc/bird.conf ${WRKSRC}/doc/bird.conf.sample
-
.include <bsd.port.mk>
diff --git a/net/bird2/distinfo b/net/bird2/distinfo
index 64f0806f6e4d..b7b8b6f8c8a0 100644
--- a/net/bird2/distinfo
+++ b/net/bird2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1616395075
-SHA256 (bird-2.0.8.tar.gz) = 19d2de83ee25a307b9e5b9e58797dd68766d439bcee33e3ac617ed502370e7f6
-SIZE (bird-2.0.8.tar.gz) = 1135228
+TIMESTAMP = 1645441068
+SHA256 (bird-2.0.9.tar.gz) = 76786bbcded3061e1bb221b011f2cc00221ec063de9cda004a7d9b061a096d5e
+SIZE (bird-2.0.9.tar.gz) = 1282045
diff --git a/net/bird2/files/patch-Makefile.in b/net/bird2/files/patch-Makefile.in
index 8bddd6d09554..2f8db6f96b66 100644
--- a/net/bird2/files/patch-Makefile.in
+++ b/net/bird2/files/patch-Makefile.in
@@ -1,15 +1,11 @@
---- Makefile.in.orig 2021-03-21 22:29:42 UTC
+--- Makefile.in.orig 2022-02-21 11:12:46 UTC
+++ Makefile.in
-@@ -206,11 +206,7 @@ install: all
- for BIN in bird @CLIENT@ ; do \
+@@ -207,7 +207,7 @@ install: all
$(INSTALL_PROGRAM) $(exedir)/$$BIN $(DESTDIR)/$(sbindir)/$$BIN ; \
done
-- if ! test -f $(DESTDIR)/@CONFIG_FILE@ ; then \
+ if ! test -f $(DESTDIR)/@CONFIG_FILE@ ; then \
- $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/@CONFIG_FILE@ ; \
-- else \
-- echo "Not overwriting old bird.conf" ; \
-- fi
-+ $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/@CONFIG_FILE@.sample ; \
-
- install-docs:
- $(INSTALL) -d $(DESTDIR)/$(docdir)
++ $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/@CONFIG_FILE@.sample ; \
+ else \
+ echo "Not overwriting old bird.conf" ; \
+ fi
diff --git a/net/bird2/files/patch-proto_babel_babel.c b/net/bird2/files/patch-proto_babel_babel.c
deleted file mode 100644
index 25cee54f7edc..000000000000
--- a/net/bird2/files/patch-proto_babel_babel.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- proto/babel/babel.c.orig 2021-04-16 21:18:15 UTC
-+++ proto/babel/babel.c
-@@ -1658,10 +1658,6 @@ babel_if_notify(struct proto *P, unsigned flags, struc
- if (!(iface->flags & IF_UP))
- return;
-
-- /* We only speak multicast */
-- if (!(iface->flags & IF_MULTICAST))
-- return;
--
- /* Ignore ifaces without link-local address */
- if (!iface->llv6)
- return;
-@@ -1734,10 +1730,6 @@ babel_reconfigure_ifaces(struct babel_proto *p, struct
- WALK_LIST(iface, iface_list)
- {
- if (!(iface->flags & IF_UP))
-- continue;
--
-- /* Ignore non-multicast ifaces */
-- if (!(iface->flags & IF_MULTICAST))
- continue;
-
- /* Ignore ifaces without link-local address */