aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2023-01-25 16:26:29 +0000
committerMathieu Arnold <mat@FreeBSD.org>2023-01-25 16:37:29 +0000
commit06051415deab060e4b0c44a060d1a19a855fdae5 (patch)
treeecd7d61f5457b755d55cda488f457350c53809aa
parent1fdc08b92541c6a6d27541951afddcf8f83adc82 (diff)
downloadports-06051415deab060e4b0c44a060d1a19a855fdae5.tar.gz
ports-06051415deab060e4b0c44a060d1a19a855fdae5.zip
dns/bind916: upgrade to 9.16.37
Security: CVE-2022-3094 CVE-2022-3736 CVE-2022-3924 Changes: https://downloads.isc.org/isc/bind9/9.16.37/doc/arm/html/notes.html#notes-for-bind-9-16-37 (cherry picked from commit 06065425a534e8388cb1b8390b4e8b884bacdbad)
-rw-r--r--dns/bind916/Makefile2
-rw-r--r--dns/bind916/distinfo6
-rw-r--r--dns/bind916/files/extrapatch-bind-min-override-ttl16
3 files changed, 12 insertions, 12 deletions
diff --git a/dns/bind916/Makefile b/dns/bind916/Makefile
index 7720db68a6bf..ff27843fc5be 100644
--- a/dns/bind916/Makefile
+++ b/dns/bind916/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl tar:xz
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.16.36
+ISCVERSION= 9.16.37
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind916/distinfo b/dns/bind916/distinfo
index f55ad1acf8be..ecb2a7dcd61e 100644
--- a/dns/bind916/distinfo
+++ b/dns/bind916/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1671811369
-SHA256 (bind-9.16.36.tar.xz) = 508c94e8c9884f6075fa820a51efae04a1758dbdd157b01695ea6cd07049c221
-SIZE (bind-9.16.36.tar.xz) = 5105696
+TIMESTAMP = 1674661960
+SHA256 (bind-9.16.37.tar.xz) = 0e4661d522a2fe1f111c1f0685e7d6993d657f81dae24e7a75dbd8db3ef2e2ab
+SIZE (bind-9.16.37.tar.xz) = 5109440
diff --git a/dns/bind916/files/extrapatch-bind-min-override-ttl b/dns/bind916/files/extrapatch-bind-min-override-ttl
index 9b4f3614413c..8bdbde740cfd 100644
--- a/dns/bind916/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind916/files/extrapatch-bind-min-override-ttl
@@ -1,8 +1,8 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2022-12-12 14:43:23 UTC
+--- bin/named/config.c.orig 2023-01-12 22:45:02 UTC
+++ bin/named/config.c
-@@ -176,6 +176,7 @@ options {\n\
+@@ -177,6 +177,7 @@ options {\n\
notify-source *;\n\
notify-source-v6 *;\n\
nsec3-test-zone no;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
parental-source *;\n\
parental-source-v6 *;\n\
provide-ixfr true;\n\
---- bin/named/server.c.orig 2022-12-12 14:43:23 UTC
+--- bin/named/server.c.orig 2023-01-12 22:45:02 UTC
+++ bin/named/server.c
-@@ -4437,6 +4437,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4444,6 +4444,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2022-12-12 14:43:23 UTC
+--- lib/dns/include/dns/view.h.orig 2023-01-12 22:45:02 UTC
+++ lib/dns/include/dns/view.h
@@ -154,6 +154,7 @@ struct dns_view {
bool requestnsid;
@@ -34,7 +34,7 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2022-12-12 14:43:23 UTC
+--- lib/dns/resolver.c.orig 2023-01-12 22:45:02 UTC
+++ lib/dns/resolver.c
@@ -6494,6 +6494,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
@@ -49,9 +49,9 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2022-12-12 14:43:23 UTC
+--- lib/isccfg/namedconf.c.orig 2023-01-12 22:45:02 UTC
+++ lib/isccfg/namedconf.c
-@@ -2053,6 +2053,7 @@ static cfg_clausedef_t view_clauses[] = {
+@@ -2054,6 +2054,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
{ "max-acache-size", &cfg_type_sizenodefault, CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },