aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-07-28 21:38:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-07-28 23:57:41 +0000
commit06b91c7e14c7a427463209d8dbd9fb46249337f5 (patch)
treeefa4efd6d883d8f1e06dae12c79fe7b08fc1579d
parent6cffdc259b6d5e0d52d61398d170e6541c0ba790 (diff)
devel/py-pytest-pretty: New port: Py.test plugin for pretty printing the test summary
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-pretty/Makefile30
-rw-r--r--devel/py-pytest-pretty/distinfo3
-rw-r--r--devel/py-pytest-pretty/pkg-descr1
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ff945de1206f..63b2df88c82c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5560,6 +5560,7 @@
SUBDIR += py-pytest-parallel
SUBDIR += py-pytest-pep8
SUBDIR += py-pytest-plus
+ SUBDIR += py-pytest-pretty
SUBDIR += py-pytest-profiling
SUBDIR += py-pytest-pycodestyle
SUBDIR += py-pytest-qt
diff --git a/devel/py-pytest-pretty/Makefile b/devel/py-pytest-pretty/Makefile
new file mode 100644
index 000000000000..8de61089b54d
--- /dev/null
+++ b/devel/py-pytest-pretty/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= pytest-pretty
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.0
+CATEGORIES= devel python
+#MASTER_SITES= PYPI # no tests
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+#DISTNAME= ${PORTNAME:S/-/_/}-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Py.test plugin for pretty printing the test summary
+WWW= https://github.com/samuelcolvin/pytest-pretty
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>0:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=7:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rich>=12:textproc/py-rich@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist pytest
+
+USE_GITHUB= yes
+GH_ACCOUNT= samuelcolvin
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-pretty/distinfo b/devel/py-pytest-pretty/distinfo
new file mode 100644
index 000000000000..dd3290d8d36b
--- /dev/null
+++ b/devel/py-pytest-pretty/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1722202514
+SHA256 (samuelcolvin-pytest-pretty-v1.2.0_GH0.tar.gz) = ef1d3f73a7a35164e88b79c937c5b68a5d0a47f83d82865d87b259a000d8d034
+SIZE (samuelcolvin-pytest-pretty-v1.2.0_GH0.tar.gz) = 209444
diff --git a/devel/py-pytest-pretty/pkg-descr b/devel/py-pytest-pretty/pkg-descr
new file mode 100644
index 000000000000..8ba945574e5c
--- /dev/null
+++ b/devel/py-pytest-pretty/pkg-descr
@@ -0,0 +1 @@
+pytest-pretty is a pytest plugin for pretty printing the test summary.