aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-07 12:26:31 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-07 12:26:31 +0000
commit073178561a1e15717e837245448b7fcf362cbc6c (patch)
treec33b4a15ac6ef4be87373c6e48b201e2a3a882b8
parent79cbda490234f0ea3c051c645d6aea8ded3534ae (diff)
downloadports-073178561a1e15717e837245448b7fcf362cbc6c.tar.gz
ports-073178561a1e15717e837245448b7fcf362cbc6c.zip
games/oolite: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--games/oolite/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/games/oolite/Makefile b/games/oolite/Makefile
index 1e4805cbaa02..13d416bb0cdb 100644
--- a/games/oolite/Makefile
+++ b/games/oolite/Makefile
@@ -58,6 +58,12 @@ BROKEN_armv6= fails to compile: your compiler does not follow the C++ specifica
BROKEN_armv7= fails to compile: your compiler does not follow the C++ specification for temporary object destruction order
BROKEN_i386= fails to compile: ../methodjit/MethodJIT.cpp:318:5: error: expected '(' after 'asm'
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+ADDITIONAL_CPPFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-patch: .SILENT
${REINPLACE_CMD} -e 's/GNUSTEP_USER_ROOT/GNUSTEP_LOCAL_ROOT/ ; \
s/sdl-config/$${SDL_CONFIG}/ ; \