aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-04 02:48:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-04 03:04:35 +0000
commit07b545fde2e88f2320dad769b949c61b5bebc8ba (patch)
tree1cef05df4d7d1b52894a23d415c09c2007ea936b
parent90319b5de65d77bea0eeafd5cf31e9e56643c2ca (diff)
downloadports-07b545fde2e88f2320dad769b949c61b5bebc8ba.tar.gz
ports-07b545fde2e88f2320dad769b949c61b5bebc8ba.zip
math/ensmallen: Update 2.16.2 -> 2.17.0
Reported by: portscout
-rw-r--r--math/ensmallen/Makefile4
-rw-r--r--math/ensmallen/distinfo6
-rw-r--r--math/ensmallen/pkg-plist16
3 files changed, 21 insertions, 5 deletions
diff --git a/math/ensmallen/Makefile b/math/ensmallen/Makefile
index 540291e02917..3672862896fd 100644
--- a/math/ensmallen/Makefile
+++ b/math/ensmallen/Makefile
@@ -1,5 +1,5 @@
PORTNAME= ensmallen
-DISTVERSION= 2.16.2
+DISTVERSION= 2.17.0
CATEGORIES= math
MASTER_SITES= https://ensmallen.org/files/
@@ -18,7 +18,7 @@ CMAKE_OFF= BUILD_TESTS
NO_BUILD= yes
NO_ARCH= yes
-do-test: # one test fails: https://github.com/mlpack/ensmallen/issues/264
+do-test: # due to a regression the test executable isn't built, see https://github.com/mlpack/ensmallen/issues/312
@cd ${BUILD_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_TESTS:BOOL=ON ${CMAKE_SOURCE_PATH} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
diff --git a/math/ensmallen/distinfo b/math/ensmallen/distinfo
index 4d0684d5bc42..6a3df9c7a968 100644
--- a/math/ensmallen/distinfo
+++ b/math/ensmallen/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1619158258
-SHA256 (ensmallen-2.16.2.tar.gz) = dac86b22be33ffcb083013dee5023d6653b8e06bc325dff05fd43a0ccbf0ade5
-SIZE (ensmallen-2.16.2.tar.gz) = 1294240
+TIMESTAMP = 1628043910
+SHA256 (ensmallen-2.17.0.tar.gz) = 2803c8cce58f278d6e7eb4a5d8090da10b4cce7a5c6c6e6f65e89de4fc9c9086
+SIZE (ensmallen-2.17.0.tar.gz) = 1318322
diff --git a/math/ensmallen/pkg-plist b/math/ensmallen/pkg-plist
index 9c3148d3556c..0fbe7fe2b793 100644
--- a/math/ensmallen/pkg-plist
+++ b/math/ensmallen/pkg-plist
@@ -29,6 +29,7 @@ include/ensmallen_bits/callbacks/callbacks.hpp
include/ensmallen_bits/callbacks/early_stop_at_min_loss.hpp
include/ensmallen_bits/callbacks/print_loss.hpp
include/ensmallen_bits/callbacks/progress_bar.hpp
+include/ensmallen_bits/callbacks/query_front.hpp
include/ensmallen_bits/callbacks/report.hpp
include/ensmallen_bits/callbacks/store_best_coordinates.hpp
include/ensmallen_bits/callbacks/timer_stop.hpp
@@ -86,6 +87,14 @@ include/ensmallen_bits/lbfgs/lbfgs_impl.hpp
include/ensmallen_bits/log.hpp
include/ensmallen_bits/lookahead/lookahead.hpp
include/ensmallen_bits/lookahead/lookahead_impl.hpp
+include/ensmallen_bits/moead/decomposition_policies/pbi_decomposition.hpp
+include/ensmallen_bits/moead/decomposition_policies/tchebycheff_decomposition.hpp
+include/ensmallen_bits/moead/decomposition_policies/weighted_decomposition.hpp
+include/ensmallen_bits/moead/moead.hpp
+include/ensmallen_bits/moead/moead_impl.hpp
+include/ensmallen_bits/moead/weight_init_policies/bbs_init.hpp
+include/ensmallen_bits/moead/weight_init_policies/dirichlet_init.hpp
+include/ensmallen_bits/moead/weight_init_policies/uniform_init.hpp
include/ensmallen_bits/nsga2/nsga2.hpp
include/ensmallen_bits/nsga2/nsga2_impl.hpp
include/ensmallen_bits/padam/padam.hpp
@@ -162,6 +171,11 @@ include/ensmallen_bits/problems/three_hump_camel_function.hpp
include/ensmallen_bits/problems/three_hump_camel_function_impl.hpp
include/ensmallen_bits/problems/wood_function.hpp
include/ensmallen_bits/problems/wood_function_impl.hpp
+include/ensmallen_bits/problems/zdt/zdt1_function.hpp
+include/ensmallen_bits/problems/zdt/zdt2_function.hpp
+include/ensmallen_bits/problems/zdt/zdt3_function.hpp
+include/ensmallen_bits/problems/zdt/zdt4_function.hpp
+include/ensmallen_bits/problems/zdt/zdt6_function.hpp
include/ensmallen_bits/pso/init_policies/default_init.hpp
include/ensmallen_bits/pso/pso.hpp
include/ensmallen_bits/pso/pso_impl.hpp
@@ -223,6 +237,8 @@ include/ensmallen_bits/swats/swats_impl.hpp
include/ensmallen_bits/swats/swats_update.hpp
include/ensmallen_bits/utility/any.hpp
include/ensmallen_bits/utility/arma_traits.hpp
+include/ensmallen_bits/utility/indicators/epsilon.hpp
+include/ensmallen_bits/utility/indicators/igd_plus.hpp
include/ensmallen_bits/wn_grad/wn_grad.hpp
include/ensmallen_bits/wn_grad/wn_grad_impl.hpp
include/ensmallen_bits/wn_grad/wn_grad_update.hpp