aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:03:13 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:03:13 +0000
commit07b836360cab9eeab5260ff30ee6c22609665281 (patch)
treed16d94b67d8a352592b08cb571113704579b8e67
parent9f68a55403545cab54a04a3be37f189cacf576cb (diff)
downloadports-07b836360cab9eeab5260ff30ee6c22609665281.tar.gz
ports-07b836360cab9eeab5260ff30ee6c22609665281.zip
devel/log4cxx: Update to 1.1.0
- Update WWW - Update pkg-descr - Take maintainership Changes: https://logging.apache.org/log4cxx/latest_stable/changelog.html
-rw-r--r--devel/log4cxx/Makefile40
-rw-r--r--devel/log4cxx/distinfo6
-rw-r--r--devel/log4cxx/pkg-descr5
-rw-r--r--devel/log4cxx/pkg-plist53
4 files changed, 57 insertions, 47 deletions
diff --git a/devel/log4cxx/Makefile b/devel/log4cxx/Makefile
index a16a59793062..67b432f57553 100644
--- a/devel/log4cxx/Makefile
+++ b/devel/log4cxx/Makefile
@@ -1,38 +1,32 @@
PORTNAME= log4cxx
-PORTVERSION= 0.11.0
+PORTVERSION= 1.1.0
CATEGORIES= devel
-MASTER_SITES= https://archive.apache.org/dist/logging/${PORTNAME}/${PORTVERSION}/
-DISTNAME= apache-${PORTNAME}-${PORTVERSION}
+MASTER_SITES= https://archive.apache.org/dist/logging/log4cxx/${PORTVERSION}/
+DISTNAME= apache-log4cxx-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= C++ port of the Log4j project
-WWW= https://logging.apache.org/log4cxx/
+WWW= https://logging.apache.org/log4cxx/ \
+ https://github.com/apache/logging-log4cxx
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libapr-1.so:devel/apr1
+LIB_DEPENDS= libapr-1.so:devel/apr1 \
+ libexpat.so:textproc/expat2 \
+ libfmt.so:devel/libfmt
+TEST_DEPENDS= zip:archivers/zip
-USES= autoreconf pathfix libtool
-GNU_CONFIGURE= yes
+USES= cmake:testing compiler:c++17-lang pathfix
+
+CMAKE_OFF= APACHE_MAINTAINER APR_STATIC APU_STATIC BUILD_TESTING ENABLE_COVERAGE LIBESMTP_STATIC LOG4CXX_ENABLE_ESMTP LOG4CXX_ENABLE_ODBC LOG4CXX_UNICHAR
+CMAKE_ON= BUILD_SHARED_LIBS ENABLE_FMT_LAYOUT LOG4CXX_INSTALL_PDB LOG4CXX_WCHAR_T
+CMAKE_TESTING_O= BUILD_TESTING
USE_LDCONFIG= yes
-INSTALL_TARGET= install-strip
-MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= BOOST DOXYGEN
+OPTIONS_DEFINE= BOOST
BOOST_BUILD_DEPENDS= ${LOCALBASE}/include/boost/regex.hpp:devel/boost-libs
-
-DOXYGEN_CONFIGURE_OFF= --disable-doxygen
-DOXYGEN_BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:devel/doxygen
-
-post-configure:
- @${REINPLACE_CMD} -e 's|-dpR|-pr|' \
- -e '/^htmldest/ s|$$(pkgdatadir)|${DOCSDIR}|' \
- ${WRKSRC}/src/site/doxy/Makefile
-
-post-install-DOXYGEN-on:
- @cd ${STAGEDIR}${PREFIX} && \
- ${FIND} ${DOCSDIR:S|${PREFIX}/||} ! -type d >> ${TMPPLIST}
+BOOST_CMAKE_BOOL= PREFER_BOOST
.include <bsd.port.mk>
diff --git a/devel/log4cxx/distinfo b/devel/log4cxx/distinfo
index aa9e05125470..3b1fa554c030 100644
--- a/devel/log4cxx/distinfo
+++ b/devel/log4cxx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1598168840
-SHA256 (apache-log4cxx-0.11.0.tar.gz) = c316705ee3c4e5b919d3561d5f305162d21687aa6ae1f31f02f6cdadc958b393
-SIZE (apache-log4cxx-0.11.0.tar.gz) = 1145075
+TIMESTAMP = 1683227583
+SHA256 (apache-log4cxx-1.1.0.tar.gz) = 1fc7d82697534184bc0f757348d969d24852b948f63d6b17283fd1ee29c2c28a
+SIZE (apache-log4cxx-1.1.0.tar.gz) = 564044
diff --git a/devel/log4cxx/pkg-descr b/devel/log4cxx/pkg-descr
index ba7d8316cb63..bae780e316e8 100644
--- a/devel/log4cxx/pkg-descr
+++ b/devel/log4cxx/pkg-descr
@@ -1,2 +1,3 @@
-Log4cxx is a C++ port of the Log4j project.
-The goal is to have the same functionality and interfaces as log4j.
+Apache Log4cxx is a logging framework for C++ patterned after Apache log4j,
+which uses Apache Portable Runtime for most platform-specific code and should be
+usable on any platform supported by APR.
diff --git a/devel/log4cxx/pkg-plist b/devel/log4cxx/pkg-plist
index d272ea131254..5b790af15ced 100644
--- a/devel/log4cxx/pkg-plist
+++ b/devel/log4cxx/pkg-plist
@@ -4,7 +4,7 @@ include/log4cxx/asyncappender.h
include/log4cxx/basicconfigurator.h
include/log4cxx/config/propertysetter.h
include/log4cxx/consoleappender.h
-include/log4cxx/dailyrollingfileappender.h
+include/log4cxx/db/dbappender.h
include/log4cxx/db/odbcappender.h
include/log4cxx/defaultconfigurator.h
include/log4cxx/defaultloggerfactory.h
@@ -20,10 +20,10 @@ include/log4cxx/filter/loggermatchfilter.h
include/log4cxx/filter/mapfilter.h
include/log4cxx/filter/propertyfilter.h
include/log4cxx/filter/stringmatchfilter.h
+include/log4cxx/fmtlayout.h
include/log4cxx/helpers/absolutetimedateformat.h
include/log4cxx/helpers/appenderattachableimpl.h
include/log4cxx/helpers/aprinitializer.h
-include/log4cxx/helpers/bufferedoutputstream.h
include/log4cxx/helpers/bufferedwriter.h
include/log4cxx/helpers/bytearrayinputstream.h
include/log4cxx/helpers/bytearrayoutputstream.h
@@ -33,13 +33,11 @@ include/log4cxx/helpers/charsetdecoder.h
include/log4cxx/helpers/charsetencoder.h
include/log4cxx/helpers/class.h
include/log4cxx/helpers/classregistration.h
-include/log4cxx/helpers/condition.h
include/log4cxx/helpers/cyclicbuffer.h
include/log4cxx/helpers/datagrampacket.h
include/log4cxx/helpers/datagramsocket.h
include/log4cxx/helpers/date.h
include/log4cxx/helpers/dateformat.h
-include/log4cxx/helpers/datelayout.h
include/log4cxx/helpers/datetimedateformat.h
include/log4cxx/helpers/exception.h
include/log4cxx/helpers/fileinputstream.h
@@ -53,12 +51,9 @@ include/log4cxx/helpers/iso8601dateformat.h
include/log4cxx/helpers/loader.h
include/log4cxx/helpers/locale.h
include/log4cxx/helpers/loglog.h
+include/log4cxx/helpers/makeunique.h
include/log4cxx/helpers/messagebuffer.h
-include/log4cxx/helpers/mutex.h
include/log4cxx/helpers/object.h
-include/log4cxx/helpers/objectimpl.h
-include/log4cxx/helpers/objectoutputstream.h
-include/log4cxx/helpers/objectptr.h
include/log4cxx/helpers/onlyonceerrorhandler.h
include/log4cxx/helpers/optionconverter.h
include/log4cxx/helpers/outputstream.h
@@ -77,15 +72,14 @@ include/log4cxx/helpers/strftimedateformat.h
include/log4cxx/helpers/strictmath.h
include/log4cxx/helpers/stringhelper.h
include/log4cxx/helpers/stringtokenizer.h
-include/log4cxx/helpers/synchronized.h
include/log4cxx/helpers/syslogwriter.h
include/log4cxx/helpers/system.h
include/log4cxx/helpers/systemerrwriter.h
include/log4cxx/helpers/systemoutwriter.h
include/log4cxx/helpers/tchar.h
-include/log4cxx/helpers/thread.h
include/log4cxx/helpers/threadlocal.h
include/log4cxx/helpers/threadspecificdata.h
+include/log4cxx/helpers/threadutility.h
include/log4cxx/helpers/timezone.h
include/log4cxx/helpers/transcoder.h
include/log4cxx/helpers/transform.h
@@ -103,15 +97,15 @@ include/log4cxx/logstring.h
include/log4cxx/mdc.h
include/log4cxx/ndc.h
include/log4cxx/net/smtpappender.h
-include/log4cxx/net/socketappender.h
include/log4cxx/net/socketappenderskeleton.h
-include/log4cxx/net/sockethubappender.h
include/log4cxx/net/syslogappender.h
include/log4cxx/net/telnetappender.h
include/log4cxx/net/xmlsocketappender.h
include/log4cxx/nt/nteventlogappender.h
include/log4cxx/nt/outputdebugstringappender.h
include/log4cxx/pattern/classnamepatternconverter.h
+include/log4cxx/pattern/colorendpatternconverter.h
+include/log4cxx/pattern/colorstartpatternconverter.h
include/log4cxx/pattern/datepatternconverter.h
include/log4cxx/pattern/filedatepatternconverter.h
include/log4cxx/pattern/filelocationpatternconverter.h
@@ -124,6 +118,7 @@ include/log4cxx/pattern/lineseparatorpatternconverter.h
include/log4cxx/pattern/literalpatternconverter.h
include/log4cxx/pattern/loggerpatternconverter.h
include/log4cxx/pattern/loggingeventpatternconverter.h
+include/log4cxx/pattern/mdcpatternconverter.h
include/log4cxx/pattern/messagepatternconverter.h
include/log4cxx/pattern/methodlocationpatternconverter.h
include/log4cxx/pattern/nameabbreviator.h
@@ -133,11 +128,31 @@ include/log4cxx/pattern/patternconverter.h
include/log4cxx/pattern/patternparser.h
include/log4cxx/pattern/propertiespatternconverter.h
include/log4cxx/pattern/relativetimepatternconverter.h
+include/log4cxx/pattern/shortfilelocationpatternconverter.h
include/log4cxx/pattern/threadpatternconverter.h
+include/log4cxx/pattern/threadusernamepatternconverter.h
include/log4cxx/pattern/throwableinformationpatternconverter.h
include/log4cxx/patternlayout.h
-include/log4cxx/portability.h
+include/log4cxx/private/action_priv.h
+include/log4cxx/private/appenderskeleton_priv.h
+include/log4cxx/private/aprdatagramsocket.h
+include/log4cxx/private/aprserversocket.h
+include/log4cxx/private/aprsocket.h
+include/log4cxx/private/boost-std-configuration.h
+include/log4cxx/private/datagramsocket_priv.h
+include/log4cxx/private/fileappender_priv.h
+include/log4cxx/private/filter_priv.h
include/log4cxx/private/log4cxx_private.h
+include/log4cxx/private/nteventlogappender_priv.h
+include/log4cxx/private/odbcappender_priv.h
+include/log4cxx/private/patternconverter_priv.h
+include/log4cxx/private/rollingpolicybase_priv.h
+include/log4cxx/private/serversocket_priv.h
+include/log4cxx/private/socket_priv.h
+include/log4cxx/private/socketappenderskeleton_priv.h
+include/log4cxx/private/string_c11.h
+include/log4cxx/private/syslogappender_priv.h
+include/log4cxx/private/writerappender_priv.h
include/log4cxx/propertyconfigurator.h
include/log4cxx/provisionnode.h
include/log4cxx/rolling/action.h
@@ -146,8 +161,8 @@ include/log4cxx/rolling/filterbasedtriggeringpolicy.h
include/log4cxx/rolling/fixedwindowrollingpolicy.h
include/log4cxx/rolling/gzcompressaction.h
include/log4cxx/rolling/manualtriggeringpolicy.h
+include/log4cxx/rolling/multiprocessrollingfileappender.h
include/log4cxx/rolling/rollingfileappender.h
-include/log4cxx/rolling/rollingfileappenderskeleton.h
include/log4cxx/rolling/rollingpolicy.h
include/log4cxx/rolling/rollingpolicybase.h
include/log4cxx/rolling/rolloverdescription.h
@@ -155,7 +170,6 @@ include/log4cxx/rolling/sizebasedtriggeringpolicy.h
include/log4cxx/rolling/timebasedrollingpolicy.h
include/log4cxx/rolling/triggeringpolicy.h
include/log4cxx/rolling/zipcompressaction.h
-include/log4cxx/rollingfileappender.h
include/log4cxx/simplelayout.h
include/log4cxx/spi/appenderattachable.h
include/log4cxx/spi/configurator.h
@@ -172,13 +186,14 @@ include/log4cxx/spi/repositoryselector.h
include/log4cxx/spi/rootlogger.h
include/log4cxx/spi/triggeringeventevaluator.h
include/log4cxx/stream.h
-include/log4cxx/ttcclayout.h
include/log4cxx/varia/fallbackerrorhandler.h
include/log4cxx/writerappender.h
include/log4cxx/xml/domconfigurator.h
include/log4cxx/xml/xmllayout.h
-lib/liblog4cxx.a
+lib/cmake/log4cxx/log4cxxConfig-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/log4cxx/log4cxxConfig.cmake
+lib/cmake/log4cxx/log4cxxConfigVersion.cmake
lib/liblog4cxx.so
-lib/liblog4cxx.so.11
-lib/liblog4cxx.so.11.0.0
+lib/liblog4cxx.so.15
+lib/liblog4cxx.so.15.1.0
libdata/pkgconfig/liblog4cxx.pc