aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-02-28 23:31:02 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-02-28 23:40:41 +0000
commit08b5ebce79c5923c31b249d37df69b99ddcb843e (patch)
tree286a6854717ed742b31d983f737ece8b6d206281
parente5963086dcc918258be1e05670c5223bb272f361 (diff)
downloadports-08b5ebce79c5923c31b249d37df69b99ddcb843e.tar.gz
ports-08b5ebce79c5923c31b249d37df69b99ddcb843e.zip
dns/py-dnspython: Revert 7fc16da
- Remove duplicate PORTVERSION based on PYTHON_MAJOR_VER - Add PORTEPOCH as version number going backwards 2.1.0=>1.16.0 - Restrict python upto 3.7 - Fix finance/electrum which was changed based on this. - Fix dns/py-dns-lexicon which was changed based on this. PR: 261325 Approved by: portmgr Fixes: 7fc16da dns/py-dnspython: Update to 2.1.0 for Python 3
-rw-r--r--dns/py-dns-lexicon/Makefile4
-rw-r--r--dns/py-dnspython/Makefile22
-rw-r--r--dns/py-dnspython/distinfo4
-rw-r--r--finance/electrum/Makefile4
4 files changed, 13 insertions, 21 deletions
diff --git a/dns/py-dns-lexicon/Makefile b/dns/py-dns-lexicon/Makefile
index f5b1b39ca35d..12f4451fbb78 100644
--- a/dns/py-dns-lexicon/Makefile
+++ b/dns/py-dns-lexicon/Makefile
@@ -2,7 +2,7 @@
PORTNAME= dns-lexicon
PORTVERSION= 3.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -32,7 +32,7 @@ OCI_DESC= Oracle Cloud Infrastructure (OCI) support
ROUTE53_DESC= Route 53 support
SOFTLAYER_DESC= SoftLayer (IBM Cloud) support
-DDNS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=2:dns/py-dnspython@${PY_FLAVOR}
+DDNS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython2>=2:dns/py-dnspython2@${PY_FLAVOR}
GRANSY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zeep>=3:net/py-zeep@${PY_FLAVOR}
LOCALZONE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}localzone>=0.9.8:dns/py-localzone@${PY_FLAVOR}
OCI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}oci>=2:devel/py-oci@${PY_FLAVOR}
diff --git a/dns/py-dnspython/Makefile b/dns/py-dnspython/Makefile
index ba52900816d1..083f98e153a6 100644
--- a/dns/py-dnspython/Makefile
+++ b/dns/py-dnspython/Makefile
@@ -2,6 +2,7 @@
PORTNAME= dnspython
PORTVERSION= 1.16.0
+PORTEPOCH= 1
CATEGORIES= dns python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,27 +13,20 @@ COMMENT= DNS toolkit for Python
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:2.7+ zip
+USES= python:2.7-3.7 zip
USE_PYTHON= autoplist concurrent cython distutils
NO_ARCH= yes
-OPTIONS_DEFINE= EXAMPLES PYCRYPTODOME
-PYCRYPTODOME_DESC= Enable pycryptodome (part of dnssec needs it)
-PYCRYPTODOME_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycryptodome>=0:security/py-pycryptodome@${PY_FLAVOR}
-
-PORTEXAMPLES= ddns.py e164.py mx.py name.py reverse.py reverse_name.py \
- xfr.py zonediff.py
+PORTEXAMPLES= ddns.py e164.py mx.py name.py reverse.py reverse_name.py xfr.py \
+ zonediff.py
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_MAJOR_VER} == 3
-PORTVERSION= 2.1.0
-.endif
+OPTIONS_DEFINE= EXAMPLES PYCRYPTODOME
+PYCRYPTODOME_DESC= Enable pycryptodome (part of dnssec needs it)
+PYCRYPTODOME_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycryptodome>=0:security/py-pycryptodome@${PY_FLAVOR}
post-install-EXAMPLES-on:
-# examples
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/examples/,} ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/py-dnspython/distinfo b/dns/py-dnspython/distinfo
index a4ae58940da3..88b7df39d17d 100644
--- a/dns/py-dnspython/distinfo
+++ b/dns/py-dnspython/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1613064959
+TIMESTAMP = 1646069762
SHA256 (dnspython-1.16.0.zip) = 36c5e8e38d4369a08b6780b7f27d790a292b2b08eea01607865bf0936c558e01
SIZE (dnspython-1.16.0.zip) = 266364
-SHA256 (dnspython-2.1.0.zip) = e4a87f0b573201a0f3727fa18a516b055fd1107e0e5477cded4a2de497df1dd4
-SIZE (dnspython-2.1.0.zip) = 389021
diff --git a/finance/electrum/Makefile b/finance/electrum/Makefile
index 93d821c7bc2e..901c2d8e96b9 100644
--- a/finance/electrum/Makefile
+++ b/finance/electrum/Makefile
@@ -2,7 +2,7 @@
PORTNAME= electrum
PORTVERSION= 4.1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= finance python
MASTER_SITES= https://download.electrum.org/${PORTVERSION}/ \
http://download.electrum.org/${PORTVERSION}/
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp-socks>=0.3:net/py-aiohttp-socks@${PY
${PYTHON_PKGNAMEPREFIX}bitstring>0:devel/py-bitstring@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cryptography>=2.6:security/py-cryptography@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}dnspython>=2.0:dns/py-dnspython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dnspython2>=2.0:dns/py-dnspython2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}httplib2>=0:www/py-httplib2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jsonrpclib-pelix>0:devel/py-jsonrpclib-pelix@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pbkdf2>=1.3:security/py-pbkdf2@${PY_FLAVOR} \