aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 19:34:09 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 19:34:43 +0000
commit08dd07f36ec34a207bdf989af9929dba35af9067 (patch)
treee506afc0a6a78f5d594d1942c1918245de4275fb
parent7e2410c5904d118217f880a8c38574b4c8c1a01e (diff)
downloadports-08dd07f36ec34a207bdf989af9929dba35af9067.tar.gz
ports-08dd07f36ec34a207bdf989af9929dba35af9067.zip
graphics/urho3d: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--graphics/urho3d/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/graphics/urho3d/Makefile b/graphics/urho3d/Makefile
index 4346be33d595..6f6a956723ce 100644
--- a/graphics/urho3d/Makefile
+++ b/graphics/urho3d/Makefile
@@ -15,6 +15,7 @@ BROKEN_i386= fails to build: error: typedef redefinition with different types
BROKEN_riscv64= fails to build: invokes x86 assembler
USES= cmake:noninja,insource dos2unix gl xorg
+USE_CXXSTD= c++14
USE_GITHUB= yes
USE_XORG= x11 xext
USE_GL= gl
@@ -26,6 +27,7 @@ DOS2UNIX_FILES= ${WRKSRC}/Source/ThirdParty/StanHull/hull.cpp
GH_PROJECT= Urho3D
OPTIONS_DEFINE= EXAMPLES
+
EXAMPLES_CMAKE_OFF= -DURHO3D_SAMPLES:BOOL=false
.include <bsd.port.mk>