aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-06-03 14:06:17 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-06-03 15:22:28 +0000
commit0932acb439f08739f7498b8de8267e32075c6ab7 (patch)
tree5c796d5ac59b18085161a9e10e9a229e07857430
parenta620325d3650b566aed94b378f4bb87d8f1ef55f (diff)
downloadports-0932acb439f08739f7498b8de8267e32075c6ab7.tar.gz
ports-0932acb439f08739f7498b8de8267e32075c6ab7.zip
math/plplot: set WXGTK by default + other fixes
- Enable the option WXGTK by default (used by science/gnudatalanguage); - fix the Fortran option. Note: the fix about shapelib has been committed previously. PR: 247181 Reported by: /me
-rw-r--r--math/plplot/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 87ca6c7838c1..2a6bd20bb17b 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -2,7 +2,7 @@
PORTNAME= plplot
DISTVERSION= 5.15.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math science
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}%20Source
@@ -30,7 +30,7 @@ SHEBANG_FILES= ${WRKSRC}/examples/python/* \
${WRKSRC}/examples/tk/*
SHEBANG_LANG= sh xtk01 xtk02 xtk04
sh_OLD_CMD= @SH_EXECUTABLE@
-sh_CMD= /bin/sh
+sh_CMD= ${SH}
xtk01_OLD_CMD= @xtk01_LOCATION@
xtk01_CMD= ${DATADIR}/examples/tk/xtk01
xtk02_OLD_CMD= @xtk02_LOCATION@
@@ -49,7 +49,7 @@ CMAKE_ARGS= -DENABLE_java:BOOL=OFF \
-DPL_FREETYPE_FONT_PATH:PATH="${FREEFONT_DIR}" \
-DCMAKE_INSTALL_PKG_CONFIG_DIR:PATH="${PREFIX}/libdata/pkgconfig" \
-DPLD_plmeta:BOOL=OFF
-CFLAGS+= -D_IS_BUILDING_PLPLOT_PORT_
+CFLAGS+= -D_IS_BUILDING_PLPLOT_PORT_ -DSHAPELIB_INCLUDE_DIR=/nonexistent
USE_LDCONFIG= yes
CMAKE_OFF= DEFAULT_NO_QT_DEVICES
LDFLAGS+= -pthread
@@ -59,11 +59,11 @@ PLIST_SUB= PLPLOT_VERSION=${PORTVERSION}
FREEFONT_DIR= ${LOCALBASE}/share/fonts/freefont-ttf
OPTIONS_DEFINE= DOCS FORTRAN GD LUA QHULL2015 QT5 TCLTK THREADS WXGTK X11
-OPTIONS_DEFAULT= QHULL2015 THREADS X11
+OPTIONS_DEFAULT= QHULL2015 THREADS WXGTK X11
OPTIONS_SUB= yes
FORTRAN_USES= fortran
-FORTRAN_CMAKE_BOOL= ENABLE_f95
+FORTRAN_CMAKE_BOOL= ENABLE_fortran
FORTRAN_CONFIGURE_ENV= CMAKE_Fortran_COMPILER="${FC}"
GD_LIB_DEPENDS= libgd.so:graphics/gd \
@@ -115,11 +115,14 @@ X11_USES= xorg
X11_USE= XORG=ice,sm,x11,xext
X11_CMAKE_BOOL= PLD_xcairo PLD_xwin
-post-patch:
+pre-configure:
${REINPLACE_CMD} -e \
's|dl dlopen|c dlopen|' \
${WRKSRC}/cmake/modules/FindLTDL.cmake
${GREP} -lR "/usr/local" ${WRKSRC}/cmake/modules | ${XARGS} \
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g'
+ ${REINPLACE_CMD} -e \
+ 's|shapefil.h|do_not_want_shapefil.h|' \
+ ${WRKSRC}/cmake/modules/FindShapelib.cmake
.include <bsd.port.mk>