aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2022-05-06 17:35:52 +0000
committerHiroki Sato <hrs@FreeBSD.org>2022-05-06 17:36:27 +0000
commit097c9235d921c27255e836c98874e3df62376711 (patch)
tree2717d952dd115bf46ade6497fb555c9b51bd4483
parent8e0b9d2d558fe1cdab743ca0b954ef5a3f578bc2 (diff)
downloadports-097c9235d921c27255e836c98874e3df62376711.tar.gz
ports-097c9235d921c27255e836c98874e3df62376711.zip
security/xmlsec1: update to 1.2.34
-rw-r--r--security/xmlsec1/Makefile4
-rw-r--r--security/xmlsec1/distinfo6
-rw-r--r--security/xmlsec1/files/patch-Makefile.in6
-rw-r--r--security/xmlsec1/files/patch-apps-xmlsec.c11
-rw-r--r--security/xmlsec1/files/patch-src_openssl_openssl__compat.h16
5 files changed, 28 insertions, 15 deletions
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index 6a1359ffb91e..6d6ccfa6822c 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -1,8 +1,7 @@
# Created by: Jim Geovedi <jim@corebsd.or.id>
PORTNAME= xmlsec1
-PORTVERSION= 1.2.29
-PORTREVISION= 2
+PORTVERSION= 1.2.34
CATEGORIES= security
MASTER_SITES= http://www.aleksey.com/xmlsec/download/ \
ftp://ftp.aleksey.com/pub/xmlsec/releases/ \
@@ -25,6 +24,7 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl="${OPENSSLBASE}" \
--with-gcrypt="${LOCALBASE}" \
+ --enable-werror \
--enable-soap \
--disable-docs-build
MAKE_ENV= ABS_BUILDDIR=${WRKSRC} TMPFOLDER=${WRKSRC}
diff --git a/security/xmlsec1/distinfo b/security/xmlsec1/distinfo
index 3a9d3c2debff..baa844e7f7ee 100644
--- a/security/xmlsec1/distinfo
+++ b/security/xmlsec1/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1581996323
-SHA256 (xmlsec1-1.2.29.tar.gz) = b1d1deba966019930f608d1f2b95c40ca3450f1393bcd3a3c001a8ba1d2839ab
-SIZE (xmlsec1-1.2.29.tar.gz) = 1989360
+TIMESTAMP = 1651858077
+SHA256 (xmlsec1-1.2.34.tar.gz) = 52ced4943f35bd7d0818a38298c1528ca4ac8a54440fd71134a07d2d1370a262
+SIZE (xmlsec1-1.2.34.tar.gz) = 1991505
diff --git a/security/xmlsec1/files/patch-Makefile.in b/security/xmlsec1/files/patch-Makefile.in
index 40393dc3aeb4..250d09d1d46d 100644
--- a/security/xmlsec1/files/patch-Makefile.in
+++ b/security/xmlsec1/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2017-12-12 16:05:23.187628000 +0300
-+++ Makefile.in 2017-12-12 16:07:19.241092000 +0300
-@@ -480,7 +480,7 @@
+--- Makefile.in.orig 2022-05-06 17:33:38 UTC
++++ Makefile.in
+@@ -490,7 +490,7 @@ DEFAULT_CRYPTO = @XMLSEC_DEFAULT_CRYPTO@
bin_SCRIPTS = xmlsec1-config
pkgconfig_DATA = xmlsec1.pc @XMLSEC_CRYPTO_PC_FILES_LIST@
pkgconfigdir = $(prefix)/libdata/pkgconfig
diff --git a/security/xmlsec1/files/patch-apps-xmlsec.c b/security/xmlsec1/files/patch-apps-xmlsec.c
new file mode 100644
index 000000000000..ce1c62f81e60
--- /dev/null
+++ b/security/xmlsec1/files/patch-apps-xmlsec.c
@@ -0,0 +1,11 @@
+--- apps/xmlsec.c.orig 2022-05-03 14:36:17 UTC
++++ apps/xmlsec.c
+@@ -1210,7 +1210,7 @@ int main(int argc, const char **argv) {
+ (xmlSecAppCmdLineParamGetInt(&repeatParam, 1) > 0)) {
+
+ repeats = xmlSecAppCmdLineParamGetInt(&repeatParam, 1);
+- fprintf(stderr, "Executed %d tests in %ld msec\n", repeats, (1000 * total_time) / CLOCKS_PER_SEC);
++ fprintf(stderr, "Executed %d tests in %ld msec\n", repeats, (long)(1000 * total_time) / CLOCKS_PER_SEC);
+ }
+
+ goto success;
diff --git a/security/xmlsec1/files/patch-src_openssl_openssl__compat.h b/security/xmlsec1/files/patch-src_openssl_openssl__compat.h
index ab20e6310f2d..21eed249a79a 100644
--- a/security/xmlsec1/files/patch-src_openssl_openssl__compat.h
+++ b/security/xmlsec1/files/patch-src_openssl_openssl__compat.h
@@ -1,11 +1,9 @@
---- src/openssl/openssl_compat.h.orig 2017-09-12 13:21:09 UTC
+--- src/openssl/openssl_compat.h.orig 2022-05-03 14:36:17 UTC
+++ src/openssl/openssl_compat.h
-@@ -49,4 +49,19 @@
+@@ -51,6 +51,21 @@
- #endif /* !defined(XMLSEC_OPENSSL_API_110) */
-
-+/******************************************************************************
-+ *
+ /******************************************************************************
+ *
+ * LibreSSL 2.7+ compatibility (implements most of OpenSSL 1.1 API)
+ *
+ *****************************************************************************/
@@ -19,4 +17,8 @@
+#define X509_OBJECT_free(x) { X509_OBJECT_free_contents(x); free(x); }
+#endif
+
- #endif /* __XMLSEC_OPENSSL_OPENSSL_COMPAT_H__ */
++/******************************************************************************
++ *
+ * boringssl compatibility
+ *
+ *****************************************************************************/