aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-21 17:03:57 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-21 17:03:57 +0000
commit0a06e53ff111126ab64c53724b10933bcf3550ab (patch)
tree14b92f5fafaee69f1482c573c068e2d08c52464c
parent44c9b7aea1b90f5e86f74ecba080ed9f0a7f78f5 (diff)
downloadports-0a06e53ff111126ab64c53724b10933bcf3550ab.tar.gz
ports-0a06e53ff111126ab64c53724b10933bcf3550ab.zip
devel/py-jaraco.context: Remove py-jaraco from RUN_DEPENDS
- Bump PORTREVISION for dependency change
-rw-r--r--devel/py-jaraco.context/Makefile15
1 files changed, 2 insertions, 13 deletions
diff --git a/devel/py-jaraco.context/Makefile b/devel/py-jaraco.context/Makefile
index 3b1fba37692a..635ced2932f7 100644
--- a/devel/py-jaraco.context/Makefile
+++ b/devel/py-jaraco.context/Makefile
@@ -1,6 +1,6 @@
PORTNAME= jaraco.context
PORTVERSION= 4.3.0
-PORTREVISION= 2
+PORTREVISION= 4
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,10 +12,9 @@ WWW= https://github.com/jaraco/jaraco.context
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=56:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.1:devel/py-setuptools_scm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jaraco>=0:devel/py-jaraco@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-black>=0.3.7:devel/py-pytest-black@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-enabler>=0:devel/py-pytest-enabler@${PY_FLAVOR} \
@@ -27,14 +26,4 @@ USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
-POST_PLIST= trim-jaraco-namespace
-
-post-install:
- @${RM} ${STAGEDIR}${PYTHON_SITELIBDIR}/jaraco/__init__.py*
- -@${RM} ${STAGEDIR}${PYTHON_SITELIBDIR}/jaraco/__pycache__/__init__.*
- -@${RMDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}/jaraco/__pycache__
-
-trim-jaraco-namespace:
- @${REINPLACE_CMD} '/jaraco\/__init__\./d; /jaraco\/__pycache__\/__init__\./d' ${TMPPLIST}
-
.include <bsd.port.mk>