aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-11-21 15:56:36 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-11-21 17:23:41 +0000
commit0ab36cf8d98e937794e29170f46d89426ab72483 (patch)
tree353f34faded0f8c9383d9f8c125abb71935f3934
parentc9b438dde00cad00b42aef009a737e12d3f3dc03 (diff)
downloadports-0ab36cf8d98e937794e29170f46d89426ab72483.tar.gz
ports-0ab36cf8d98e937794e29170f46d89426ab72483.zip
graphics/py-pyglet: update to 2.0.0
- Preserve pyglet 1.x as graphics/py-pyglet1 - Add mutual conflicts between graphics/py-pyglet1 and graphics/py-pyglet - Switch all consumers to graphics/py-pyglet1 as it's likely that no consumer is compatible with pyglet 2.x yet
-rw-r--r--devel/py-trimesh/Makefile4
-rw-r--r--games/brainworkshop/Makefile3
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-glooey/Makefile4
-rw-r--r--graphics/py-pyglet/Makefile4
-rw-r--r--graphics/py-pyglet/distinfo6
-rw-r--r--graphics/py-pyglet1/Makefile23
-rw-r--r--graphics/py-pyglet1/distinfo3
-rw-r--r--graphics/py-pyglet1/pkg-descr3
-rw-r--r--math/py-sympy/Makefile3
10 files changed, 45 insertions, 9 deletions
diff --git a/devel/py-trimesh/Makefile b/devel/py-trimesh/Makefile
index 1b43c9c2b500..0eaac75d1bae 100644
--- a/devel/py-trimesh/Makefile
+++ b/devel/py-trimesh/Makefile
@@ -1,6 +1,6 @@
PORTNAME= trimesh
PORTVERSION= 3.5.25
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel cad python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
NEEDED_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}networkx>0:math/py-networkx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyglet>0:graphics/py-pyglet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyglet1>0:graphics/py-pyglet1@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Shapely>0:devel/py-shapely@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}rtree>0:devel/py-rtree@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}svg_path>0:graphics/py-svg.path@${PY_FLAVOR} \
diff --git a/games/brainworkshop/Makefile b/games/brainworkshop/Makefile
index 85c285ee2088..c0ccb9440694 100644
--- a/games/brainworkshop/Makefile
+++ b/games/brainworkshop/Makefile
@@ -1,6 +1,7 @@
PORTNAME= brainworkshop
DISTVERSIONPREFIX= v
DISTVERSION= 5.0.2
+PORTREVISION= 1
CATEGORIES= games python
MAINTAINER= amdmi3@FreeBSD.org
@@ -9,7 +10,7 @@ WWW= https://github.com/samcv/brainworkshop
LICENSE= GPLv1+ # version not specified
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyglet/__init__.py:graphics/py-pyglet@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyglet1>=0:graphics/py-pyglet1@${PY_FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= brain-workshop
diff --git a/graphics/Makefile b/graphics/Makefile
index 4b43687827f6..92fe658afe02 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -914,6 +914,7 @@
SUBDIR += py-pygeoapi
SUBDIR += py-pygeos
SUBDIR += py-pyglet
+ SUBDIR += py-pyglet1
SUBDIR += py-pygraph
SUBDIR += py-pygraphviz
SUBDIR += py-pyinsane2
diff --git a/graphics/py-glooey/Makefile b/graphics/py-glooey/Makefile
index 13ba37d8d979..de4a0287478b 100644
--- a/graphics/py-glooey/Makefile
+++ b/graphics/py-glooey/Makefile
@@ -1,5 +1,6 @@
PORTNAME= glooey
PORTVERSION= 0.3.3
+PORTREVISION= 1
CATEGORIES= graphics x11-toolkits python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +12,8 @@ WWW= https://pypi.org/project/glooey
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyglet>0:graphics/py-pyglet@${PY_FLAVOR} \
+# see https://github.com/kxgames/glooey/issues/56 regarding pyglet2 support
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyglet1>0:graphics/py-pyglet1@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}more-itertools>0:devel/py-more-itertools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}vecrec>0:graphics/py-vecrec@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}autoprop>0:devel/py-autoprop@${PY_FLAVOR} \
diff --git a/graphics/py-pyglet/Makefile b/graphics/py-pyglet/Makefile
index 183751944969..af1047762cda 100644
--- a/graphics/py-pyglet/Makefile
+++ b/graphics/py-pyglet/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pyglet
-PORTVERSION= 1.5.27
+PORTVERSION= 2.0.0
CATEGORIES= graphics multimedia x11-toolkits python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,4 +17,6 @@ USE_GL= gl glu
USE_PYTHON= autoplist distutils
NO_ARCH= yes
+CONFLICTS_INSTALL=${PYTHON_PKGNAMEPREFIX}${PORTNAME}1
+
.include <bsd.port.mk>
diff --git a/graphics/py-pyglet/distinfo b/graphics/py-pyglet/distinfo
index af24f7d16e42..6e48f51122ce 100644
--- a/graphics/py-pyglet/distinfo
+++ b/graphics/py-pyglet/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1663788533
-SHA256 (pyglet-1.5.27.zip) = 4d00e067451f3b10fd51b69764fddab65444372a2da344ee2b35f0a8e6ebf005
-SIZE (pyglet-1.5.27.zip) = 6978692
+TIMESTAMP = 1668703084
+SHA256 (pyglet-2.0.0.zip) = da3069e51d2241b122995982ef99f3eb1226477b3a704920a2e4e649778d09ad
+SIZE (pyglet-2.0.0.zip) = 6639682
diff --git a/graphics/py-pyglet1/Makefile b/graphics/py-pyglet1/Makefile
new file mode 100644
index 000000000000..e9803a2d597a
--- /dev/null
+++ b/graphics/py-pyglet1/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= pyglet
+PORTVERSION= 1.5.27
+CATEGORIES= graphics multimedia x11-toolkits python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 1
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Cross-platform windowing and multimedia library (legacy version)
+WWW= https://pypi.org/project/pyglet/ \
+ https://github.com/pyglet/pyglet
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= display:test gl python:3.6+ pytest zip
+USE_GL= gl glu
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+CONFLICTS_INSTALL=${PYTHON_PKGNAMEPREFIX}${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pyglet1/distinfo b/graphics/py-pyglet1/distinfo
new file mode 100644
index 000000000000..246bf21e8b41
--- /dev/null
+++ b/graphics/py-pyglet1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1668705790
+SHA256 (pyglet-1.5.27.zip) = 4d00e067451f3b10fd51b69764fddab65444372a2da344ee2b35f0a8e6ebf005
+SIZE (pyglet-1.5.27.zip) = 6978692
diff --git a/graphics/py-pyglet1/pkg-descr b/graphics/py-pyglet1/pkg-descr
new file mode 100644
index 000000000000..c04957dbce83
--- /dev/null
+++ b/graphics/py-pyglet1/pkg-descr
@@ -0,0 +1,3 @@
+pyglet provides an object-oriented programming interface for
+developing games and other visually-rich applications for Windows,
+Mac OS X and Linux.
diff --git a/math/py-sympy/Makefile b/math/py-sympy/Makefile
index 21cc2e544990..c6f5b635b66f 100644
--- a/math/py-sympy/Makefile
+++ b/math/py-sympy/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sympy
PORTVERSION= 1.11.1
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,7 +21,7 @@ NO_ARCH= yes
OPTIONS_DEFINE= PYGLET
PYGLET_DESC= Enable plotting support
-PYGLET_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyglet>=1.1.2:graphics/py-pyglet@${PY_FLAVOR}
+PYGLET_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyglet1>=1.1.2:graphics/py-pyglet1@${PY_FLAVOR}
post-patch:
@${REINPLACE_CMD} -e "s#share/man/man1#man/man1#" ${WRKSRC}/setup.py