aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2024-04-03 14:25:54 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2024-04-03 14:26:36 +0000
commit0ab48d13ccccefe5cafcf3cbd979fd4968dbb7be (patch)
tree2c266d5604b503cffb57c551ceab91753b282a94
parente28645651463f6a7c9649f1fd687f42dd2a74b3b (diff)
downloadports-0ab48d13ccccefe5cafcf3cbd979fd4968dbb7be.tar.gz
ports-0ab48d13ccccefe5cafcf3cbd979fd4968dbb7be.zip
www/gitlab-ce: reorder lines to much as possible to make portclippy happy
-rw-r--r--devel/gitaly/Makefile8
-rw-r--r--devel/gitlab-runner/Makefile16
-rw-r--r--devel/gitlab-shell/Makefile10
-rw-r--r--www/gitlab-ce/Makefile41
-rw-r--r--www/gitlab-pages/Makefile5
-rw-r--r--www/gitlab-workhorse/Makefile8
6 files changed, 42 insertions, 46 deletions
diff --git a/devel/gitaly/Makefile b/devel/gitaly/Makefile
index d165f5cf46ae..e122e40307a1 100644
--- a/devel/gitaly/Makefile
+++ b/devel/gitaly/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gitaly
-DISTVERSION= 16.10.1
DISTVERSIONPREFIX= v
+DISTVERSION= 16.10.1
CATEGORIES= devel
MAINTAINER= mfechner@FreeBSD.org
@@ -23,13 +23,13 @@ USES= cpe gmake go:modules,no_targets,1.22 iconv pkgconfig ssl
CPE_VENDOR= gitlab
+USE_GITLAB= yes
+GL_ACCOUNT= gitlab-org
+
MAKE_ENV= GOFLAGS="${GO_BUILDFLAGS}"
# make sure to pass go build options into make process
MAKE_ENV+= ${GO_ENV}
-USE_GITLAB= yes
-GL_ACCOUNT= gitlab-org
-
# for go dependencies
# Gitlab hosts there dependencies on their own platform and not on go-proxy
# so we download the required go.mod file from gitlab
diff --git a/devel/gitlab-runner/Makefile b/devel/gitlab-runner/Makefile
index eeff52843e89..bb8f7654a7d3 100644
--- a/devel/gitlab-runner/Makefile
+++ b/devel/gitlab-runner/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gitlab-runner
-DISTVERSION= 16.10.0
DISTVERSIONPREFIX= v
+DISTVERSION= 16.10.0
CATEGORIES= devel
MASTER_SITES= https://gitlab-runner-downloads.s3.amazonaws.com/master/docker/:dockerx64 \
https://gitlab-runner-downloads.s3.amazonaws.com/master/docker/:dockerarm
@@ -23,6 +23,11 @@ RUN_DEPENDS= bash:shells/bash \
git:devel/git
USES= go:modules,1.22
+USE_GITLAB= yes
+GL_ACCOUNT= gitlab-org
+USE_RC_SUBR= gitlab_runner
+
+GITBRANCH= 16-10-stable
GO_MODULE= gitlab.com/gitlab-org/gitlab-runner
_BUILD_DATE= $$(date -u +%Y-%m-%dT%H:%M:%S%z)
@@ -33,9 +38,6 @@ GO_BUILDFLAGS= -ldflags=" \
-X gitlab.com/gitlab-org/gitlab-runner/common.BUILT=${_BUILD_DATE} \
-X gitlab.com/gitlab-org/gitlab-runner/common.BRANCH=${GITBRANCH} \
-s -w"
-USE_GITLAB= yes
-GL_ACCOUNT= gitlab-org
-GITBRANCH= 16-10-stable
# for go dependencies
# Gitlab hosts there dependencies on their own platform and not on go-proxy
@@ -47,13 +49,11 @@ DISTFILES+= go.mod
EXTRACT_ONLY+= ${DISTFILES:N*.mod\:*:N*.mod:C/:.*//:Nprebuilt*:}
# ---------------------------
-PLIST_FILES= bin/gitlab-runner
-
-USE_RC_SUBR= gitlab_runner
-
USERS= gitlab-runner
GROUPS= gitlab-runner
+PLIST_FILES= bin/gitlab-runner
+
post-patch:
@${MKDIR} ${WRKSRC}/out/docker/
@${CP} ${DISTDIR}/${DIST_SUBDIR}/prebuilt-x86_64.tar.xz ${WRKSRC}/out/docker/
diff --git a/devel/gitlab-shell/Makefile b/devel/gitlab-shell/Makefile
index 7c84718c37e0..dc2a463a2a6b 100644
--- a/devel/gitlab-shell/Makefile
+++ b/devel/gitlab-shell/Makefile
@@ -18,15 +18,13 @@ USES= gmake go:modules,no_targets,1.22 pkgconfig
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
-USERS= git
-GROUPS= git
-
-#INSTALL_TARGET= install-strip
-ALL_TARGET= build
-
MAKE_ENV= GOFLAGS="${GO_BUILDFLAGS}"
# make sure to pass go build options into make process
MAKE_ENV+= ${GO_ENV}
+ALL_TARGET= build
+
+USERS= git
+GROUPS= git
# for go dependencies
# Gitlab hosts there dependencies on their own platform and not on go-proxy
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index 24f5db72c97a..cfaa5bdc0412 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -286,32 +286,12 @@ BUILD_DEPENDS= gem:devel/ruby-gems \
RUN_DEPENDS= ${MY_DEPENDS}
-CONFLICTS_INSTALL= gitolite \
- gitolite2 \
- gogs \
- gitea \
- gitosis
-
USES= go:modules nodejs:env ruby shebangfix
-USE_RC_SUBR= gitlab
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
GL_PROJECT= gitlab-foss
-
-USERS= git
-GROUPS= git
-
-NO_BUILD= yes
-
-NO_ARCH= yes
-
-OPTIONS_DEFINE= KERBEROS
-OPTIONS_DEFAULT= KERBEROS
-
-KERBEROS_BUILD_DEPENDS= rubygem-timfel-krb5-auth>=0.8<1:security/rubygem-timfel-krb5
-KERBEROS_RUN_DEPENDS= rubygem-timfel-krb5-auth>=0.8<1:security/rubygem-timfel-krb5
-KERBEROS_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-patch-Gemfile-kerberos-off
+USE_RC_SUBR= gitlab
SHEBANG_FILES= scripts/build_qa_image \
scripts/build_gdk_image \
@@ -326,6 +306,25 @@ SHEBANG_FILES= scripts/build_qa_image \
qa/gdk/entrypoint \
qa/bin/test
+CONFLICTS_INSTALL= gitolite \
+ gitolite2 \
+ gogs \
+ gitea \
+ gitosis
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+USERS= git
+GROUPS= git
+
+OPTIONS_DEFINE= KERBEROS
+OPTIONS_DEFAULT= KERBEROS
+
+KERBEROS_BUILD_DEPENDS= rubygem-timfel-krb5-auth>=0.8<1:security/rubygem-timfel-krb5
+KERBEROS_RUN_DEPENDS= rubygem-timfel-krb5-auth>=0.8<1:security/rubygem-timfel-krb5
+KERBEROS_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-patch-Gemfile-kerberos-off
+
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/config/gitlab.yml.example \
${WRKSRC}/config/puma.rb.example \
diff --git a/www/gitlab-pages/Makefile b/www/gitlab-pages/Makefile
index 0c5c5dd5ddf9..f52643bb0332 100644
--- a/www/gitlab-pages/Makefile
+++ b/www/gitlab-pages/Makefile
@@ -13,15 +13,14 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go:modules,1.22
-GO_MODULE= gitlab.com/gitlab-org/gitlab-pages
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
+USE_RC_SUBR= gitlab_pages
+GO_MODULE= gitlab.com/gitlab-org/gitlab-pages
GO_BUILDFLAGS= -ldflags="-X 'main.VERSION=${PORTVERSION}' -X 'main.REVISION=${GL_TAGNAME}'"
-USE_RC_SUBR= gitlab_pages
-
USERS= gitlab-pages
GROUPS= gitlab-pages
diff --git a/www/gitlab-workhorse/Makefile b/www/gitlab-workhorse/Makefile
index 6ddad411c980..915380230d97 100644
--- a/www/gitlab-workhorse/Makefile
+++ b/www/gitlab-workhorse/Makefile
@@ -14,15 +14,15 @@ BUILD_DEPENDS= git>=2.42.0:devel/git
RUN_DEPENDS= p5-Image-ExifTool>=0:graphics/p5-Image-ExifTool
USES= gmake go:modules,no_targets,1.22
+USE_GITLAB= yes
+GL_ACCOUNT= gitlab-org
+GL_PROJECT= gitlab-foss
MAKE_ENV= GOFLAGS="${GO_BUILDFLAGS}"
MAKE_ENV+= ${GO_ENV}
WRKSRC_SUBDIR= workhorse
# found in work/gitlab-foss*/workhorse/go.mod
#GO_MODULE= gitlab.com/gitlab-org/gitlab/workhorse
-USE_GITLAB= yes
-GL_ACCOUNT= gitlab-org
-GL_PROJECT= gitlab-foss
# for go dependencies
# Gitlab hosts there dependencies on their own platform and not on go-proxy
@@ -42,11 +42,11 @@ go-post-fetch:
${SETENV} ${GO_ENV} GOPROXY=${GO_GOPROXY} ${GO_CMD} mod download -x all)
# ---------------------------
+PLIST_DIRS= ${WWWDIR}
PLIST_FILES= bin/gitlab-resize-image \
bin/gitlab-workhorse \
bin/gitlab-zip-cat \
bin/gitlab-zip-metadata
-PLIST_DIRS= ${WWWDIR}
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/www/${PORTNAME}