aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-10-30 21:34:22 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-10-31 00:12:57 +0000
commit0b0fc74c665c146c472aa72ff35dc72c8b7bbe34 (patch)
tree200d1bd6eadb1a7c75352963295789d1e52839d3
parentac5b3786e811c8948c098aca33ca26ee42f4a11f (diff)
devel/git-workspace: Fix build on i386
Reported by: fallout (cherry picked from commit 176fe177754bf8e71a7546dec46ec00ef25231fc)
-rw-r--r--devel/git-workspace/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/git-workspace/Makefile b/devel/git-workspace/Makefile
index ddebe7dbef69..4706b0e4c844 100644
--- a/devel/git-workspace/Makefile
+++ b/devel/git-workspace/Makefile
@@ -17,6 +17,8 @@ USES= cargo localbase:ldflags
USE_GITHUB= yes
GH_ACCOUNT= orf
+RUSTFLAGS= ${ARCH:S/i386/YES/:C/^[a-z].*//:S/YES/-C target-feature=+sse,+sse2/} # add sse sse2 target-features only on i386
+
CARGO_CRATES= adler-1.0.2 \
aho-corasick-1.1.3 \
alloc-no-stdlib-2.0.4 \