aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-03 21:21:00 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-03 21:29:38 +0000
commit0b85330cae8bff2a72207a626a6b6735c07cf497 (patch)
tree6f0d313f1795d675a6c57d3b9535bfb514463c8c
parentd5d8a4e4739c41ba8084d63107b890ad57ccdd2b (diff)
downloadports-0b85330cae8bff2a72207a626a6b6735c07cf497.tar.gz
ports-0b85330cae8bff2a72207a626a6b6735c07cf497.zip
math/couenne: Install MiniZinc interface
-rw-r--r--math/couenne/Makefile10
-rw-r--r--math/couenne/files/couenne.msc.in8
-rw-r--r--math/couenne/pkg-plist1
3 files changed, 18 insertions, 1 deletions
diff --git a/math/couenne/Makefile b/math/couenne/Makefile
index ed0986eb2d67..b2c61b658f58 100644
--- a/math/couenne/Makefile
+++ b/math/couenne/Makefile
@@ -1,7 +1,7 @@
PORTNAME= couenne
DISTVERSIONPREFIX= releases/
DISTVERSION= 0.5.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= math
PKGNAMEPREFIX= coin-or-
@@ -33,4 +33,12 @@ CONFIGURE_ARGS= --with-nauty-incdir=${LOCALBASE}/include/nauty --with-nauty-lib=
INSTALL_TARGET= install-strip
+SUB_FILES= ${PORTNAME}.msc
+SUB_LIST= PORTVERSION=${PORTVERSION}
+
+post-install:
+ # install MiniZinc configuration file
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/minizinc/solvers
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.msc ${STAGEDIR}${PREFIX}/share/minizinc/solvers
+
.include <bsd.port.mk>
diff --git a/math/couenne/files/couenne.msc.in b/math/couenne/files/couenne.msc.in
new file mode 100644
index 000000000000..d4c15c6bc233
--- /dev/null
+++ b/math/couenne/files/couenne.msc.in
@@ -0,0 +1,8 @@
+{
+ "id" : "org.coin-or.couenne",
+ "name" : "Couenne",
+ "executable" : "%%PREFIX%%/bin/couenne",
+ "version": "%%PORTVERSION%%",
+ "supportsFzn":false,
+ "supportsNL":true
+}
diff --git a/math/couenne/pkg-plist b/math/couenne/pkg-plist
index 9938131cefc5..976e53a41319 100644
--- a/math/couenne/pkg-plist
+++ b/math/couenne/pkg-plist
@@ -95,3 +95,4 @@ share/coin/doc/Couenne/AUTHORS
share/coin/doc/Couenne/LICENSE
share/coin/doc/Couenne/README
share/coin/doc/Couenne/couenne_addlibs.txt
+share/minizinc/solvers/couenne.msc