aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2022-05-20 07:59:59 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2022-06-08 08:23:05 +0000
commit0b95c0475f367ceda5e8253f89501f9b861e344d (patch)
treed992a425c24fec628d4671c40229d4c3786da577
parentcc3e89f7d60e69ef058fd1a0e64dd62275b157d4 (diff)
downloadports-0b95c0475f367ceda5e8253f89501f9b861e344d.tar.gz
ports-0b95c0475f367ceda5e8253f89501f9b861e344d.zip
x11-drivers/xf86-video-amdgpu: Update to 22.0.0
While here pet portlint. Sponsored by: Beckhoff Automation GmbH & Co. KG Differential Revision: https://reviews.freebsd.org/D35269
-rw-r--r--x11-drivers/xf86-video-amdgpu/Makefile19
-rw-r--r--x11-drivers/xf86-video-amdgpu/distinfo10
-rw-r--r--x11-drivers/xf86-video-amdgpu/files/patch-src_amdgpu__drm__queue.c47
-rw-r--r--x11-drivers/xf86-video-amdgpu/files/patch-src_amdgpu__kms.c11
4 files changed, 15 insertions, 72 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/Makefile b/x11-drivers/xf86-video-amdgpu/Makefile
index 134aa97a9a3c..664c8e7d3145 100644
--- a/x11-drivers/xf86-video-amdgpu/Makefile
+++ b/x11-drivers/xf86-video-amdgpu/Makefile
@@ -1,26 +1,27 @@
# this port is for future amdgpu kernel support testing.
PORTNAME= xf86-video-amdgpu
-PORTVERSION= 19.1.0
-PORTREVISION= 2
+PORTVERSION= 22.0.0
CATEGORIES= x11-drivers
+PATCH_SITES= https://gitlab.freedesktop.org/xorg/driver/${PORTNAME}/-/commit/
+PATCHFILES+= 77b13493.patch:-p1 # https://gitlab.freedesktop.org/xorg/driver/xf86-video-amdgpu/-/merge_requests/77
+
MAINTAINER= x11@FreeBSD.org
COMMENT= X.Org amdgpu display driver
-PATCH_SITES= https://gitlab.freedesktop.org/xorg/driver/${PORTNAME}/-/commit/
-PATCHFILES+= edcbe5f52ddfceee3d66d69bbcebbceac06b6d0d.patch:-p1
-
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
+# No amdgpu kernel driver on non-x86 and PC98.
+ONLY_FOR_ARCHS= aarch64 amd64 i386 powerpc64le
+ONLY_FOR_ARCHS_REASON= KMS is required and currently only available on x86/arm64/powerpc64le
+
LIB_DEPENDS= libdrm_amdgpu.so:graphics/libdrm
-USES= gl xorg-cat:driver
+EXTRACT_SUFX= .tar.xz
+USES= gl xorg-cat:driver tar:xz
USE_GL= gbm
-# No amdgpu kernel driver on non-x86 and PC98.
-ONLY_FOR_ARCHS= aarch64 i386 amd64 powerpc64le
-ONLY_FOR_ARCHS_REASON= KMS is required and currently only available on x86/arm64/powerpc64le
CONFIGURE_ARGS+=--disable-udev
diff --git a/x11-drivers/xf86-video-amdgpu/distinfo b/x11-drivers/xf86-video-amdgpu/distinfo
index 6787da0e094b..c6eb8f643809 100644
--- a/x11-drivers/xf86-video-amdgpu/distinfo
+++ b/x11-drivers/xf86-video-amdgpu/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1597786182
-SHA256 (xorg/driver/xf86-video-amdgpu-19.1.0.tar.bz2) = 4f0ea4e0ae61995ac2b7c72433d31deab63b60c78763020aaa1b28696124fe5d
-SIZE (xorg/driver/xf86-video-amdgpu-19.1.0.tar.bz2) = 441746
-SHA256 (xorg/driver/edcbe5f52ddfceee3d66d69bbcebbceac06b6d0d.patch) = 6a0c855a3c6d1a747055ee5c616c2a155b0e798485b3de4028ccfef420835084
-SIZE (xorg/driver/edcbe5f52ddfceee3d66d69bbcebbceac06b6d0d.patch) = 848
+TIMESTAMP = 1654594086
+SHA256 (xorg/driver/xf86-video-amdgpu-22.0.0.tar.xz) = 9d23fb602915dc3ccde92aa4d1e9485e7e54eaae2f41f485e55eb20761778266
+SIZE (xorg/driver/xf86-video-amdgpu-22.0.0.tar.xz) = 376956
+SHA256 (xorg/driver/77b13493.patch) = 1e76bb36f7fd69e0556ae6b5a7d2331a711367b6a7421adc221f2fcae1aff82b
+SIZE (xorg/driver/77b13493.patch) = 1269
diff --git a/x11-drivers/xf86-video-amdgpu/files/patch-src_amdgpu__drm__queue.c b/x11-drivers/xf86-video-amdgpu/files/patch-src_amdgpu__drm__queue.c
deleted file mode 100644
index bbf1c20c91ac..000000000000
--- a/x11-drivers/xf86-video-amdgpu/files/patch-src_amdgpu__drm__queue.c
+++ /dev/null
@@ -1,47 +0,0 @@
---- src/amdgpu_drm_queue.c.orig 2016-09-20 08:19:15 UTC
-+++ src/amdgpu_drm_queue.c
-@@ -61,7 +61,7 @@ amdgpu_drm_queue_handler(int fd, unsigne
- unsigned int usec, void *user_ptr)
- {
- uintptr_t seq = (uintptr_t)user_ptr;
-- struct amdgpu_drm_queue_entry *e, *tmp;
-+ struct amdgpu_drm_queue_entry *e = NULL, *tmp;
-
- xorg_list_for_each_entry_safe(e, tmp, &amdgpu_drm_queue, list) {
- if (e->seq == seq) {
-@@ -133,7 +133,7 @@ amdgpu_drm_abort_one(struct amdgpu_drm_q
- void
- amdgpu_drm_abort_client(ClientPtr client)
- {
-- struct amdgpu_drm_queue_entry *e;
-+ struct amdgpu_drm_queue_entry *e = NULL;
-
- xorg_list_for_each_entry(e, &amdgpu_drm_queue, list) {
- if (e->client == client)
-@@ -147,7 +147,7 @@ amdgpu_drm_abort_client(ClientPtr client
- void
- amdgpu_drm_abort_entry(uintptr_t seq)
- {
-- struct amdgpu_drm_queue_entry *e, *tmp;
-+ struct amdgpu_drm_queue_entry *e = NULL, *tmp;
-
- xorg_list_for_each_entry_safe(e, tmp, &amdgpu_drm_queue, list) {
- if (e->seq == seq) {
-@@ -163,7 +163,7 @@ amdgpu_drm_abort_entry(uintptr_t seq)
- void
- amdgpu_drm_abort_id(uint64_t id)
- {
-- struct amdgpu_drm_queue_entry *e, *tmp;
-+ struct amdgpu_drm_queue_entry *e = NULL, *tmp;
-
- xorg_list_for_each_entry_safe(e, tmp, &amdgpu_drm_queue, list) {
- if (e->id == id) {
-@@ -191,7 +191,7 @@ amdgpu_drm_queue_init()
- void
- amdgpu_drm_queue_close(ScrnInfoPtr scrn)
- {
-- struct amdgpu_drm_queue_entry *e, *tmp;
-+ struct amdgpu_drm_queue_entry *e = NULL, *tmp;
-
- xorg_list_for_each_entry_safe(e, tmp, &amdgpu_drm_queue, list) {
- if (e->crtc->scrn == scrn)
diff --git a/x11-drivers/xf86-video-amdgpu/files/patch-src_amdgpu__kms.c b/x11-drivers/xf86-video-amdgpu/files/patch-src_amdgpu__kms.c
deleted file mode 100644
index 885b2058eef4..000000000000
--- a/x11-drivers/xf86-video-amdgpu/files/patch-src_amdgpu__kms.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/amdgpu_kms.c.orig 2016-11-17 06:07:48 UTC
-+++ src/amdgpu_kms.c
-@@ -723,7 +723,7 @@ amdgpu_dirty_update(ScrnInfoPtr scrn)
- {
- AMDGPUInfoPtr info = AMDGPUPTR(scrn);
- ScreenPtr screen = scrn->pScreen;
-- PixmapDirtyUpdatePtr ent;
-+ PixmapDirtyUpdatePtr ent = NULL;
- RegionPtr region;
-
- xorg_list_for_each_entry(ent, &screen->pixmap_dirty_list, ent) {