aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGoran Meki? <meka@tilda.center>2021-06-23 20:30:35 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2021-06-23 20:34:47 +0000
commit0c6ce3c9c26d878acf943d53fb2a01ba602b71c2 (patch)
tree6f7b2e7e72776a940c63731c9441782225a6114c
parent64fbe3630590d931074878a8b886d41cbe8a23e0 (diff)
downloadports-0c6ce3c9c26d878acf943d53fb2a01ba602b71c2.tar.gz
ports-0c6ce3c9c26d878acf943d53fb2a01ba602b71c2.zip
devel/py-pytest: Update to 6.2.4
PR: 256624
-rw-r--r--devel/py-pytest/Makefile12
-rw-r--r--devel/py-pytest/distinfo6
-rw-r--r--devel/py-pytest/files/patch-testing-test_parseopt.py11
3 files changed, 7 insertions, 22 deletions
diff --git a/devel/py-pytest/Makefile b/devel/py-pytest/Makefile
index 2f87d8b80937..478833803b41 100644
--- a/devel/py-pytest/Makefile
+++ b/devel/py-pytest/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pytest
-PORTVERSION= 4.6.11
+PORTVERSION= 6.2.4
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,6 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}atomicwrites>=1.0:devel/py-atomicwrites@${PY
${PYTHON_PKGNAMEPREFIX}pluggy>=0.12<1.0:devel/py-pluggy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}py>=1.5.0:devel/py-py@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}iniconfig>=0:devel/py-iniconfig@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wcwidth>=0:devel/py-wcwidth@${PY_FLAVOR}
TEST_DEPENDS= bash:shells/bash \
lsof:sysutils/lsof \
@@ -29,10 +30,10 @@ TEST_DEPENDS= bash:shells/bash \
${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pexpect>=0:misc/py-pexpect@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-xdist>=1.13:devel/py-pytest-xdist@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xmlschema>=0:textproc/py-xmlschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}unittest2>=0:devel/py-unittest2@${PY_FLAVOR}
USES= python:3.6+
@@ -46,12 +47,7 @@ NO_ARCH= yes
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0.12:devel/py-importlib-metadata@${PY_FLAVOR}
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' ${WRKSRC}/testing/test_parseopt.py
-
-# test_cache_failure_warns fails
-# https://github.com/pytest-dev/pytest/issues/1845
do-test:
- cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs -k 'not test_cache_failure_warns'
+ cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs
.include <bsd.port.post.mk>
diff --git a/devel/py-pytest/distinfo b/devel/py-pytest/distinfo
index db173fdad5c5..6ccf342cc812 100644
--- a/devel/py-pytest/distinfo
+++ b/devel/py-pytest/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620405525
-SHA256 (pytest-4.6.11.tar.gz) = 50fa82392f2120cc3ec2ca0a75ee615be4c479e66669789771f1758332be4353
-SIZE (pytest-4.6.11.tar.gz) = 952305
+TIMESTAMP = 1623756059
+SHA256 (pytest-6.2.4.tar.gz) = 50bcad0a0b9c5a72c8e4e7c9855a3ad496ca6a881a3641b4260605450772c54b
+SIZE (pytest-6.2.4.tar.gz) = 1118084
diff --git a/devel/py-pytest/files/patch-testing-test_parseopt.py b/devel/py-pytest/files/patch-testing-test_parseopt.py
deleted file mode 100644
index 22683ffee3af..000000000000
--- a/devel/py-pytest/files/patch-testing-test_parseopt.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- testing/test_parseopt.py.orig 2020-06-05 12:09:03 UTC
-+++ testing/test_parseopt.py
-@@ -305,7 +305,7 @@ def test_argcomplete(testdir, monkeypatch):
- # redirect output from argcomplete to stdin and stderr is not trivial
- # http://stackoverflow.com/q/12589419/1307905
- # so we use bash
-- fp.write('COMP_WORDBREAKS="$COMP_WORDBREAKS" python -m pytest 8>&1 9>&2')
-+ fp.write('COMP_WORDBREAKS="$COMP_WORDBREAKS" %%PYTHON_CMD%% -m pytest 8>&1 9>&2')
- # alternative would be exteneded Testdir.{run(),_run(),popen()} to be able
- # to handle a keyword argument env that replaces os.environ in popen or
- # extends the copy, advantage: could not forget to restore