aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-09-20 07:55:56 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-09-20 07:57:05 +0000
commit0ca2c84f88cd0a83e16370385435cb326b8ba6df (patch)
tree49cb133502e38fad2cefdfe7c78562b646c1bb00
parenta12f0cc2ebe0735a14824e8be694c074ffffdc02 (diff)
downloadports-0ca2c84f88cd0a83e16370385435cb326b8ba6df.tar.gz
ports-0ca2c84f88cd0a83e16370385435cb326b8ba6df.zip
math/ceres-solver: Backport commit: Enable compatibility with SuiteSparse 7.2.0
Suggested by: thierry@freebsd.org
-rw-r--r--math/ceres-solver/Makefile2
-rw-r--r--math/ceres-solver/files/patch-internal_ceres_covariance__impl.cc14
2 files changed, 15 insertions, 1 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index 7c25a663e3c9..4875d17ff833 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ceres-solver
DISTVERSION= 2.1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/ceres-solver/files/patch-internal_ceres_covariance__impl.cc b/math/ceres-solver/files/patch-internal_ceres_covariance__impl.cc
new file mode 100644
index 000000000000..88872405f429
--- /dev/null
+++ b/math/ceres-solver/files/patch-internal_ceres_covariance__impl.cc
@@ -0,0 +1,14 @@
+- backport of the commit Enable compatibility with SuiteSparse 7.2.0
+- see https://github.com/ceres-solver/ceres-solver/commit/9cca671273c2f205ca7350422f48b7b119c5dd78
+
+--- internal/ceres/covariance_impl.cc.orig 2023-09-20 07:40:12 UTC
++++ internal/ceres/covariance_impl.cc
+@@ -630,7 +630,7 @@ bool CovarianceImpl::ComputeCovarianceValuesUsingSuite
+ // separately.
+ const SuiteSparse_long rank = SuiteSparseQR<double>(SPQR_ORDERING_BESTAMD,
+ SPQR_DEFAULT_TOL,
+- cholmod_jacobian.ncol,
++ static_cast<int64_t>(cholmod_jacobian.ncol),
+ &cholmod_jacobian,
+ &R,
+ &permutation,