aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-04-23 07:03:34 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-04-23 16:13:16 +0000
commit0cad1d8425c36f4c99397d197d0f1871d9d5c292 (patch)
treee9cb8a1b297a1c900e5b2cfc2f0251b448ee14cd
parentcdf1aef1ccda3584edab59654b173e55500eae6c (diff)
downloadports-0cad1d8425c36f4c99397d197d0f1871d9d5c292.tar.gz
ports-0cad1d8425c36f4c99397d197d0f1871d9d5c292.zip
gecko: switch to llvm12
May help with LTO and -march=native issues.
-rw-r--r--Mk/bsd.gecko.mk2
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--www/firefox-esr/Makefile1
-rw-r--r--www/firefox/Makefile2
4 files changed, 4 insertions, 2 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 70471bd03281..b611e4421b3c 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -92,7 +92,7 @@ MOZ_EXPORT+= LLVM_OBJDUMP="${LOCALBASE}/bin/llvm-objdump${LLVM_DEFAULT}"
.endif
# Ignore Mk/bsd.default-versions.mk but respect make.conf(5)
.if !defined(DEFAULT_VERSIONS) || ! ${DEFAULT_VERSIONS:Mllvm*}
-LLVM_DEFAULT= 11 # bump if not latest release
+LLVM_DEFAULT= 12 # bump if not latest release
.endif
# Require newer Clang than what's in base system unless user opted out
. if ${CC} == cc && ${CXX} == c++ && exists(/usr/lib/libc++.so)
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 871f5d2168ba..efa3ed52e127 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -2,6 +2,7 @@
PORTNAME= thunderbird
DISTVERSION= 78.10.0
+PORTREVISION= 1
CATEGORIES= mail news net-im
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 67b63e15bedc..2c823a5b160f 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -2,6 +2,7 @@
PORTNAME= firefox
DISTVERSION= 78.10.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 30556e7188b7..1666c2000095 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -2,7 +2,7 @@
PORTNAME= firefox
DISTVERSION= 88.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \