aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-24 02:03:42 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-24 02:03:42 +0000
commit0cf06a09a9311411881eca000d4f5354297f569e (patch)
tree734bcc71e95c02baa128974dae1df38d333e00ee
parent6281532dad65ce42ad6341ed46ca481278d70a50 (diff)
downloadports-0cf06a09a9311411881eca000d4f5354297f569e.tar.gz
ports-0cf06a09a9311411881eca000d4f5354297f569e.zip
emulators/qemu31: fix build on powerpc
/wrkdirs/usr/ports/emulators/qemu31/work/qemu-3.1.1.1/tcg/ppc/tcg-target.inc.c:1922:3: error: "Unhandled abi"
-rw-r--r--emulators/qemu31/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/emulators/qemu31/Makefile b/emulators/qemu31/Makefile
index e2d6f023cffa..503131d3b9a6 100644
--- a/emulators/qemu31/Makefile
+++ b/emulators/qemu31/Makefile
@@ -91,6 +91,7 @@ PORTDOCS?= docs qemu-doc.html qemu-doc.txt qemu-ga-ref.html qemu-ga-ref.txt \
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
+CFLAGS_powerpc= -D_CALL_SYSV
CONFIGURE_ARGS?=--localstatedir=/var --extra-ldflags=-L\"/usr/lib\" \
--extra-ldflags=-L\"${LOCALBASE}/lib\" --disable-libssh2 --enable-debug \
--prefix=${PREFIX} --cc=${CC} --enable-netmap --enable-docs --disable-kvm \