aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2021-05-24 06:29:14 +0000
committerGleb Popov <arrowd@FreeBSD.org>2021-05-24 06:32:02 +0000
commit0da1ad3eb5beb90ab1b86ff0e478a9ab0f08baca (patch)
tree720690de4f6b3757e16069afc4c15d4df161041a
parent67229851ac6f93f056c20ea21460e5fc6fa12853 (diff)
downloadports-0da1ad3eb5beb90ab1b86ff0e478a9ab0f08baca.tar.gz
ports-0da1ad3eb5beb90ab1b86ff0e478a9ab0f08baca.zip
Uses/cabal.mk: Make cabal-extract-deps target overridable.
-rw-r--r--Mk/Uses/cabal.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/Mk/Uses/cabal.mk b/Mk/Uses/cabal.mk
index bc576b73d091..5154bcca81b3 100644
--- a/Mk/Uses/cabal.mk
+++ b/Mk/Uses/cabal.mk
@@ -156,14 +156,16 @@ cabal-extract: ${WRKDIR}
# Fetches and unpacks dependencies sources for a cabal-extract'ed package.
# Builds them as side-effect.
+. if !target(cabal-extract-deps)
cabal-extract-deps:
-. if ${cabal_ARGS:Mhpack}
+. if ${cabal_ARGS:Mhpack}
cd ${WRKSRC} && ${SETENV} HOME=${CABAL_HOME} hpack
-. endif
+. endif
cd ${WRKSRC} && \
${SETENV} ${LOCALE_ENV} HOME=${CABAL_HOME} cabal new-configure --disable-benchmarks --disable-tests --flags="${CABAL_FLAGS}" ${CONFIGURE_ARGS}
cd ${WRKSRC} && \
${SETENV} ${LOCALE_ENV} HOME=${CABAL_HOME} cabal new-build --disable-benchmarks --disable-tests --dependencies-only ${BUILD_ARGS}
+. endif
# Generates USE_CABAL= ... line ready to be pasted into the port based on artifacts of cabal-extract-deps.
make-use-cabal: