diff options
author | Muhammad Moinur Rahman <bofh@FreeBSD.org> | 2024-07-27 12:13:00 +0000 |
---|---|---|
committer | Muhammad Moinur Rahman <bofh@FreeBSD.org> | 2024-07-27 13:06:58 +0000 |
commit | 0f438952da055c26e2b55288f2e406bc5b5e474a (patch) | |
tree | 466d8d43586178f4939b5c517c4191a4f369388b | |
parent | bbf559f07f4499e782f339cfdb3f13826deaa271 (diff) |
lang/php81: Fix build with libxml 2.12 and newer
- Rename rc script to comply to the rc scripting recommendations [1]
PR: 280153, 280134 [1]
Co-authored-by: Alexander Leidinger <netchild@FreeBSD.org>
Co-authored-by: Daniel Engberg <diizzy@FreeBSD.org>
-rw-r--r-- | UPDATING | 15 | ||||
-rw-r--r-- | lang/php81/Makefile | 8 | ||||
-rw-r--r-- | lang/php81/distinfo | 6 | ||||
-rw-r--r-- | lang/php81/files/php_fpm.in (renamed from lang/php81/files/php-fpm.in) | 6 |
4 files changed, 29 insertions, 6 deletions
@@ -5,6 +5,21 @@ they are unavoidable. You should get into the habit of checking this file for changes each time you update your ports collection, before attempting any port upgrades. +20240727: + AFFECTS: lang/php81 + AUTHOR: netchildFreeBSD.org + + The start scripts of php-fpm have been renamed to php_fpm for improved + compatibility with other parts of the system. The automatic start at boot + (rc.conf variable settings) is not affected, but if you have some other + automatism you may want to change + ".../etc/rc.d/php-fpm" to ".../etc/rc.d/php_fpm" + or + "service php-fpm ..." to "service php_fpm ..." + + If you have custom start scripts which depend upon php-fpm, you need to + change the REQUIRE lines in them from "php-fpm" to "php_fpm". + 20240726: AFFECTS: users of archivers/py-borgbackup AUTHOR: mandree@FreeBSD.org diff --git a/lang/php81/Makefile b/lang/php81/Makefile index 750403b7109c..f49642639ecd 100644 --- a/lang/php81/Makefile +++ b/lang/php81/Makefile @@ -1,6 +1,6 @@ PORTNAME= php81 DISTVERSION= 8.1.29 -PORTREVISION?= 0 +PORTREVISION?= 1 CATEGORIES?= lang devel www MASTER_SITES= PHP/distributions DISTNAME= php-${DISTVERSION} @@ -21,6 +21,10 @@ PHP_VER= 81 CONFLICTS_INSTALL?= php[0-9][0-9]${PKGNAMESUFFIX} .if !defined(PKGNAMESUFFIX) +PATCH_SITES= https://github.com/php/php-src/commit/ +PATCHFILES= 0a39890c967aa57225bb6bdf4821aff7a3a3c082.patch:-p1 \ + 061058a9b1bbd90d27d97d79aebcf2b5029767b0.patch:-p1 + LIB_DEPENDS= libargon2.so:security/libargon2 \ libpcre2-8.so:devel/pcre2 @@ -79,7 +83,7 @@ FPM_CONFIGURE_ON= --enable-fpm \ --with-fpm-group=${WWWGRP} \ --with-fpm-user=${WWWOWN} FPM_VARS= PHP_SAPI+=fpm \ - USE_RC_SUBR+=php-fpm + USE_RC_SUBR+=php_fpm IPV6_CONFIGURE_OFF= --disable-ipv6 LINKTHR_LIBS= -lpthread MYSQLND_CONFIGURE_ON= --enable-mysqlnd diff --git a/lang/php81/distinfo b/lang/php81/distinfo index dc21da65012f..c70ab757f03e 100644 --- a/lang/php81/distinfo +++ b/lang/php81/distinfo @@ -1,3 +1,7 @@ -TIMESTAMP = 1717709327 +TIMESTAMP = 1722079462 SHA256 (php-8.1.29.tar.xz) = 288884af60581d4284baba2ace9ca6d646f72facbd3e3c2dd2acc7fe6f903536 SIZE (php-8.1.29.tar.xz) = 11826292 +SHA256 (0a39890c967aa57225bb6bdf4821aff7a3a3c082.patch) = 5f634c23b5f4e23a3984dbb38cfdd119ca7e0441b01f7f4bc48a650454b0d5d3 +SIZE (0a39890c967aa57225bb6bdf4821aff7a3a3c082.patch) = 2286 +SHA256 (061058a9b1bbd90d27d97d79aebcf2b5029767b0.patch) = ee211a60cf3f2bb6c524ffa49b7e8508967c7b75559c90328237bc5cc69e6f4e +SIZE (061058a9b1bbd90d27d97d79aebcf2b5029767b0.patch) = 10396 diff --git a/lang/php81/files/php-fpm.in b/lang/php81/files/php_fpm.in index 9f753ea485e9..12253b537b2e 100644 --- a/lang/php81/files/php-fpm.in +++ b/lang/php81/files/php_fpm.in @@ -1,14 +1,14 @@ #!/bin/sh -# PROVIDE: php-fpm +# PROVIDE: php_fpm # REQUIRE: LOGIN # KEYWORD: shutdown # # Add the following line to /etc/rc.conf to enable php-fpm: -# php-fpm_enable (bool): Set to "NO" by default. +# php_fpm_enable (bool): Set to "NO" by default. # Set it to "YES" to enable php-fpm -# php-fpm_profiles (str): Set to "" by default. +# php_fpm_profiles (str): Set to "" by default. # Define your profiles here. # php_fpm_pid_prefix (str): Set to "" by default. # When using profiles manually assign value to "php_fpm_" |