aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2021-10-30 10:44:54 +0000
committerBernard Spil <brnrd@FreeBSD.org>2021-10-30 10:44:54 +0000
commit0f488da862dbbc4fba0b9ba694797a357d6e1199 (patch)
tree1bc8a893773e8c752a273bb01866bd53ab02adb3
parentc71f5a10a7112de6ffe8331ac2a2d2c5244ab69d (diff)
mail/roundcube-twofactor_gauthenticator: Add port
-rw-r--r--mail/Makefile1
-rw-r--r--mail/roundcube-twofactor_gauthenticator/Makefile36
-rw-r--r--mail/roundcube-twofactor_gauthenticator/distinfo3
-rw-r--r--mail/roundcube-twofactor_gauthenticator/files/pkg-message.in13
-rw-r--r--mail/roundcube-twofactor_gauthenticator/pkg-descr4
-rw-r--r--mail/roundcube-twofactor_gauthenticator/pkg-plist45
6 files changed, 102 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index fe52f7df0018..bc1a3e9a7e24 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -564,6 +564,7 @@
SUBDIR += roundcube-mvision2
SUBDIR += roundcube-sauserprefs
SUBDIR += roundcube-thunderbird_labels
+ SUBDIR += roundcube-twofactor_gauthenticator
SUBDIR += roundcube-umich
SUBDIR += roundcube-veximaccountadmin
SUBDIR += roundcube-yubikey_auth
diff --git a/mail/roundcube-twofactor_gauthenticator/Makefile b/mail/roundcube-twofactor_gauthenticator/Makefile
new file mode 100644
index 000000000000..f51438c8df8e
--- /dev/null
+++ b/mail/roundcube-twofactor_gauthenticator/Makefile
@@ -0,0 +1,36 @@
+# Created by: Bernard Spil <brnrd@FreeBSD.org>
+
+PORTNAME= twofactor_gauthenticator
+PORTVERSION= g20210816
+CATEGORIES= mail security
+PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+
+MAINTAINER= brnrd@FreeBSD.org
+COMMENT= Roundcube TOTP auth plugin
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
+RUN_DEPENDS= roundcube${PHP_PKGNAMESUFFIX}>=1.0:mail/roundcube@${PHP_FLAVOR}
+
+USES= php:flavors
+
+USE_GITHUB= yes
+GH_ACCOUNT= alexandregz
+GH_TAGNAME= a3944c4
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+SUB_FILES= pkg-message
+
+WWWDIR= ${PREFIX}/www/roundcube/plugins/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ cd ${WRKSRC} && ${PAX} -r -w . ${STAGEDIR}${WWWDIR}
+ cd ${STAGEDIR}${WWWDIR} && \
+ ${MV} config.inc.php.dist config.inc.php.sample
+
+.include <bsd.port.mk>
diff --git a/mail/roundcube-twofactor_gauthenticator/distinfo b/mail/roundcube-twofactor_gauthenticator/distinfo
new file mode 100644
index 000000000000..11c724fbf118
--- /dev/null
+++ b/mail/roundcube-twofactor_gauthenticator/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633595053
+SHA256 (alexandregz-twofactor_gauthenticator-g20210816-a3944c4_GH0.tar.gz) = b734c70e84c7b2948cb9f4dd986c38bc689535e012a27c725a079086e7d89913
+SIZE (alexandregz-twofactor_gauthenticator-g20210816-a3944c4_GH0.tar.gz) = 1156718
diff --git a/mail/roundcube-twofactor_gauthenticator/files/pkg-message.in b/mail/roundcube-twofactor_gauthenticator/files/pkg-message.in
new file mode 100644
index 000000000000..3a098ae07e7f
--- /dev/null
+++ b/mail/roundcube-twofactor_gauthenticator/files/pkg-message.in
@@ -0,0 +1,13 @@
+[
+{ type: install
+ message: <<EOM
+Activate the TOTP MFA plugin by adding the following to Roundcube's
+%%PREFIX%%/roundcube/config/config.inc.php:
+
+$config['plugins'] = array('twofactor_gauthenticator');
+
+and edit %%WWWDIR%%/config.inc.php
+to suit your needs.
+EOM
+}
+]
diff --git a/mail/roundcube-twofactor_gauthenticator/pkg-descr b/mail/roundcube-twofactor_gauthenticator/pkg-descr
new file mode 100644
index 000000000000..15ae9e839f88
--- /dev/null
+++ b/mail/roundcube-twofactor_gauthenticator/pkg-descr
@@ -0,0 +1,4 @@
+This plugin adds the option to use TOTP as second-factor
+authentication.
+
+WWW: https://github.com/alexandregz/twofactor_gauthenticator
diff --git a/mail/roundcube-twofactor_gauthenticator/pkg-plist b/mail/roundcube-twofactor_gauthenticator/pkg-plist
new file mode 100644
index 000000000000..72ea1835ffc8
--- /dev/null
+++ b/mail/roundcube-twofactor_gauthenticator/pkg-plist
@@ -0,0 +1,45 @@
+%%WWWDIR%%/.gitignore
+%%WWWDIR%%/2FA_qr_code.js
+%%WWWDIR%%/CIDR.php
+%%WWWDIR%%/LICENSE
+%%WWWDIR%%/PHPGangsta/GoogleAuthenticator.php
+%%WWWDIR%%/README.md
+%%WWWDIR%%/ToDo
+%%WWWDIR%%/composer.json
+@sample %%WWWDIR%%/config.inc.php.sample
+%%WWWDIR%%/localization/cs_CZ.inc
+%%WWWDIR%%/localization/da_DK.inc
+%%WWWDIR%%/localization/de_DE.inc
+%%WWWDIR%%/localization/en_US.inc
+%%WWWDIR%%/localization/es_AR.inc
+%%WWWDIR%%/localization/es_ES.inc
+%%WWWDIR%%/localization/fr_FR.inc
+%%WWWDIR%%/localization/gl_ES.inc
+%%WWWDIR%%/localization/he_IL.inc
+%%WWWDIR%%/localization/hu_HU.inc
+%%WWWDIR%%/localization/it_IT.inc
+%%WWWDIR%%/localization/ja_JP.inc
+%%WWWDIR%%/localization/nb_NO.inc
+%%WWWDIR%%/localization/nl_NL.inc
+%%WWWDIR%%/localization/nn_NO.inc
+%%WWWDIR%%/localization/pl_PL.inc
+%%WWWDIR%%/localization/pt_BR.inc
+%%WWWDIR%%/localization/ru_RU.inc
+%%WWWDIR%%/localization/sk_SK.inc
+%%WWWDIR%%/localization/sv_SE.inc
+%%WWWDIR%%/qrcode.min.js
+%%WWWDIR%%/screenshots/001-login.png
+%%WWWDIR%%/screenshots/002-2steps.png
+%%WWWDIR%%/screenshots/003-settings_default.png
+%%WWWDIR%%/screenshots/004-settings_ok.png
+%%WWWDIR%%/screenshots/005-settings_qr_code.png
+%%WWWDIR%%/screenshots/006-recovery_codes.png
+%%WWWDIR%%/screenshots/007-check_code.png
+%%WWWDIR%%/screenshots/008-msg_infor_about_enrollment.png
+%%WWWDIR%%/screenshots/009-elastic_skin_start.png
+%%WWWDIR%%/screenshots/010-elastic_skin_config.png
+%%WWWDIR%%/screenshots/IMG_20160321_210439.jpg
+%%WWWDIR%%/screenshots/screen30days.png
+%%WWWDIR%%/twofactor_gauthenticator.js
+%%WWWDIR%%/twofactor_gauthenticator.php
+%%WWWDIR%%/twofactor_gauthenticator_form.js