aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-12-27 02:30:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-12-27 02:31:33 +0000
commit0f5b6cdfcf335903b38f1dbad910b3f059fbb441 (patch)
tree8776941c15d97385488e2364b0feaca4c5b40ad0
parent584731c11e4175699dbf0de01397b00ef3ec19d9 (diff)
cad/py-pymtl: New port: Python-based hardware generation, simulation, verification framework
-rw-r--r--cad/Makefile1
-rw-r--r--cad/py-pymtl/Makefile25
-rw-r--r--cad/py-pymtl/distinfo3
-rw-r--r--cad/py-pymtl/pkg-descr4
4 files changed, 33 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index df6a54034b91..299ab699da5c 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -104,6 +104,7 @@
SUBDIR += py-ocp
SUBDIR += py-phidl
SUBDIR += py-pyfda
+ SUBDIR += py-pymtl
SUBDIR += python-gdsii
SUBDIR += qcad
SUBDIR += qcsxcad
diff --git a/cad/py-pymtl/Makefile b/cad/py-pymtl/Makefile
new file mode 100644
index 000000000000..63ac4e1e889d
--- /dev/null
+++ b/cad/py-pymtl/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= pymtl
+DISTVERSION= 3.1.6
+CATEGORIES= cad python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= ${PORTVERSION:R:R}
+DISTNAME= ${PORTNAME}${PORTVERSION:R:R}-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python-based hardware generation, simulation, verification framework
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= \
+ ${PYTHON_PKGNAMEPREFIX}cffi>0:devel/py-cffi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}greenlet>0:devel/py-greenlet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hypothesis>0:devel/py-hypothesis@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/cad/py-pymtl/distinfo b/cad/py-pymtl/distinfo
new file mode 100644
index 000000000000..18c674ed6a60
--- /dev/null
+++ b/cad/py-pymtl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1640560195
+SHA256 (pymtl3-3.1.6.tar.gz) = 3359716e9641f4cd48c92c5e5a60ba4e3b1c5b7c360200fc5283884071aa8824
+SIZE (pymtl3-3.1.6.tar.gz) = 348155
diff --git a/cad/py-pymtl/pkg-descr b/cad/py-pymtl/pkg-descr
new file mode 100644
index 000000000000..4258850e6075
--- /dev/null
+++ b/cad/py-pymtl/pkg-descr
@@ -0,0 +1,4 @@
+Pymtl 3 (Mamba) is an open-source Python-based hardware generation, simulation,
+and verification framework.
+
+WWW: https://github.com/pymtl/pymtl3