aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-15 01:11:09 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-15 01:18:46 +0000
commit105841ed69169f606c79a2917262a5b7a2904939 (patch)
treeaf832694a07e5b10a05de38e93facf6545f60e37
parentf79db40f6c1d1242e136d2cc0c22a3568e24278f (diff)
downloadports-105841ed69169f606c79a2917262a5b7a2904939.tar.gz
ports-105841ed69169f606c79a2917262a5b7a2904939.zip
devel/pydeps: New port: Display Python module dependencies
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pydeps/Makefile20
-rw-r--r--devel/pydeps/distinfo3
-rw-r--r--devel/pydeps/pkg-descr4
4 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 949749becab2..f47fa11ad1c6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5643,6 +5643,7 @@
SUBDIR += pycos
SUBDIR += pycount
SUBDIR += pydbus-common
+ SUBDIR += pydeps
SUBDIR += pydio-packr
SUBDIR += pyenv
SUBDIR += pygobject3-common
diff --git a/devel/pydeps/Makefile b/devel/pydeps/Makefile
new file mode 100644
index 000000000000..bf37f2e9a796
--- /dev/null
+++ b/devel/pydeps/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= pydeps
+DISTVERSION= 1.11.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Display Python module dependencies
+WWW= https://github.com/thebjorn/pydeps
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}stdlib-list>0:devel/py-stdlib-list@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/pydeps/distinfo b/devel/pydeps/distinfo
new file mode 100644
index 000000000000..c058bed2897a
--- /dev/null
+++ b/devel/pydeps/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1671065042
+SHA256 (pydeps-1.11.0.tar.gz) = cc6b2428f2628cdd1a27ab85b74b7997f04bcb1c4171f2e1a01d07780e056064
+SIZE (pydeps-1.11.0.tar.gz) = 41187
diff --git a/devel/pydeps/pkg-descr b/devel/pydeps/pkg-descr
new file mode 100644
index 000000000000..b95dddb27c7f
--- /dev/null
+++ b/devel/pydeps/pkg-descr
@@ -0,0 +1,4 @@
+pydeps is a Python module dependency visualizer.
+
+It is primarly intended to be used from the command line through the pydeps
+command.