aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-17 10:44:06 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-17 12:34:17 +0000
commit10672193d0daad0be9520df775f4c4d8d7e49ba6 (patch)
treea82b664a3c46f9860b6ac55959dada4358cd37e7
parent1c8cadd110e46070265494d8348bf9108bde2fa8 (diff)
downloadports-10672193d0daad0be9520df775f4c4d8d7e49ba6.tar.gz
ports-10672193d0daad0be9520df775f4c4d8d7e49ba6.zip
graphics/autotrace: fix package build by disabling one of conflicting options
autotrace (optionally) pulls both imagemagick6 and pstoedit, while the latter also pulls imagemagick7. Since imagemagick6 conflicts with imagemagick7 and autotrace does not support imagemagick7, one of the options need to be disabled by default to avoid the conflict. Disabling PSTOEDIT in assumption that raster image support would be more useful than postscript support. Approved by: portmgr blanket
-rw-r--r--graphics/autotrace/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index 3017e51ea673..b2d03ed1272f 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -23,7 +23,7 @@ LDFLAGS+= $$(libpng-config --L_opts)
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= IMAGEMAGICK MING PSTOEDIT
-OPTIONS_DEFAULT=IMAGEMAGICK PSTOEDIT
+OPTIONS_DEFAULT=IMAGEMAGICK
MING_DESC= Enable swf interface
PSTOEDIT_DESC= Convert postscript to other formats
@@ -46,4 +46,5 @@ post-patch:
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libautotrace.so
+
.include <bsd.port.mk>