aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2022-10-29 18:20:13 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2022-10-30 05:34:34 +0000
commit10759b4b510d3646256bacded16bb0288de7a718 (patch)
treea0f1ff62581dc07c9f51c4ad1e86f79d5bc04085
parentff7949343c4aeacc08afac2ff66d90c372c78584 (diff)
downloadports-10759b4b510d3646256bacded16bb0288de7a718.tar.gz
ports-10759b4b510d3646256bacded16bb0288de7a718.zip
security/libgpg-error: update to 1.46
-rw-r--r--security/libgpg-error/Makefile5
-rw-r--r--security/libgpg-error/distinfo6
-rw-r--r--security/libgpg-error/files/patch-posix-lock-fix85
-rw-r--r--security/libgpg-error/pkg-plist4
4 files changed, 8 insertions, 92 deletions
diff --git a/security/libgpg-error/Makefile b/security/libgpg-error/Makefile
index 480b65c20672..c1ce9c607f1c 100644
--- a/security/libgpg-error/Makefile
+++ b/security/libgpg-error/Makefile
@@ -1,5 +1,5 @@
PORTNAME= libgpg-error
-PORTVERSION= 1.45
+PORTVERSION= 1.46
CATEGORIES= security devel
MASTER_SITES= GNUPG
@@ -19,7 +19,8 @@ CPE_VENDOR= gnupg
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPP+= -P
-CONFIGURE_ARGS= --enable-static=yes
+CONFIGURE_ARGS= --enable-static=yes \
+ --enable-install-gpg-error-config
INSTALL_TARGET= install-strip
DOCS= AUTHORS ChangeLog NEWS README
INFO= gpgrt
diff --git a/security/libgpg-error/distinfo b/security/libgpg-error/distinfo
index 7ec1db75282e..3fc50ef7ae24 100644
--- a/security/libgpg-error/distinfo
+++ b/security/libgpg-error/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1649467850
-SHA256 (libgpg-error-1.45.tar.bz2) = 570f8ee4fb4bff7b7495cff920c275002aea2147e9a1d220c068213267f80a26
-SIZE (libgpg-error-1.45.tar.bz2) = 1015954
+TIMESTAMP = 1667065870
+SHA256 (libgpg-error-1.46.tar.bz2) = b7e11a64246bbe5ef37748de43b245abd72cfcd53c9ae5e7fc5ca59f1c81268d
+SIZE (libgpg-error-1.46.tar.bz2) = 1014291
diff --git a/security/libgpg-error/files/patch-posix-lock-fix b/security/libgpg-error/files/patch-posix-lock-fix
deleted file mode 100644
index af29591e9205..000000000000
--- a/security/libgpg-error/files/patch-posix-lock-fix
+++ /dev/null
@@ -1,85 +0,0 @@
-From 6e17e70bb7eea1f6ed4c08f795ea65a09f89d38f Mon Sep 17 00:00:00 2001
-From: NIIBE Yutaka <gniibe@fsij.org>
-Date: Mon, 28 Mar 2022 13:36:19 +0900
-Subject: [PATCH] core: Fix support of posix-lock for FreeBSD.
-
-* src/posix-lock.c [__FreeBSD__] (use_pthread_p): Use
-pthread_key_create to determine if it's linked to lpthread or not.
-
---
-
-This is from glthread_in_use in gnulib/lib/glthread/threadlib.c.
-
-On FreeBSD, pthread_key_create in there in libc (stub function) as
-well as -lpthread (real one), while pthread_create is not available
-in libc.
-
-Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
----
- src/posix-lock.c | 36 +++++++++++++++++++++++++++++++++++-
- 1 file changed, 35 insertions(+), 1 deletion(-)
-
-diff --git a/src/posix-lock.c b/src/posix-lock.c
-index d0fd07a..85ec660 100644
---- src/posix-lock.c
-+++ src/posix-lock.c
-@@ -67,6 +67,38 @@
- # endif
- # endif /*!USE_POSIX_THREADS_WEAK*/
- # if PTHREAD_IN_USE_DETECTION_HARD
-+# if defined __FreeBSD__ || defined __DragonFly__ /* FreeBSD */
-+
-+/* Test using pthread_key_create. */
-+
-+static int
-+use_pthread_p (void)
-+{
-+ static int tested;
-+ static int result; /* 1: linked with -lpthread, 0: only with libc */
-+
-+ if (!tested)
-+ {
-+ pthread_key_t key;
-+ int err = pthread_key_create (&key, NULL);
-+
-+ if (err == ENOSYS)
-+ result = 0;
-+ else
-+ {
-+ result = 1;
-+ if (err == 0)
-+ pthread_key_delete (key);
-+ }
-+ tested = 1;
-+ }
-+ return result;
-+}
-+
-+# else /* Solaris, HP-UX */
-+
-+/* Test using pthread_create. */
-+
- /* The function to be executed by a dummy thread. */
- static void *
- dummy_thread_func (void *arg)
-@@ -84,7 +116,7 @@ use_pthread_p (void)
- {
- pthread_t thread;
-
-- if (pthread_create (&thread, NULL, dummy_thread_func, NULL))
-+ if (pthread_create (&thread, NULL, dummy_thread_func, NULL) != 0)
- result = 0; /* Thread creation failed. */
- else
- {
-@@ -102,6 +134,8 @@ use_pthread_p (void)
- }
- return result;
- }
-+# endif /* Solaris, HP-UX */
-+
- # endif /*PTHREAD_IN_USE_DETECTION_HARD*/
- #endif /*USE_POSIX_THREADS*/
-
---
-2.11.0
-
diff --git a/security/libgpg-error/pkg-plist b/security/libgpg-error/pkg-plist
index bd061e415ffd..88825b213a75 100644
--- a/security/libgpg-error/pkg-plist
+++ b/security/libgpg-error/pkg-plist
@@ -7,9 +7,9 @@ include/gpgrt.h
lib/libgpg-error.a
lib/libgpg-error.so
lib/libgpg-error.so.0
-lib/libgpg-error.so.0.33.0
+lib/libgpg-error.so.0.33.1
libdata/pkgconfig/gpg-error.pc
-man/man1/gpgrt-config.1.gz
+man/man1/gpg-error-config.1.gz
share/aclocal/gpg-error.m4
share/aclocal/gpgrt.m4
share/common-lisp/source/gpg-error/gpg-error-codes.lisp