aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 18:57:03 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 21:18:13 +0000
commit11254016eedc9bcbe80e36f05137f1e6ea341fd1 (patch)
tree785243b8d85e260dc59ee100821fe6728a965dde
parent2ab0da4e95d9ef52c7629ef7aad75ce9c8e05125 (diff)
downloadports-11254016eedc9bcbe80e36f05137f1e6ea341fd1.tar.gz
ports-11254016eedc9bcbe80e36f05137f1e6ea341fd1.zip
security/steghide: Fix build with llvm16
- Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--security/steghide/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/security/steghide/Makefile b/security/steghide/Makefile
index afb3ea7d069d..73a318d0163f 100644
--- a/security/steghide/Makefile
+++ b/security/steghide/Makefile
@@ -16,12 +16,17 @@ LIB_DEPENDS= libmcrypt.so:security/libmcrypt \
USES= compiler cpe gmake jpeg libtool:build localbase perl5
CPE_VENDOR= ${PORTNAME}_project
+USE_CXXSTD= c++14
+
GNU_CONFIGURE= yes
+
+MAKE_ARGS= LIBTOOL="${LOCALBASE}/bin/libtool"
+
CPPFLAGS+= -fpermissive
-LIBS+= -lmcrypt
CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
CXXFLAGS_clang= -Wno-static-float-init
-MAKE_ARGS= LIBTOOL="${LOCALBASE}/bin/libtool"
+
+LIBS+= -lmcrypt
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes