aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-04 07:16:19 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-04 07:16:54 +0000
commit11422944c5b58d8e606c63e44bc0475f55df953d (patch)
treea5cc27cdc217be65f6e1af15150e53798f19e28d
parent9fa6e61f4fef5f8b59afe98e07754e07e732402f (diff)
downloadports-11422944c5b58d8e606c63e44bc0475f55df953d.tar.gz
ports-11422944c5b58d8e606c63e44bc0475f55df953d.zip
graphics/gmic: Update 3.1.3 -> 3.1.5
Reported by: portscout
-rw-r--r--graphics/gmic/Makefile5
-rw-r--r--graphics/gmic/distinfo6
-rw-r--r--graphics/gmic/files/patch-src_gmic.cpp33
-rw-r--r--graphics/gmic/pkg-plist2
4 files changed, 28 insertions, 18 deletions
diff --git a/graphics/gmic/Makefile b/graphics/gmic/Makefile
index 24fed0983167..a788f94cf3cc 100644
--- a/graphics/gmic/Makefile
+++ b/graphics/gmic/Makefile
@@ -1,5 +1,5 @@
PORTNAME= gmic
-DISTVERSION= 3.1.3
+DISTVERSION= 3.1.5
CATEGORIES= graphics
MASTER_SITES= https://gmic.eu/files/source/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -24,8 +24,9 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libpng.so:graphics/png \
libtiff.so:graphics/tiff
-USES= compiler:c++11-lang gmake jpeg localbase:ldflags pkgconfig
+USES= compiler:c++11-lang gettext-runtime gmake jpeg localbase:ldflags pkgconfig xorg
USE_LDCONFIG= yes
+USE_XORG= x11 xau xcb xdmcp
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/graphics/gmic/distinfo b/graphics/gmic/distinfo
index 386b7d390b4f..fb5cddd1e25c 100644
--- a/graphics/gmic/distinfo
+++ b/graphics/gmic/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1655578556
-SHA256 (gmic_3.1.3.tar.gz) = 25d1583932801321fe559ee87c3c19c60d45f9119447d86049f073ad295b3da3
-SIZE (gmic_3.1.3.tar.gz) = 10770532
+TIMESTAMP = 1656916160
+SHA256 (gmic_3.1.5.tar.gz) = fa77e85b3a39638008515ac525f23f0ed7a45b63c463c0ba6292c87f5e88e30d
+SIZE (gmic_3.1.5.tar.gz) = 10782647
diff --git a/graphics/gmic/files/patch-src_gmic.cpp b/graphics/gmic/files/patch-src_gmic.cpp
index 80860cb5274a..4444e383d9ba 100644
--- a/graphics/gmic/files/patch-src_gmic.cpp
+++ b/graphics/gmic/files/patch-src_gmic.cpp
@@ -1,20 +1,29 @@
---- src/gmic.cpp.orig 2022-05-11 08:15:20 UTC
+--- src/gmic.cpp.orig 2022-06-30 12:35:34 UTC
+++ src/gmic.cpp
-@@ -2516,7 +2516,7 @@ double gmic::mp_store(const Ts *const ptr, const unsig
- // Manage correspondence between abort pointers and thread ids.
- CImgList<void*> gmic::list_p_is_abort = CImgList<void*>();
- bool *gmic::abort_ptr(bool *const p_is_abort) {
+@@ -2314,7 +2314,7 @@ inline CImgList<void*>& gmic_runs() {
+ }
+
+ inline void* get_tid() {
-#if defined(__MACOSX__) || defined(__APPLE__)
+#if defined(__MACOSX__) || defined(__APPLE__) || defined(__FreeBSD__)
void* tid = (void*)(cimg_ulong)getpid();
#elif cimg_OS==1
void* tid = (void*)(cimg_ulong)syscall(SYS_gettid);
-@@ -2858,7 +2858,7 @@ gmic::~gmic() {
- cimg::exception_mode(cimg_exception_mode);
- cimg_forX(display_windows,l) delete &display_window(l);
- cimg::mutex(21);
+@@ -2322,7 +2322,7 @@ inline void* get_tid() {
+ void* tid = (void*)(cimg_ulong)GetCurrentThreadId();
+ #else
+ void* tid = (void*)0;
+-#endif // #if defined(__MACOSX__) || defined(__APPLE__)
++#endif // #if defined(__MACOSX__) || defined(__APPLE__) || defined(__FreeBSD__)
+ return tid;
+ }
+
+@@ -10762,7 +10762,7 @@ gmic& gmic::_run(const CImgList<char>& commands_line,
+ #ifdef gmic_is_parallel
+ #ifdef PTHREAD_CANCEL_ENABLE
+
-#if defined(__MACOSX__) || defined(__APPLE__)
+#if defined(__MACOSX__) || defined(__APPLE__) || defined(__FreeBSD__)
- void* tid = (void*)(cimg_ulong)getpid();
- #elif cimg_OS==1
- void* tid = (void*)(cimg_ulong)syscall(SYS_gettid);
+ const cimg_uint64 stacksize = (cimg_uint64)8*1024*1024;
+ pthread_attr_t thread_attr;
+ if (!pthread_attr_init(&thread_attr) && !pthread_attr_setstacksize(&thread_attr,stacksize))
diff --git a/graphics/gmic/pkg-plist b/graphics/gmic/pkg-plist
index 37e56be4c2c7..b99da8d9407d 100644
--- a/graphics/gmic/pkg-plist
+++ b/graphics/gmic/pkg-plist
@@ -2,7 +2,7 @@ include/gmic.h
include/gmic_libc.h
lib/libgmic.so
lib/libgmic.so.3
-lib/libgmic.so.313
+lib/libgmic.so.315
libexec/gimp/2.2/plug-ins/gmic_cluts.gmz
libexec/gimp/2.2/plug-ins/gmic_denoise_cnn.gmz
share/man/fr/man1/gmic.1.gz