aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-27 21:10:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-27 21:10:04 +0000
commit11cd9ddf548e34d21ee6bb02b33d5193eefa7c21 (patch)
tree6c52076a17294efda919ca80f1582677efb4b3a2
parent8e26ebd0d3806d4377d327d204d0b1bfc9845ed7 (diff)
downloadports-11cd9ddf548e34d21ee6bb02b33d5193eefa7c21.tar.gz
ports-11cd9ddf548e34d21ee6bb02b33d5193eefa7c21.zip
misc/py-detecta: New port: Library to detect events in data
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-detecta/Makefile23
-rw-r--r--misc/py-detecta/distinfo3
-rw-r--r--misc/py-detecta/pkg-descr10
4 files changed, 37 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 6b6c1e8caeb6..36fe481a027e 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -383,6 +383,7 @@
SUBDIR += py-colorbrewer
SUBDIR += py-colored
SUBDIR += py-crudini
+ SUBDIR += py-detecta
SUBDIR += py-dictdiffer
SUBDIR += py-eemeter
SUBDIR += py-emoji
diff --git a/misc/py-detecta/Makefile b/misc/py-detecta/Makefile
new file mode 100644
index 000000000000..cbdcd8594025
--- /dev/null
+++ b/misc/py-detecta/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= detecta
+DISTVERSION= 0.0.5
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library to detect events in data
+WWW= https://github.com/demotu/detecta
+
+LICENSE= APACHE20
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYNUMPY}
+BUILD_DEPENDS= ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-detecta/distinfo b/misc/py-detecta/distinfo
new file mode 100644
index 000000000000..d1a6d0e8bcef
--- /dev/null
+++ b/misc/py-detecta/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1672174658
+SHA256 (detecta-0.0.5.tar.gz) = d2ea7d13dfbbc994d6ce385a7f8dc0a85fe675a8a8e712a64ec56e54c40603ed
+SIZE (detecta-0.0.5.tar.gz) = 9301
diff --git a/misc/py-detecta/pkg-descr b/misc/py-detecta/pkg-descr
new file mode 100644
index 000000000000..873dd4559561
--- /dev/null
+++ b/misc/py-detecta/pkg-descr
@@ -0,0 +1,10 @@
+detecta is a Python module to detect events in data.
+
+The following functions are implemented in detecta:
+* detect_peaks.py: detects peaks in data based on their amplitude and other
+ features.
+* detect_onset.py: detects onset in data based on amplitude threshold.
+* detect_cusum.py: detects abrupt changes in data using cumulative sum algorithm
+ (CUSUM).
+* detect_seq.py: detects initial and final indices of sequential data identical
+ to a parameter.