aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2022-04-30 08:52:17 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2022-05-01 02:13:56 +0000
commit124ba3c89de65ffbcccf1e1cc15aa88fc5f6f20e (patch)
tree9dbed746c478da83fff4b2320355004fd6a2d5d4
parentc110cee2bea4a01c3723444006d35bfe767a6c87 (diff)
downloadports-124ba3c89de65ffbcccf1e1cc15aa88fc5f6f20e.tar.gz
ports-124ba3c89de65ffbcccf1e1cc15aa88fc5f6f20e.zip
misc/compat.el: Add new port
Add compat.el, a forwards-compatibility library for (GNU) Emacs Lisp, versions 24.3 and newer.
-rw-r--r--misc/Makefile1
-rw-r--r--misc/compat.el/Makefile41
-rw-r--r--misc/compat.el/distinfo3
-rw-r--r--misc/compat.el/pkg-descr20
-rw-r--r--misc/compat.el/pkg-plist18
5 files changed, 83 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 7cbb2ea6ffe4..48c27615550d 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -43,6 +43,7 @@
SUBDIR += clpbar
SUBDIR += colortail
SUBDIR += colwide
+ SUBDIR += compat.el
SUBDIR += compat10x
SUBDIR += compat11x
SUBDIR += compat12x
diff --git a/misc/compat.el/Makefile b/misc/compat.el/Makefile
new file mode 100644
index 000000000000..74bdb28d44b8
--- /dev/null
+++ b/misc/compat.el/Makefile
@@ -0,0 +1,41 @@
+PORTNAME= compat.el
+DISTVERSION= 28.1.1.0
+CATEGORIES= misc elisp
+PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
+
+MAINTAINER= yasu@FreeBSD.org
+COMMENT= Compatibility library for Emacs Lisp
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= emacs gmake makeinfo
+USE_GITHUB= yes
+GH_ACCOUNT= phikal
+
+ALL_TARGET= all compat.info
+
+NO_ARCH= yes
+
+INFO= compat
+PORTDOCS= MANUAL NEWS.org README.md
+
+OPTIONS_DEFINE= DOCS
+
+ELISP_FILES= compat-24.el compat-24.elc compat-25.el compat-25.elc \
+ compat-26.el compat-26.elc compat-27.el compat-27.elc \
+ compat-28.el compat-28.elc compat-font-lock.el \
+ compat-font-lock.elc compat-help.el compat-help.elc \
+ compat-macs.el compat-macs.elc compat.el compat.elc
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/compat
+ ${INSTALL_DATA} ${ELISP_FILES:C/^/${WRKSRC}\//} \
+ ${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/compat
+ ${INSTALL_DATA} ${WRKSRC}/*.info ${STAGEDIR}${PREFIX}/${INFO_PATH}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORT_DOCS:C/^/${WRKSRC}\//} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/misc/compat.el/distinfo b/misc/compat.el/distinfo
new file mode 100644
index 000000000000..b1d9a083e49e
--- /dev/null
+++ b/misc/compat.el/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1651309625
+SHA256 (phikal-compat.el-28.1.1.0_GH0.tar.gz) = c8309e294339c5e17e2ef5fca009d07c8c34fbf77eef36165a38b8fa16699d58
+SIZE (phikal-compat.el-28.1.1.0_GH0.tar.gz) = 70535
diff --git a/misc/compat.el/pkg-descr b/misc/compat.el/pkg-descr
new file mode 100644
index 000000000000..9c20c54851ef
--- /dev/null
+++ b/misc/compat.el/pkg-descr
@@ -0,0 +1,20 @@
+Compat.el is a forwards-compatibility library for (GNU) Emacs Lisp,
+versions 24.3 and newer.
+
+The intended audience of this library aren't day-to-day users, but
+package developers that wish to make use of newer functionality, not
+provided in older versions of Emacs, without breaking compatibility
+for users bound to specific Emacs releases.
+
+Version 24.3 is chosen as the oldest version, because this is the
+newest version on CentOS 7. It is intended to preserve compatibility
+for at least as the Centos 7 reaches EOL, 2024.
+
+Note that compat.el provides a few prefixed function, ie. functions
+with a compat- prefix. These are used to provide extended
+functionality for commands that are already defined (sort, assoc,
+...). It might be possible to transform these into advised functions
+later on, so that the modified functionality is accessible without a
+prefix. Feedback on this point is appreciated.
+
+WWW: https://sr.ht/~pkal/compat/
diff --git a/misc/compat.el/pkg-plist b/misc/compat.el/pkg-plist
new file mode 100644
index 000000000000..c18d226c49dc
--- /dev/null
+++ b/misc/compat.el/pkg-plist
@@ -0,0 +1,18 @@
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-24.el
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-24.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-25.el
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-25.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-26.el
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-26.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-27.el
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-27.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-28.el
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-28.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-font-lock.el
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-font-lock.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-help.el
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-help.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-macs.el
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat-macs.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat.el
+%%EMACS_VERSION_SITE_LISPDIR%%/compat/compat.elc