aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-18 05:01:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-18 05:13:28 +0000
commit12c00cfcc07c30741e2a8059eedcf3c22cb3e9bb (patch)
tree0eafa1ef63b6657e8b91773256e5c7a16e3fb3bf
parent95bbd18366cce8c376fbf73218d495e8a099d53a (diff)
downloadports-12c00cfcc07c30741e2a8059eedcf3c22cb3e9bb.tar.gz
ports-12c00cfcc07c30741e2a8059eedcf3c22cb3e9bb.zip
misc/py-einops: New port: New flavour of deep learning operations
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-einops/Makefile24
-rw-r--r--misc/py-einops/distinfo3
-rw-r--r--misc/py-einops/pkg-descr3
4 files changed, 31 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 33e6f49aa1db..42fbbba739b2 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -398,6 +398,7 @@
SUBDIR += py-detecta
SUBDIR += py-dictdiffer
SUBDIR += py-eemeter
+ SUBDIR += py-einops
SUBDIR += py-emoji
SUBDIR += py-ezc3d
SUBDIR += py-fast-histogram
diff --git a/misc/py-einops/Makefile b/misc/py-einops/Makefile
new file mode 100644
index 000000000000..cc9798f1751e
--- /dev/null
+++ b/misc/py-einops/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= einops
+DISTVERSION= 0.6.0
+CATEGORIES= misc # machine-learning
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= New flavour of deep learning operations
+WWW= https://einops.rocks/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=1.10.0:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=1.10.0:devel/py-hatchling@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nbconvert>0:devel/py-nbconvert@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}parameterized>0:devel/py-parameterized@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= pep517 autoplist pytest # 1 test fails because of missing pytorch
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-einops/distinfo b/misc/py-einops/distinfo
new file mode 100644
index 000000000000..c990869af818
--- /dev/null
+++ b/misc/py-einops/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674013800
+SHA256 (einops-0.6.0.tar.gz) = 6f6c78739316a2e3ccbce8052310497e69da092935e4173f2e76ec4e3a336a35
+SIZE (einops-0.6.0.tar.gz) = 54337
diff --git a/misc/py-einops/pkg-descr b/misc/py-einops/pkg-descr
new file mode 100644
index 000000000000..1dfd36810fa2
--- /dev/null
+++ b/misc/py-einops/pkg-descr
@@ -0,0 +1,3 @@
+einops provides flexible and powerful tensor operations for readable and
+reliable code.
+It supports numpy, pytorch, tensorflow, jax, and others.