aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-02-28 01:23:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-28 01:29:35 +0000
commit12da909032613bda1502baaa0fd567bcc541009c (patch)
treeff32a7df522a7a5896513a1ecc073ec87cc281dc
parente20ee3cf0f70a8da841785afc28f3d4db4ba91dd (diff)
downloadports-12da909032613bda1502baaa0fd567bcc541009c.tar.gz
ports-12da909032613bda1502baaa0fd567bcc541009c.zip
misc/py-wandb: New port: CLI and library for interacting with the Weights and Biases API
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-wandb/Makefile52
-rw-r--r--misc/py-wandb/distinfo3
-rw-r--r--misc/py-wandb/pkg-descr3
4 files changed, 59 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 847f3a81b5fa..e1e00528cb12 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -462,6 +462,7 @@
SUBDIR += py-tqdm
SUBDIR += py-tvm
SUBDIR += py-uhi
+ SUBDIR += py-wandb
SUBDIR += py-wurlitzer
SUBDIR += py-xgboost
SUBDIR += pyobd
diff --git a/misc/py-wandb/Makefile b/misc/py-wandb/Makefile
new file mode 100644
index 000000000000..27805b91192e
--- /dev/null
+++ b/misc/py-wandb/Makefile
@@ -0,0 +1,52 @@
+PORTNAME= wandb
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.13.10
+CATEGORIES= misc # mechine-learning
+#MASTER_SITES= PYPI # no tests
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= CLI and library for interacting with the Weights and Biases API
+WWW= https://wandb.ai/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.3:devel/py-appdirs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=7.0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}docker-pycreds>=0.4.0:security/py-docker-pycreds@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gitpython>=1.0.0:devel/py-gitpython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pathtools>=0:devel/py-pathtools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=3.19.0:devel/py-protobuf@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>=5.0.0:sysutils/py-psutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.0.0,<3:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sentry-sdk>=1.0.0:devel/py-sentry-sdk@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setproctitle>=0:devel/py-setproctitle@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>0:devel/py-typing-extensions@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR} \
+ ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bokeh>0:www/py-bokeh@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nbclient>0:devel/py-nbclient@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nbformat>0:devel/py-nbformat@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}parameterized>0:devel/py-parameterized@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-flask>0:devel/py-pytest-flask@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-mock>=1.10.4:devel/py-pytest-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-rerunfailures>0:devel/py-pytest-rerunfailures@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-timeout>0:devel/py-pytest-timeout@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}responses>0:devel/py-responses@${PY_FLAVOR}
+
+USES= python shebangfix
+USE_PYTHON= pep517 concurrent autoplist pytest # tests fail because some test dependencies are missing
+USE_GITHUB= yes
+
+SHEBANG_GLOB= *.py
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-wandb/distinfo b/misc/py-wandb/distinfo
new file mode 100644
index 000000000000..5e63fc7158c8
--- /dev/null
+++ b/misc/py-wandb/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1677545761
+SHA256 (wandb-wandb-v0.13.10_GH0.tar.gz) = bc8e38f05000675eea06f68216f3afe9cbd2114e591faf37b8acb1e5d4ef9246
+SIZE (wandb-wandb-v0.13.10_GH0.tar.gz) = 14958338
diff --git a/misc/py-wandb/pkg-descr b/misc/py-wandb/pkg-descr
new file mode 100644
index 000000000000..34d0f3767c26
--- /dev/null
+++ b/misc/py-wandb/pkg-descr
@@ -0,0 +1,3 @@
+wandb helps to build better machine learning models faster. It allows to track
+and visualize all the pieces of your machine learning pipeline, from datasets
+to production machine learning models.