aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:42:48 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 13:01:54 +0000
commit1310c366b76d8e2ce3ba8e3faac11bdd33e10750 (patch)
tree2f0c61faaa2b69372dc8ee64ee57f6041540b802
parent38aeaf5de59f5b84f15be2b1290dd5f8ec99c3af (diff)
downloadports-1310c366b76d8e2ce3ba8e3faac11bdd33e10750.tar.gz
ports-1310c366b76d8e2ce3ba8e3faac11bdd33e10750.zip
textproc/hunspell: Use upstream release tarball
- Cosmetic change
-rw-r--r--textproc/hunspell/Makefile19
-rw-r--r--textproc/hunspell/distinfo6
-rw-r--r--textproc/hunspell/files/patch-src_tools_hunspell.cxx6
3 files changed, 17 insertions, 14 deletions
diff --git a/textproc/hunspell/Makefile b/textproc/hunspell/Makefile
index 88c9dabf0909..ab64e60ac388 100644
--- a/textproc/hunspell/Makefile
+++ b/textproc/hunspell/Makefile
@@ -1,6 +1,6 @@
PORTNAME= hunspell
PORTVERSION= 1.7.2
-DISTVERSIONPREFIX= v
+MASTER_SITES= https://github.com/hunspell/hunspell/releases/download/v${PORTVERSION}/
CATEGORIES= textproc
DIST_SUBDIR= ${PORTNAME}
@@ -14,20 +14,23 @@ LICENSE_FILE_GPLv2+ = ${_LICENSE_STORE}/GPLv2
LICENSE_FILE_LGPL21+ = ${_LICENSE_STORE}/LGPL21
LICENSE_FILE_MPL11= ${WRKSRC}/COPYING.MPL
-CONFLICTS_INSTALL= tinker
+USES= compiler:c++11-lang cpe gettext-tools iconv libtool:keepla ncurses pathfix perl5 readline shebangfix
+USE_PERL5= run
+
CONFIGURE_ARGS= --disable-nls ${ICONV_CONFIGURE_ARG} --with-readline --with-ui
GNU_CONFIGURE= yes
-USES= autoreconf compiler:c++11-lib cpe gettext-tools libtool:keepla \
- pathfix iconv ncurses readline shebangfix perl5
-CPE_VENDOR= ${PORTNAME}_project
-USE_GITHUB= yes
-SHEBANG_FILES= src/tools/ispellaff2myspell
USE_LDCONFIG= yes
-USE_PERL5= run
INSTALL_TARGET= install-strip
PLIST_SUB= SHLIB_VER=${PORTVERSION:R}
+# bin/analyze
+CONFLICTS_INSTALL= tinker
+
+CPE_VENDOR= hunspell_project
+
+SHEBANG_FILES= src/tools/ispellaff2myspell
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/src/tools/hunspell.cxx
diff --git a/textproc/hunspell/distinfo b/textproc/hunspell/distinfo
index 63aed93f1c56..562a3a874b61 100644
--- a/textproc/hunspell/distinfo
+++ b/textproc/hunspell/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1674107927
-SHA256 (hunspell/hunspell-hunspell-v1.7.2_GH0.tar.gz) = 69fa312d3586c988789266eaf7ffc9861d9f6396c31fc930a014d551b59bbd6e
-SIZE (hunspell/hunspell-hunspell-v1.7.2_GH0.tar.gz) = 981394
+TIMESTAMP = 1674590670
+SHA256 (hunspell/hunspell-1.7.2.tar.gz) = 11ddfa39afe28c28539fe65fc4f1592d410c1e9b6dd7d8a91ca25d85e9ec65b8
+SIZE (hunspell/hunspell-1.7.2.tar.gz) = 1536202
diff --git a/textproc/hunspell/files/patch-src_tools_hunspell.cxx b/textproc/hunspell/files/patch-src_tools_hunspell.cxx
index 705f8eab53b7..9edb415badc9 100644
--- a/textproc/hunspell/files/patch-src_tools_hunspell.cxx
+++ b/textproc/hunspell/files/patch-src_tools_hunspell.cxx
@@ -1,8 +1,8 @@
---- src/tools/hunspell.cxx.orig 2017-03-25 21:20:45 UTC
+--- src/tools/hunspell.cxx.orig 2022-12-25 23:48:44 UTC
+++ src/tools/hunspell.cxx
@@ -115,29 +115,23 @@
- #include "xmlparser.hxx"
- #include "odfparser.hxx"
+ #include "../parsers/xmlparser.hxx"
+ #include "../parsers/odfparser.hxx"
-#define LIBDIR \
- "/usr/share/hunspell:" \