aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2023-05-15 07:34:26 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2023-05-15 07:35:38 +0000
commit137ad9afca9c07496ceb49732a4e97d41f3580bf (patch)
treed8224eb0a6ad24f5ce1d5c647d5a9919a739e618
parent766cb164ce75eaba9487f8595b677d82cc3e1dff (diff)
downloadports-137ad9afca9c07496ceb49732a4e97d41f3580bf.tar.gz
ports-137ad9afca9c07496ceb49732a4e97d41f3580bf.zip
devel/electron24: update to 24.3.0
Changelog: https://github.com/electron/electron/releases/tag/v24.3.0 Reported by: GitHub (watch releases)
-rw-r--r--devel/electron24/Makefile2
-rw-r--r--devel/electron24/Makefile.version2
-rw-r--r--devel/electron24/distinfo10
-rw-r--r--devel/electron24/files/patch-electron_shell_browser_api_electron__api__web__contents.cc14
4 files changed, 14 insertions, 14 deletions
diff --git a/devel/electron24/Makefile b/devel/electron24/Makefile
index 8574895a0d36..08de9f27aff2 100644
--- a/devel/electron24/Makefile
+++ b/devel/electron24/Makefile
@@ -217,7 +217,7 @@ REACTIVEOBJC_VER= 74ab5baccc6f7202c8ac69a8d1e152c29dc1ea76
# See ${WRKSRC}/electron/DEPS for MANTLE_VER
MANTLE_VER= 78d3966b3c331292ea29ec38661b25df0a245948
-YARN_TIMESTAMP= 1683530525
+YARN_TIMESTAMP= 1684050401
.include "Makefile.version"
.include <bsd.port.pre.mk>
diff --git a/devel/electron24/Makefile.version b/devel/electron24/Makefile.version
index 7b08c5d59b2b..a84469b91e73 100644
--- a/devel/electron24/Makefile.version
+++ b/devel/electron24/Makefile.version
@@ -1,2 +1,2 @@
-ELECTRON_VER= 24.2.0
+ELECTRON_VER= 24.3.0
ELECTRON_VER_MAJOR= ${ELECTRON_VER:C/\..*//}
diff --git a/devel/electron24/distinfo b/devel/electron24/distinfo
index 482e2b54b517..3f2ec02c1caa 100644
--- a/devel/electron24/distinfo
+++ b/devel/electron24/distinfo
@@ -1,12 +1,12 @@
-TIMESTAMP = 1683530977
+TIMESTAMP = 1684050898
SHA256 (electron/chromium-112.0.5615.165.tar.xz) = 168c62fea9f428f99fbf967f36a75ee5da160429e3a5b86bf02188c5fe7c79fd
SIZE (electron/chromium-112.0.5615.165.tar.xz) = 1730146076
SHA256 (electron/336e775eec536b2d785cc80eff6ac39051931286) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
SIZE (electron/336e775eec536b2d785cc80eff6ac39051931286) = 32624734
-SHA256 (electron/electron-yarn-cache-24.2.0.tar.xz) = 0cff4a0cf97d30a735e9efce8a341f9948e778d70da8542da9b8d0c972b5cf33
-SIZE (electron/electron-yarn-cache-24.2.0.tar.xz) = 39365676
-SHA256 (electron/electron-electron-v24.2.0_GH0.tar.gz) = 0dd1434ff9e6ff8f266d82ff42d922414088b4940f0dfca4d5d22062ff94d3d6
-SIZE (electron/electron-electron-v24.2.0_GH0.tar.gz) = 10457860
+SHA256 (electron/electron-yarn-cache-24.3.0.tar.xz) = a0c07ddcade9bd20746585e3c1ca4aba3dbfb99dbfcc621c4403cf550394dd03
+SIZE (electron/electron-yarn-cache-24.3.0.tar.xz) = 39365592
+SHA256 (electron/electron-electron-v24.3.0_GH0.tar.gz) = 3359336061436701b6eebc589559753d240bd8fb8c92d5c944563d2cbf0f6762
+SIZE (electron/electron-electron-v24.3.0_GH0.tar.gz) = 10458047
SHA256 (electron/nodejs-node-v18.14.0_GH0.tar.gz) = 31bbccdff73269baebcc9f32c2ffe428f28be79841527c63e95da93e8c630829
SIZE (electron/nodejs-node-v18.14.0_GH0.tar.gz) = 113058999
SHA256 (electron/nodejs-nan-16fa32231e2ccd89d2804b3f765319128b20c4ac_GH0.tar.gz) = 3807ae6a1e451a29f068540472f100f9718d457c60ac62f2f8469d1d57475d39
diff --git a/devel/electron24/files/patch-electron_shell_browser_api_electron__api__web__contents.cc b/devel/electron24/files/patch-electron_shell_browser_api_electron__api__web__contents.cc
index 104447400bed..09d1ada73c31 100644
--- a/devel/electron24/files/patch-electron_shell_browser_api_electron__api__web__contents.cc
+++ b/devel/electron24/files/patch-electron_shell_browser_api_electron__api__web__contents.cc
@@ -1,6 +1,6 @@
---- electron/shell/browser/api/electron_api_web_contents.cc.orig 2023-04-03 22:25:21 UTC
+--- electron/shell/browser/api/electron_api_web_contents.cc.orig 2023-05-09 16:07:54 UTC
+++ electron/shell/browser/api/electron_api_web_contents.cc
-@@ -152,11 +152,11 @@
+@@ -151,11 +151,11 @@
#include "ui/base/cocoa/defaults_utils.h"
#endif
@@ -14,7 +14,7 @@
#include "ui/gfx/font_render_params.h"
#endif
-@@ -400,7 +400,7 @@ absl::optional<base::TimeDelta> GetCursorBlinkInterval
+@@ -494,7 +494,7 @@ absl::optional<base::TimeDelta> GetCursorBlinkInterval
ui::TextInsertionCaretBlinkPeriodFromDefaults());
if (system_value)
return *system_value;
@@ -23,7 +23,7 @@
if (auto* linux_ui = ui::LinuxUi::instance())
return linux_ui->GetCursorBlinkInterval();
#elif BUILDFLAG(IS_WIN)
-@@ -854,7 +854,7 @@ void WebContents::InitWithSessionAndOptions(
+@@ -948,7 +948,7 @@ void WebContents::InitWithSessionAndOptions(
accept_languages.pop_back();
prefs->accept_languages = accept_languages;
@@ -32,7 +32,7 @@
// Update font settings.
static const gfx::FontRenderParams params(
gfx::GetFontRenderParams(gfx::FontRenderParamsQuery(), nullptr));
-@@ -2394,7 +2394,7 @@ void WebContents::ForcefullyCrashRenderer() {
+@@ -2488,7 +2488,7 @@ void WebContents::ForcefullyCrashRenderer() {
content::RenderProcessHost* rph = rwh->GetProcess();
if (rph) {
@@ -41,7 +41,7 @@
// A generic |CrashDumpHungChildProcess()| is not implemented for Linux.
// Instead we send an explicit IPC to crash on the renderer's IO thread.
rph->ForceCrash();
-@@ -3037,7 +3037,7 @@ void WebContents::CopyImageAt(int x, int y) {
+@@ -3131,7 +3131,7 @@ void WebContents::CopyImageAt(int x, int y) {
void WebContents::Focus() {
// Focusing on WebContents does not automatically focus the window on macOS
// and Linux, do it manually to match the behavior on Windows.
@@ -50,7 +50,7 @@
if (owner_window())
owner_window()->Focus(true);
#endif
-@@ -3843,7 +3843,7 @@ ui::ImageModel WebContents::GetDevToolsWindowIcon() {
+@@ -3937,7 +3937,7 @@ ui::ImageModel WebContents::GetDevToolsWindowIcon() {
}
#endif