aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 01:51:18 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 02:08:35 +0000
commit141bff18da2fc2a4a3d126f0a172c7faf1ed39f1 (patch)
tree85a93645b7fc9594cdc633d831da85b10fdbf779
parentc5b253da12d6baa8f342be294fce5960919591e9 (diff)
downloadports-141bff18da2fc2a4a3d126f0a172c7faf1ed39f1.tar.gz
ports-141bff18da2fc2a4a3d126f0a172c7faf1ed39f1.zip
devel/rubygem-aws-crt: Update to 0.1.9
-rw-r--r--devel/rubygem-aws-crt/Makefile2
-rw-r--r--devel/rubygem-aws-crt/distinfo6
-rw-r--r--devel/rubygem-aws-crt/files/patch-aws-crt-ffi-crt-s2n-CMakeLists.txt17
-rw-r--r--devel/rubygem-aws-crt/files/patch-powerpc64le8
4 files changed, 8 insertions, 25 deletions
diff --git a/devel/rubygem-aws-crt/Makefile b/devel/rubygem-aws-crt/Makefile
index aeeaee379c2c..04137a99dcee 100644
--- a/devel/rubygem-aws-crt/Makefile
+++ b/devel/rubygem-aws-crt/Makefile
@@ -1,5 +1,5 @@
PORTNAME= aws-crt
-PORTVERSION= 0.1.8
+PORTVERSION= 0.1.9
CATEGORIES= devel rubygems
MASTER_SITES= RG
diff --git a/devel/rubygem-aws-crt/distinfo b/devel/rubygem-aws-crt/distinfo
index 9d8ffc9ef108..7f2630ee638c 100644
--- a/devel/rubygem-aws-crt/distinfo
+++ b/devel/rubygem-aws-crt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1680726246
-SHA256 (rubygem/aws-crt-0.1.8.gem) = f14a5dd5c86ffd1342bfee4b83420a1009843366c08e71e23749977a6c2a5146
-SIZE (rubygem/aws-crt-0.1.8.gem) = 52463104
+TIMESTAMP = 1698341123
+SHA256 (rubygem/aws-crt-0.1.9.gem) = 363f827cfc3030a96111c77dd23c06e8d54b1a2d2188e3e21a9b10beaced9fbf
+SIZE (rubygem/aws-crt-0.1.9.gem) = 65491456
diff --git a/devel/rubygem-aws-crt/files/patch-aws-crt-ffi-crt-s2n-CMakeLists.txt b/devel/rubygem-aws-crt/files/patch-aws-crt-ffi-crt-s2n-CMakeLists.txt
deleted file mode 100644
index d3121011d646..000000000000
--- a/devel/rubygem-aws-crt/files/patch-aws-crt-ffi-crt-s2n-CMakeLists.txt
+++ /dev/null
@@ -1,17 +0,0 @@
---- aws-crt-ffi/crt/s2n/CMakeLists.txt.orig 2022-07-30 03:57:27 UTC
-+++ aws-crt-ffi/crt/s2n/CMakeLists.txt
-@@ -460,10 +460,10 @@ if (__RESTRICT__SUPPORTED)
- target_compile_options(${PROJECT_NAME} PUBLIC -DS2N___RESTRICT__SUPPORTED)
- endif()
-
--if (MADVISE_SUPPORTED)
-- target_compile_options(${PROJECT_NAME} PUBLIC -DS2N_MADVISE_SUPPORTED)
-- message(STATUS "madvise() support detected")
--endif()
-+#if (MADVISE_SUPPORTED)
-+# target_compile_options(${PROJECT_NAME} PUBLIC -DS2N_MADVISE_SUPPORTED)
-+# message(STATUS "madvise() support detected")
-+#endif()
-
- if (MINHERIT_SUPPORTED)
- target_compile_options(${PROJECT_NAME} PUBLIC -DS2N_MINHERIT_SUPPORTED)
diff --git a/devel/rubygem-aws-crt/files/patch-powerpc64le b/devel/rubygem-aws-crt/files/patch-powerpc64le
index 407c59a12350..9cdc7c15a4c6 100644
--- a/devel/rubygem-aws-crt/files/patch-powerpc64le
+++ b/devel/rubygem-aws-crt/files/patch-powerpc64le
@@ -1,9 +1,9 @@
Reference: https://cgit.freebsd.org/ports/commit/?id=f08b67611f0b19c0ee8d9053ee4d22e09b03f2b1
---- aws-crt-ffi/crt/aws-lc/crypto/fipsmodule/cpucap/cpu_ppc64le.c.orig 2022-07-30 03:57:26 UTC
+--- aws-crt-ffi/crt/aws-lc/crypto/fipsmodule/cpucap/cpu_ppc64le.c.orig 2023-10-20 20:00:18 UTC
+++ aws-crt-ffi/crt/aws-lc/crypto/fipsmodule/cpucap/cpu_ppc64le.c
-@@ -25,7 +25,11 @@
- #endif
+@@ -27,7 +27,11 @@
+ extern uint8_t OPENSSL_cpucap_initialized;
void OPENSSL_cpuid_setup(void) {
+#if defined(__linux__)
@@ -11,6 +11,6 @@ Reference: https://cgit.freebsd.org/ports/commit/?id=f08b67611f0b19c0ee8d9053ee4
+#elif defined(__FreeBSD__)
+ elf_aux_info(AT_HWCAP2, &OPENSSL_ppc64le_hwcap2, sizeof(OPENSSL_ppc64le_hwcap2));
+#endif
+ OPENSSL_cpucap_initialized = 1;
}
- int CRYPTO_is_PPC64LE_vcrypto_capable(void) {