aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 10:18:45 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 10:50:17 +0000
commit141cd26606a2c8019966cdbb00a967db49bcb1b6 (patch)
tree02a089041f650a2c911d826adb5b77e3f852d498
parent79241e4fe74ef2377d8e7dc9589b61c570fb6346 (diff)
downloadports-141cd26606a2c8019966cdbb00a967db49bcb1b6.tar.gz
ports-141cd26606a2c8019966cdbb00a967db49bcb1b6.zip
print/ttf2pt1: Fix build with llvm16
- Utilize USES=localbase - Pet port{clippy|fmt} Sponsored by: The FreeBSD Foundation
-rw-r--r--print/ttf2pt1/Makefile42
-rw-r--r--print/ttf2pt1/files/patch-Makefile6
-rw-r--r--print/ttf2pt1/files/patch-ft.c4
3 files changed, 27 insertions, 25 deletions
diff --git a/print/ttf2pt1/Makefile b/print/ttf2pt1/Makefile
index cb80316b4b68..588b287bd063 100644
--- a/print/ttf2pt1/Makefile
+++ b/print/ttf2pt1/Makefile
@@ -14,26 +14,28 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libfreetype.so:print/freetype2
RUN_DEPENDS= t1asm:print/t1utils
-USES= pkgconfig shebangfix perl5 uidfix tar:tgz
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} ${CPPFLAGS}" LIBS="${LIBS}" \
- INSTDIR="${STAGEDIR}${PREFIX}" LIBXDIR="${STAGEDIR}${PREFIX}/bin" \
- OWNER=${BINOWN} GROUP=${BINGRP}
-SHEBANG_FILES= app/TeX/sfd2map \
- app/TeX/cjk-latex-config \
- other/showdf \
- other/showg \
- other/*.pl \
- scripts/forceiso \
- scripts/frommap \
- scripts/inst_dir \
- scripts/html2man \
- scripts/t1fdir \
- scripts/trans
-
-CPPFLAGS+= `pkg-config --cflags freetype2` \
- -I${LOCALBASE}/include -DUSE_FREETYPE
-LIBS+= `pkg-config --libs freetype2` \
- -L${LOCALBASE}/lib -lm
+USES= localbase perl5 pkgconfig shebangfix tar:tgz uidfix
+
+SHEBANG_FILES= app/TeX/cjk-latex-config app/TeX/sfd2map other/*.pl \
+ other/showdf other/showg scripts/forceiso scripts/frommap \
+ scripts/html2man scripts/inst_dir scripts/t1fdir scripts/trans
+
+MAKE_ARGS= CC="${CC}" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ GROUP=${BINGRP} \
+ INSTDIR="${STAGEDIR}${PREFIX}" \
+ LIBS="${LIBS}" \
+ LIBXDIR="${STAGEDIR}${PREFIX}/bin" \
+ OWNER=${BINOWN}
+
+CPPFLAGS+= `pkg-config --cflags freetype2` -DUSE_FREETYPE
+LIBS+= `pkg-config --libs freetype2` -lm
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ttf2pt1
diff --git a/print/ttf2pt1/files/patch-Makefile b/print/ttf2pt1/files/patch-Makefile
index 9e9c62b2b3c4..3c1cd37a83e6 100644
--- a/print/ttf2pt1/files/patch-Makefile
+++ b/print/ttf2pt1/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Sun Oct 22 23:19:32 2006
-+++ Makefile Sun Oct 22 23:19:36 2006
-@@ -243,7 +243,6 @@
+--- Makefile.orig 2002-08-30 18:03:07 UTC
++++ Makefile
+@@ -243,7 +243,6 @@ install: all
chgrp -R $(GROUP) $(SHAREDIR)
chmod -R go-w $(SHAREDIR)
scripts/inst_file ttf2pt1 $(BINDIR)/ttf2pt1 $(OWNER) $(GROUP) 0755
diff --git a/print/ttf2pt1/files/patch-ft.c b/print/ttf2pt1/files/patch-ft.c
index 80140af7a608..0eb1559a626f 100644
--- a/print/ttf2pt1/files/patch-ft.c
+++ b/print/ttf2pt1/files/patch-ft.c
@@ -1,5 +1,5 @@
---- ft.c.orig 2003-12-31 22:30:50.000000000 +0100
-+++ ft.c 2013-12-16 16:50:37.000000000 +0100
+--- ft.c.orig 2003-12-31 21:30:50 UTC
++++ ft.c
@@ -12,11 +12,12 @@
#include <stdlib.h>
#include <ctype.h>