aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-30 15:56:06 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-30 15:56:06 +0000
commit1443c051409b8984f3303cc59141572f4fae2349 (patch)
tree19f6e4d88efb0d66f11abe1ca094432189a0f785
parentea95d4a3b6b09cdb18ab16f65a34e4e124a869ef (diff)
downloadports-1443c051409b8984f3303cc59141572f4fae2349.tar.gz
ports-1443c051409b8984f3303cc59141572f4fae2349.zip
devel/py-pure-eval: Add py-pure-eval 0.2.2
pure_eval is a Python package that lets you safely evaluate certain AST nodes without triggering arbitrary code that may have unwanted side effects. WWW: https://github.com/alexmojaki/pure_eval
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pure-eval/Makefile24
-rw-r--r--devel/py-pure-eval/distinfo3
-rw-r--r--devel/py-pure-eval/pkg-descr4
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3de47f146154..0b5f382e55c8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4994,6 +4994,7 @@
SUBDIR += py-ptpython
SUBDIR += py-ptvsd
SUBDIR += py-pudb
+ SUBDIR += py-pure-eval
SUBDIR += py-purl
SUBDIR += py-py
SUBDIR += py-py-ubjson
diff --git a/devel/py-pure-eval/Makefile b/devel/py-pure-eval/Makefile
new file mode 100644
index 000000000000..9a978d455a27
--- /dev/null
+++ b/devel/py-pure-eval/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pure-eval
+PORTVERSION= 0.2.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pure_eval-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Safely evaluate AST nodes without side effects
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.3:devel/py-setuptools_scm@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0,1:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pure-eval/distinfo b/devel/py-pure-eval/distinfo
new file mode 100644
index 000000000000..dc7f95ad869d
--- /dev/null
+++ b/devel/py-pure-eval/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1651316573
+SHA256 (pure_eval-0.2.2.tar.gz) = 2b45320af6dfaa1750f543d714b6d1c520a1688dec6fd24d339063ce0aaa9ac3
+SIZE (pure_eval-0.2.2.tar.gz) = 19395
diff --git a/devel/py-pure-eval/pkg-descr b/devel/py-pure-eval/pkg-descr
new file mode 100644
index 000000000000..f8c6cb24e38a
--- /dev/null
+++ b/devel/py-pure-eval/pkg-descr
@@ -0,0 +1,4 @@
+pure_eval is a Python package that lets you safely evaluate certain AST nodes
+without triggering arbitrary code that may have unwanted side effects.
+
+WWW: https://github.com/alexmojaki/pure_eval